Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to display (Gravatar avatar) image on Firefox

more options

Hi there,

I'm building my first website. When I log in (jam-works.org/wp-admin) the very right end of the top bar in the 'dashboard' menu shows a blank, empty box where my avatar or pic or Gravatar or whatever should be ("1of2" below). The profile section from which to change this displays that same blank square with a link: "You can change your profile picture on Gravatar".

Which I've done. When I open jam-works.org/wp-admin with another browser, it displays the picture ("2of2" below), but I really don't want to use other browsers. I tried Firefox 'Options', 'Privacy & Security' and 'clear data', rebooted but no luck.

Can someone please help? I'm older than technology, so please type slowly so I can understand. Seriously. I just found out that an "Ethernet" isn't a thing to catch the Ether Bunny with, sooooo, yeah - please kinda spell it out for me if you can.

Thanks!

Attached screenshots

Chosen solution

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can check the Web Console for possible messages about blocked content.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can check the Web Console for possible messages about blocked content.

Helpful?

more options

Thank you so much! I adjusted the extensions in Firefox, refreshed my website and poof - my profile pic was where it is supposed to be. I appreciate your help - Cheers!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.