Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Links from Twitter or other websites will not display in yahoo.com news pages.

more options

When I open articles or posts on yahoo.com, Firefox will not allow the twitter or other links to be viewed on the page. I have tried with add-ons disabled and in Private mode. These can be viewed in other browsers without a problem.

Do I need to turn a feature on or off?

Attached screenshots

All Replies (4)

more options

Check the "shield" icon at the left end of the address bar. If it's a bit purplish, the Enhanced Tracking Protection feature is blocking something in the page, possibly Twitter content. You can click the shield and make an exception for Yahoo to allow tracking content to load by clicking the slider switch on the ETP drop-down.

More info on this feature: Enhanced Tracking Protection in Firefox for desktop

Helpful?

more options

Hi, turned it off, restarted Firefox and these windows are still being blocked. I also started it in Safe Mode. Still same issue. See gray area below left and clip from Bing on the right.

Modified by justin.spitzer

Helpful?

more options

Thank you for the example. On https://www.yahoo.com/lifestyle/thanksgiving-sides-macaroni-and-cheese-green-bean-casserole-145020789.html the Countdown to Thanksgiving banner is initially hidden and then a script runs which makes it visible.

Can your Firefox load the image if I embed it here:

If it is visible here but not on Yahoo, it seems that script which makes it visible is blocked or broken on your Firefox. It is difficult to guess why if it's not due to Enhanced Tracking Protection or an add-on.

The page uses scripts from yahoo.com, yahoo.net, yimg.com, and oath.com (plus numerous advertisers).

Could you check whether the DNS over HTTPS feature makes any difference? This article describes how to turn that feature on/off: Firefox DNS-over-HTTPS.

Note: this forum has a link filter, so including a non-Mozilla URL in your reply will delay its appearance while your post passes through moderation.

Helpful?

more options

Hi, I removed all my add-ons and restored them one by one. With nothing added, I can can see everything. It looks like it might be Ghostery, but when I turn it off while installed, I still don't get the images. I'll have to investigate further. Thank you for the assistance.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.