Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Changing camera/microphone permissions does not work

  • 4 replies
  • 1 has this problem
  • 52 views
  • Last reply by gdiloreto

more options

Hi folks, Firefox says I must update the camera and microphone permissions in order to use my camera. In the section entitled "Using the Firefox Options Menu to Change Camera and Microphone Permissions," Line #5 says to enter the website URL in the Search field (which I did), then Line #6 says to "Press the Enter key" (which I did) and "the website displays in the list below." However, NOTHING happens when I press "Enter." The URL does NOT appear in the list. I tested several web addresses with the same results. Any clues as to why following Firefox's instructions to-the-letter doesn't work? Your help would be appreciated.

Hi folks, Firefox says I must update the camera and microphone permissions in order to use my camera. In the section entitled "Using the Firefox Options Menu to Change Camera and Microphone Permissions," Line #5 says to enter the website URL in the Search field (which I did), then Line #6 says to "Press the Enter key" (which I did) and "the website displays in the list below." However, NOTHING happens when I press "Enter." The URL does NOT appear in the list. I tested several web addresses with the same results. Any clues as to why following Firefox's instructions to-the-letter doesn't work? Your help would be appreciated.

All Replies (4)

more options

Hi, I think that is to remove a permission that you didn't intend to grant.

To add a new permission, you can use the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Use the camera" and uncheck the "Use default" box, and then select "Always ask" or "Allow" depending on your trust for the site. Repeat with "Use the microphone."

There is a known problem where the site that wants to use the camera or microphone is embedded in a page from a different site, like Hangouts in Gmail: Firefox often doesn't allow it even if everyone has individual permission.

more options

Hi. I hope this reply finds the right person. Thank you for your prompt response with instructions. I followed them and have changed the settings as you directed. I will test it shortly. The frustrating thing is that Firefox instructions do specifically state that to add camera and/or microphone permission for a website you type the web address in the displayed search box and press "Enter" which (supposedly) adds that address to your list of permitted sites below that search box. To remove a site it tells you to simply select the appropriate address from your permissions list and click on the "Remove Website" box. So it all makes perfect sense - except it doesn't work. Being technologically-challenged, I may return for more advice or clarification after I test it, but I wanted to thank you very much for your assistance! Kind Regards, Gerry

more options

I see what you're saying. The article "How to manage your camera and microphone permissions with Firefox" implies that the search bar can be used to add to the list, not just search it. I've submitted an edit that hopefully will clarify that.

more options

Hi. Thanks for looking into it. I'm glad you found those instructions I was referring to because I'd hate to think I'm the only one confused and frustrated by them. Kind Regards, Gerry