Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The "remember passwords" feature keeps getting turned off.

  • 3 replies
  • 1 has this problem
  • 13 views
  • Last reply by cor-el

more options

I am not sure what is happening but across my devices I sync Firefox on my saved password settings keep getting tuned off. I pretty much have to turn them on every time I start Firefox and it is quite annoying. I have searched this forum some and found solutions that relate to trend micro password manager but I don't have that installed. I am running the latest version of Firefox on mac.

Chosen solution

Do you have the remember password feature enabled on all devices that are connected to this Sync account ?

The signon.rememberSignons pref that controls this feature is part of preferences that are synced and this means that on all connected devices this setting will be the same. If you do not want to include signon.rememberSignons with syncing prefs then you set set this pref to false on the about:config page.

  • services.sync.prefs.sync.signon.rememberSignons = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 0

All Replies (3)

more options

Are you running Firefox directly from the downloaded firefox.dmg file?

This is a mistake that a lot of Mac users make when installing software on their computer. If you don't move the firefox.app file from the firefox.dmg file into the Applications folder on your computer, it's not really installed on the computer.

Essentially, it's like you are running Firefox from a CD disc, which tricks Firefox into thinking that it's a new installation each time you open it. This can cause Firefox to create a new blank profile for you with the default settings and none of your data.

See How to download and install Firefox on Mac for more information.

Hope this helps.

Helpful?

more options

Thanks for the suggestion Wesley. I am running Firefox from my mac's application folder on all my devices.

Helpful?

more options

Chosen Solution

Do you have the remember password feature enabled on all devices that are connected to this Sync account ?

The signon.rememberSignons pref that controls this feature is part of preferences that are synced and this means that on all connected devices this setting will be the same. If you do not want to include signon.rememberSignons with syncing prefs then you set set this pref to false on the about:config page.

  • services.sync.prefs.sync.signon.rememberSignons = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.