Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox open link in new tab sometimes loads link in current tab as well.

  • 6 replies
  • 1 has this problem
  • 23 views
  • Last reply by annahaugen

more options

I regularly open links in a new tab to read later, especially for websites that I know will be slow to load (my internet is not great).

For the last couple of months, sometimes when I open a link in a new tab, it loads the link in the tab I'm in in addition to the new tab. If I go to the new tab immediately, wait for it to load the page completely, and then go back to the original tab to continue browsing in that tab, it's fine. If I open the link in a new tab and stay in the original tab to continue browsing further, the original tab will load the link in addition to the new tab so that the link is open in two tabs and the page I was on isn't in any tab. The back button still works, but it is INCREDIBLY annoying.

It doesn't do this on all links, but it consistently does that when I am using my Outlook email via webbrowser, and clicking on a link in the Washington Post email digest to a Washington Post article. For a while I thought it was just some weird thing in the Washington Post emails, but I have noticed it happening on other websites as well, most recently when I was on tumblr and clicked on a gofundme link.

Is this a general Firefox problem? a problem with an extension?

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Read this answer in context 👍 1

All Replies (6)

more options

Hi annahaugen, what method are you using to open the link in a new tab? For example:

  • right-click > Open Link in New Tab
  • middle-click with the mouse scroll wheel
  • Ctrl+click

I've actually listed those in increasing order of risk of encountering this problem: most sites will not navigate on right-click, but many sites may treat a Ctrl+click as a regular click.

Helpful?

more options

I use a laptop with a touchpad, and it happens both when the webpage automatically opens every link in a new tab (as with my outlook webmail) and when I right-click using the laptop touchpad.

Helpful?

more options

You can check the browser.link.open_newwindow prefs on the about:config page to see if they are default.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Helpful?

more options

cor-el said

You can check the browser.link.open_newwindow prefs on the about:config page to see if they are default.

Here are the settings for browser.link.open_newwindow:

browser.link.open_newwindow 3 browser.link.open_newwindow.disabled_in_fullscreen false browser.link.open_newwindow.override.external -1 browser.link.open_newwindow.restriction 2 services.sync.prefs.sync.browser.link.open_newwindow true

Are they what they should be? I don't see any setting marked "default"

Modified by annahaugen

Helpful?

more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

Thank you for the help. After going through all of my extensions, it appears to be WhatCampaign that's doing it. However, the weird behavior WhatCampaign is doing now is different from (but related to) what was happening before I disabled all extensions and then re-enabled them one by one. Before, it was (on some webpages, with some links) opening links in both a new tab and the current tab when it was only supposed to be opening it in a new tab. Now, having disabled and re-enabled every add-on one by one, when I have What Campaign enabled and open a link in a new tab it opens it in a new tab but not the original tab ... but it sends the original tab into an endless refresh loop. Weird. I've left a review on the extension, hope the dev figures out the problem and fixes it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.