Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

youtube videos not loading, only spinning circle || issue after latest update

  • 9 replies
  • 1 has this problem
  • Last reply by Sunil Kinra

more options

since update I can't open you tube videos, site is working & can search get previews but when click to open it don't play only try to load & keeps spinning circle on black background. Cleared cache & cookies, deleted temp files, refresh Firefox but no help. Not using any add-on other than anti virus (updated), no plug-in used. No issue with other sites only concern is you tube video not playing. However, in private window video is playing without any problem. Other browser working fine, facing this issue after latest update - 77.0.1 (64-bit). No issue before update.

Attached screenshots

All Replies (9)

more options

Hello sunil kinra,

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> General: Performance

remove checkmark: [ ] "Use recommended performance settings"

remove checkmark: [ ] "Use hardware acceleration when available"

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

I expect your problem must have been resolved if done please reply me.

Thank you!

more options

Hi sunil.kinra, glad to see you on Mozilla Support Forum.

  • Click the menu button and select Options (Windows) or Preferences (Mac, Linux).
  • Select the General panel.
  • Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
  • Uncheck Use hardware acceleration when available.
  • Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

more options

Thanks Arman Khan & Shashank Shekhar for quickly responding, I've unchecked the performance settings & hardware acceleration, restart FF but no help. My graphics driver is up to date again checked for updates just now to re confirm. I guess some issue in FF update itself. I also tried safe mode but not working.

more options

Firefox automatically uses settings that work best with your computer. You can modify these settings in your Firefox Options page. Click the menu button Fx57Menu and select Options. In the General panel, go down to the Performance section and uncheck the box next to Use recommended performance settings. You will then be able to change the following settings:

Use hardware acceleration when available: This setting allows Firefox to use your computer's graphics processor, if possible, instead of the main processor, to display graphics-heavy web content such as videos or games. This frees up resources on your computer so it can run other applications, like Firefox, faster. This box is checked by default but the feature isn't available for all graphics processors. You must restart Firefox after changing this setting, before it will take effect.

Firefox and some plugins use your graphics card to help speed up the display of web content. Graphic cards are also used by advanced web features like WebGL. To fix problems with these features or to take advantage of them, you may need to update your graphics card drivers. This article describes how to do that.

more options

Thanks Pallavi for replying but I've already changed this as advised earlier also & tried both options hardware on & off, restart FF after changing settings. Unfortunately, this is not working for me. My graphics drivers are up to date, re verified. However, all videos work fine in private window as I've updated in my original post. I don't see any issues on my side, only concern is FF update. Other browser also working fine.

more options

Hi sunil.kinra Sometimes, YouTube videos won't load in Mozilla Firefox, due to a damaged Firefox extension. To bypass the problem, proceed and reset Firefox to default settings. To do that:

1. From the Firefox menu image choose Help > Troubleshooting information. 2. Click Restart with Add-ons Disabled. 3. After Firefox restart, try to play a video on YouTube and, depending on the effect, perform the suggested action:

   Case A. If the problem is solved and you can watch videos, proceed and disable one-by-one the installed Add-ons (Extensions) until you find out which one is cause the problem.
   Case B. If you still cannot play videos on YouTube, navigate again to the "Troubleshooting information" screen and click Refresh Firefox to reset the browser to default settings.
more options

Thanks Anamika, I've tried these options already but no help. I don't have any add-on or plug-ins in my FF, start FF with add-on disabled also can't play videos, refresh FF done but no help. Again I am repeating videos are working in private window.

more options
  • If a YouTube video, Facebook game, or other media isn't working, try the steps below to fix it.

These steps can help for: A video or game that won't load A video or game that's blank A gray box that shows instead of a video or game Chrome freezes or crashes while loading a video or game

Step 1: Update Chrome Videos and games sometimes need the latest version of Chrome.

1.On your Android phone or tablet, open the Play Store app . 2.At the top left, tap Menu My apps & games. 3.Under "Updates," look for Chrome . 4.If Chrome is listed, tap Update. 5.When the update is done, go back to the site with the video or game. At the top right, tap More Reload .

more options

Thanks Pallavi, but my question wasn't related to Android phone / tablet. I just observed the issue is not in FF but from Google, somehow I am unable to play you tube videos when logged in, tried to sign out & play videos, they're playing normally. Not sure about the problem but it seems Google only can help. I also tried to play videos in other browser while logged in & same issue video not playing; sign out & play again it works. Thanks everyone here for help, hope to resolve this issue somehow.