Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

home page

  • 29 replies
  • 3 have this problem
  • 158 views
  • Last reply by sirgknight

more options

firefox icon does not open my home page

All Replies (9)

more options

@jscher2000

Ive been having the same issue except I use Gmail, not Yahoo. Setting Gmail as the homepage loads a blank white screen also. https://mail.google.com/mail/u/0/#inbox If I set Google as the home page, it does the same thing also. www.yahoo.com also does not work. The hack mentioned above of typing yahoo.com only in the New Windows and Tabs option does work.

Clearing Cache files does not help. Unchecking security options in About: does not work as one of the FF guys suggested. I uninstalled and reinstalled the direct Windows 64bit version from the downloads page (as was suggested on another thread here), it worked for the first time then blank after that.

This didn't happen in version 77.0.0 and Ive reinstalled that version to confirm. But IF I install 77.0.1, it starts all over again.

Modified by gumper

Helpful?

more options

Hi sirgknight, glad to see you on Mozilla Support Forum.

   Click on menu icon.
   Click on Options.
   In left pane, you will find home menu.
   In this menu, you will find an option New Windows and Tabs.
   In this option choose Firefox Home(Default) from dropdown menu named Homepage and New Windows. 

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Helpful?

more options

See: "3-bar" menu button -> Options/Preferences -> Advanced -> General: Accessibility remove checkmark: [ ] "Warn me when web sites try to redirect or reload the page" The setting in "Options/Preferences -> Advanced -> General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting. See also: https://support.mozilla.org/en-US/kb/settings-network-updates-and-encryption#w_general-tab http://kb.mozillazine.org/Accessibility_features_of_Firefox

Helpful?

more options

Hello again! Is it because your default search engine is Yahoo? If so click the menu bar, then options(or preferences sometimes) once there, click search on the side. Change your defualt search engine to what you want it to be.

Helpful?

more options

Very interesting

Helpful?

more options

Could be a problem with your connection setting or DNS service that is used. Firefox 77.0.1 was released to address an issue with overloading third-party DNS services due to TRR (DNS over HTTPS) being enabled.


You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

more options

Thanks @cor-el

Im my case setting No Proxy did not work unfortunately.

Helpful?

more options

sirgknight said

Well I finally discovered the fix......in the custom url box I was entering "www.yahoo.com" and this didn't work. Just by chance I entered "yahoo.com" and whallla! IT WORKS. Now when I click on the firefox icon it goes directly to my yahoo home page....crazy.

This resolved the issue for me, too. Firefox 77.0.1 64-bit Linux Mint 19.3, which the OS was installed just yesterday on a new hard drive. Nothing fixed the blank page at opening issue until I came across the above.

-- Mike

Helpful?

more options

I have no idea what led me to try dropping the www, maybe my guardian angel. Glad it works for others also.

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.