Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My local domains are giving search results after upgrading to firefox 77?

more options

I have a DNS resolver running on my router, and I had reports from users on my network that after upgrading to nightly 77 they were no longer able to access any intranet domains, I have tested this as well and it would appear that all intranet domains are trying to do search results, this is causing issues as clients(whom I do not own or control their computer) need to access my captive portal prior to gaining internet access and their search fails.

Chosen solution

I forgot to mention, there is a "whitelist" option for your frequent visitors who don't use autofill or clear their history:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name, e.g.,

  • browser.fixup.domainwhitelist.gateway
  • browser.fixup.domainwhitelist.hello.local

If this preference was already created and shows a value of true or false, skip to step (4).

(3) On the bar with the preference name, keep the selection next to Boolean and click the + button to add the preference. Then Firefox should display the new value.

<center></center>

(4) If the value is true, you're done; if it's false, double-click to toggle the value to true.

More info on about:config: Configuration Editor for Firefox.

Read this answer in context 👍 0

All Replies (8)

more options

Is DNS over HTTPS turned on?

See Firefox DNS-over-HTTPS.

more options

What kind of domain is it? For example:

  • gateway
  • hello.local

If a domain does not have a standard Top Level Domain, Firefox Nightly will send it to search. Here are two workarounds, but yes, they are an extra step for the end-user:

(A) Use the protocol, for example:

  • http://gateway
  • https://hello.local

(B) Add a second dot after the TLD, when applicable, for example

  • https://hello.local.
more options

Chosen Solution

I forgot to mention, there is a "whitelist" option for your frequent visitors who don't use autofill or clear their history:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name, e.g.,

  • browser.fixup.domainwhitelist.gateway
  • browser.fixup.domainwhitelist.hello.local

If this preference was already created and shows a value of true or false, skip to step (4).

(3) On the bar with the preference name, keep the selection next to Boolean and click the + button to add the preference. Then Firefox should display the new value.

<center></center>

(4) If the value is true, you're done; if it's false, double-click to toggle the value to true.

More info on about:config: Configuration Editor for Firefox.

more options

My Captive Portal and All my intranet domains are using the standard .libre tld, as my network is part of the OPENNIC system.

I don't think I would trust my users to even do half of those things with any level of success if this gets pushed out to the stable version of firefox.

Modified by zachary_daltorio

more options

Do the users get the Infobar prompt from the background DNS check, or is that only available when the search is successful? I'm attaching a screenshot showing what I mean.

more options

From Testing clients who have been on the network prior are getting the popup but those who are new users are not, and are just getting an error page.

All are getting a network login page so it is detecting a captive portal is present.

Modified by zachary_daltorio

more options

zachary_daltorio said

From Testing clients who have been on the network prior are getting the popup but those who are new users are not, and are just getting an error page.

Is it something along the lines of a security error that the certificate doesn't match the domain, the type of thing you might generally expect for an https request intercepted by a captive portal? That certainly makes everything more complicated.

more options

It is a self-signed cert via pfsense, I did have to notified users to add an exemption for the captive portal but it has worked fine for firefox 75.