Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Tab content is missing

more options

I have a problem with Firefox New Tab content. As far as I am concerned there should be Firefox logo, search bar and my most popular sites. But only search bar is visible. I have checked the Popular checkbox under settings, but nothing seems to be working. Attached is a screenshot how it looks like. I tried restoring settings to default ones, but to no avail. Any tips here?

Attached screenshots

All Replies (4)

more options

Try changing the toolkit.legacyUserProfileCustomizations.stylesheets preference on the about:config page to false. Then restart Firefox and see if that fixes the issue. Once you're done testing to see if the issue is still there, you can change the setting back if you want.

If the issue goes away, that means there's either a userChrome.css or userContent.css file in your Firefox profile modifying the appearance of Firefox. That's the likely culprit.

If the issue is still there, I'd recommend trying Firefox in Safe Mode to see if there's an add-on that's blocking or modifying part of the Firefox page.

If none of that helps, a clean reinstall will likely fix the problem. It could just be that a file is damaged or missing in your Firefox installation, so reinstalling will replace any damaged or missing files. More information about reinstalling Firefox can be found here.

Hope this helps.

Helpful?

more options

You normally only see the Firefox logo on the Firefox Home page in case only the search bar is selected in the "Options/Preferences -> Home" settings. I see the cogwheel (settings) button and the search bar in your screenshot. If you have more items apart from search selected then you won't get the logo (you can test this by only selecting search). If more items are selected, but you do not see them then maybe try to purge the startup caches.

Try to start Firefox once with the -purgecaches command line switch to refresh the startup caches. Make sure that Firefox is closed via "Firefox -> Exit/Quit Firefox".


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

Thanks to both of you, gents. I ended up reinstalling Firefox and this seemed to fix the issue.

Helpful?

more options

Hi, your problem is probably caused by an extension, theme, or hardware acceleration.To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.Try with the help of this link -https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Thank You.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.