Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable "Search with Google", browser.urlbar.unifiedcomplete False no longer working

  • 1 reply
  • 1 has this problem
  • 17 views
  • Last reply by jscher2000

more options

I would like to totally get rid of the blue bar that pops up under the address bar. Previously, setting browser.urlbar.unifiedcomplete to False did the trick. I found that solution in this article https://www.askvg.com/tip-remove-search-with-google-and-visit-website-options-from-firefox-addressbar-results/ Now on Firefox 75 I realized it's not working. The blue bar shows up if doing a search, using a URL shortcut (alias) or doing a quick search. It's add no value to me and is just clutter. I've been using Firefox since it's release in the early 2000s and the plain jane address/search bar has always worked for me. How can I get rid of the blue bar?

Attached screenshots

All Replies (1)

more options

Hi droidekas, the blue bar is simply explanatory: it tells you what Firefox will do if you press Enter or click the Go button at this moment. I understand when you say that experienced users don't need this information.

There hasn't been a browser.urlbar.unifiedcomplete preference since Firefox 47, so perhaps you were using a custom style rule in a userChrome.css file to hide that top row of the drop-down in recent years?

I know I provided code for that in the past, but the new bar design in Firefox 75 may have obsoleted it. I think this might be the update to remove the top row, but I haven't tested for a while:

  #urlbar-results .urlbarView-row:first-of-type {
    display:none !important;
  }