Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I turn on the mic for a video call in Messenger? I've gone through preferences/microphone/settings and nothing changed.

  • 2 replies
  • 1 has this problem
  • 4 views
  • Last reply by philip22

more options

I'm trying to video call on FB Messenger. It keeps error messaging me, telling me to allow microphone access. Tried that through the Firefox menu preferences - can't make that work. Tried it through the apple preferences/Privacy & Security - can't make that work. Completely stymied. Nothing online seems to specifically address the issue. Any thoughts welcome.

Chosen solution

Hi philip22, could you check the Site Permissions in the Page Info dialog? To call that up, either:

  • (menu bar) Tools > Page Info
  • right-click a blank area of the page > View Page Info

Along the top of the dialog, click the icon for Permissions.

Then scroll down to "Use the microphone" at the bottom, uncheck the "Use default" box and click Allow.

You may need to reload the Messenger page to trigger it to check again.

Does that work?

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hi philip22, could you check the Site Permissions in the Page Info dialog? To call that up, either:

  • (menu bar) Tools > Page Info
  • right-click a blank area of the page > View Page Info

Along the top of the dialog, click the icon for Permissions.

Then scroll down to "Use the microphone" at the bottom, uncheck the "Use default" box and click Allow.

You may need to reload the Messenger page to trigger it to check again.

Does that work?

more options

Thank you - I had tried that, but trying it again made me realise that I had to do the same for the camera! Obvious in hindsight. Thanks for your help.