X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Hi, Everytime I change the Default Search Engine for Google, it is always change again as default by Tapufind, even the homepage. Ineed help

m_2
Posted

I need that Firefox respect the search engine I have decided. I don´t like Tapufind!

I need that Firefox respect the search engine I have decided. I don´t like Tapufind!

Chosen solution

m_2 said

I need that Firefox respect the search engine I have decided. I don´t like Tapufind!

Hello m_2,

Please, don't blame Firefox - unfortunately you seem to have picked up some malware, cause TapuFind is a browser hijacker ....

See : https://www.pcrisk.com/removal-guides/14248-search-tapufind-com-redirect-mac

Go to the Firefox menu (≡) => Preferences => Add-ons => Extensions and remove anything that looks unfamiliar or suspicious.

Next step : run malwarescans - further information can be found in this article :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. They all work differently - what one program doesn't pick up, the other might.

Especially for Mac : https://www.malwarebytes.com/mac/

Read this answer in context 3
Quote
GiraffeKey 1 solutions 3 answers

When does it change back? Is it when re-downloading Firefox, or does your current installation of Firefox not save your choice?

When does it change back? Is it when re-downloading Firefox, or does your current installation of Firefox not save your choice?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
625 solutions 6000 answers

Chosen Solution

m_2 said

I need that Firefox respect the search engine I have decided. I don´t like Tapufind!

Hello m_2,

Please, don't blame Firefox - unfortunately you seem to have picked up some malware, cause TapuFind is a browser hijacker ....

See : https://www.pcrisk.com/removal-guides/14248-search-tapufind-com-redirect-mac

Go to the Firefox menu (≡) => Preferences => Add-ons => Extensions and remove anything that looks unfamiliar or suspicious.

Next step : run malwarescans - further information can be found in this article :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. They all work differently - what one program doesn't pick up, the other might.

Especially for Mac : https://www.malwarebytes.com/mac/

''m_2 [[#question-1279998|said]]'' <blockquote> I need that Firefox respect the search engine I have decided. I don´t like Tapufind! </blockquote> Hello m_2, Please, don't blame Firefox - unfortunately you seem to have picked up some malware, cause TapuFind is a browser hijacker .... See : https://www.pcrisk.com/removal-guides/14248-search-tapufind-com-redirect-mac Go to the Firefox menu (≡) => Preferences => Add-ons => Extensions and remove anything that looks unfamiliar or suspicious. Next step : run malwarescans - further information can be found in this article : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no '''Run most or all of the listed malware scanners'''. They all work differently - what one program doesn't pick up, the other might. Especially for Mac : https://www.malwarebytes.com/mac/
Was this helpful to you? 3
Quote

Helpful Reply

Yes, Thank you very much for your help!

Yes, Thank you very much for your help!
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
625 solutions 6000 answers

m_2 said

Yes, Thank you very much for your help!

My pleasure - I'm glad that you got rid of that nuisance !

You inadvertently marked your own post as Chosen Solution ....

You can rectify it by clicking on the "Undo" button to the right of your post, and then mark my (first) post by clicking on the "Solved the problem" button to the right.

Thank you in advance !

''m_2 [[#answer-1291192|said]]'' <blockquote> Yes, Thank you very much for your help! </blockquote> My pleasure - I'm glad that you got rid of that nuisance ! You inadvertently marked your own post as Chosen Solution .... You can rectify it by clicking on the "Undo" button to the right of your post, and then mark my (first) post by clicking on the "Solved the problem" button to the right. Thank you in advance !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.