Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

If I start Firefox by clicking a link in another application or operating system a window without Menu Bar items is opened

  • 5 replies
  • 6 have this problem
  • 43 views
  • Last reply by J.

more options

As stated in the title, everytime when I open a link in the operating system (i.e. clicking on a link in an email or opening a website with Alfred) while Firefox is not already running, the following happens:

1. Two Firefox windows are opened 2. One window opens the requested website (https://startpage.com in the Screenshots) but has no context items in the Menu Bar above. 3. The second opens at Home and has the items in the Menu Bar.

I am using Mac OS Catalina (multiple versions) and the issue persisted a complete reinstall (I wiped my hard drive and did a clean install) of the operating system. I tried mainstream Firefox 73.0 and Firefox Dev Edition latest beta 74.0b2. (Used `brew cask` to install) Also I do have another Mac on High Sierra that does not have this issue.

Attached screenshots

Chosen solution

This is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 👍 1

All Replies (5)

more options

Start Firefox in Safe Mode first {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Then try using a link. Is the problem still there?

more options

Chosen Solution

This is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Hello How long should be WAIT until this BUG is fixed by Firefox? [[Bug 1603956|https://bugzilla.mozilla.org/show_bug.cgi?id=1603956]] Regards Phil

more options

https://bugzilla.mozilla.org/show_bug.cgi?id=1612653#c36 Verified - fixed on Firefox RC 74.0

more options

This bug still persists. On the aforementioned bug 1603956 the tracking flags end with firefox 76 fix optional. I am on beta 78.0b4 and the bug remains.