X
Tap here to go to the mobile version of the site.

Support Forum

How can I keep Whatsapp.web connected even when I close Firefox?

Posted

I am using the currect version of FF, 71 or 70. something, not sure but I just updated. I use Whatsapp.web to chat when on my PC. I have no trouble connecting to Whatsapp.web using my Iphone and Firefox. However, EVERY time that FF closes, for a restart, or simply when I make a mistake and accidentally close the browser, the connection to Whatsapp.web is apparently broken. I say apparently because on the Iphone, it sontinues to list Windows 10 as an active device using the web app. When I used Microsoft Edge, once I scanned the QR code and connected, I would STAY connected, even overnight after I had shut down the PC. I am wondering if there are certain privacy or security settings which are preventing Whatsapp from staying connected when the FF browser closes. I also remember that a couple of years ago, when I was using FF in the 40s versions, maybe, Whatsapp also stayed connected. Just a note: the reason this is sort of a problem for me is that I am blind, and I use certain visual accessibility settings on Windows and FF that do not allow the Whatsapp QR to be scanned; so I have to change the entirevisual setting of my PC, scan the code, then restore the entire visual setting. Any ideas how to keep Whatsapp.web connected always, or at least as long as I don't end my Windows session?

I am using the currect version of FF, 71 or 70. something, not sure but I just updated. I use Whatsapp.web to chat when on my PC. I have no trouble connecting to Whatsapp.web using my Iphone and Firefox. However, EVERY time that FF closes, for a restart, or simply when I make a mistake and accidentally close the browser, the connection to Whatsapp.web is apparently broken. I say apparently because on the Iphone, it sontinues to list Windows 10 as an active device using the web app. When I used Microsoft Edge, once I scanned the QR code and connected, I would STAY connected, even overnight after I had shut down the PC. I am wondering if there are certain privacy or security settings which are preventing Whatsapp from staying connected when the FF browser closes. I also remember that a couple of years ago, when I was using FF in the 40s versions, maybe, Whatsapp also stayed connected. Just a note: the reason this is sort of a problem for me is that I am blind, and I use certain visual accessibility settings on Windows and FF that do not allow the Whatsapp QR to be scanned; so I have to change the entirevisual setting of my PC, scan the code, then restore the entire visual setting. Any ideas how to keep Whatsapp.web connected always, or at least as long as I don't end my Windows session?
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

crankygoat
  • Top 25 Contributor
40 solutions 471 answers

If Firefox is deleting cookies and site data when it closes, you will be logged out of any site. This will also happen if any third-party cleaning software is set to delete cookies.

In the Firefox Preferences, ensure cookies and site data are not set to delete when Firefox closes.

You can use this URI in the address bar - about:preferences#privacy or navigate from the Firefox menu and select the Preferences entry, and select the Privacy & Security page from the column on the left.

1) In the Cookies and Site Data section, ensure the tick box for Delete cookies and site data when Firefox is closed is empty.

2) In the History section further down the page, if Use custom settings for history is selected, and Clear history when Firefox closes is also selected, then ensure that the settings for this do not include Cookies, Active Logins, and Site Data.

If Firefox is deleting cookies and site data when it closes, you will be logged out of any site. This will also happen if any third-party cleaning software is set to delete cookies. In the Firefox Preferences, ensure cookies and site data are not set to delete when Firefox closes. You can use this URI in the address bar - '''about:preferences#privacy''' or navigate from the Firefox menu and select the Preferences entry, and select the Privacy & Security page from the column on the left. 1) In the Cookies and Site Data section, ensure the tick box for '''Delete cookies and site data when Firefox is closed''' is empty. 2) In the History section further down the page, if '''Use custom settings for history''' is selected, and '''Clear history when Firefox closes''' is also selected, then ensure that the settings for this do not include Cookies, Active Logins, and Site Data.
Was this helpful to you? 0
Quote

Question owner

Sorry, I checked both settings, and they were correct. Well, I have FF set to remember history, so the second setting was not necessary. I also looked at the Check Data page, but I could not understand it, so I left it alone. By the way, yes, I have the Keep me signed in button checked on the whatsapp.web page!

Sorry, I checked both settings, and they were correct. Well, I have FF set to remember history, so the second setting was not necessary. I also looked at the Check Data page, but I could not understand it, so I left it alone. By the way, yes, I have the Keep me signed in button checked on the whatsapp.web page!
Was this helpful to you?
Quote
crankygoat
  • Top 25 Contributor
40 solutions 471 answers

I have been looking into this on and off all day. This used to be a generically bigger problem, but i don't see much recently, especially since whatsapp was allowed to connect to more devices, and device support got better. I don't see much of anything in the whatsapp web documentation, either.

When it disconnects, do you receive an error message such as "Phone not connected" , "Computer not connected", or is it simply not connected any longer without mention?

McCoy, another volunteer here, suggested perhaps if you have Firefox remember your session, this would help. In your Menu → Options, there is a checkbox for Restore Previous Session right at the top in the Startup section.

If nothing else is helping, maybe installing and using the whatsapp desktop app and escape the frustrating issue for now: https://www.whatsapp.com/download/

I have been looking into this on and off all day. This used to be a generically bigger problem, but i don't see much recently, especially since whatsapp was allowed to connect to more devices, and device support got better. I don't see much of anything in the whatsapp web documentation, either. When it disconnects, do you receive an error message such as "Phone not connected" , "Computer not connected", or is it simply not connected any longer without mention? McCoy, another volunteer here, suggested perhaps if you have Firefox remember your session, this would help. In your Menu → Options, there is a checkbox for Restore Previous Session right at the top in the Startup section. If nothing else is helping, maybe installing and using the whatsapp desktop app and escape the frustrating issue for now: https://www.whatsapp.com/download/
Was this helpful to you?
Quote

Question owner

Thank you for your hard w3ork! No, the web.whatsapp page simply reverts to the sign-in screen, as if I had not just been connected. Curiously, on my Iphone, the Whatsapp app shows that there is still an active session, although it identifies it as Windows, and not Firefox. Yes, I tried reopening FF with the previous session recovered, but that did not help. As for the Whatsapp desktop app, sigh, like so many other such apps, it does not play nice with the TTS software. Again, I do not want to be a whiner. I have the workaround on FF, clunky as it is, and I can also just open Edge, connect to web.whatsapp, and use that for my messagin while otherwise browsing with FF.

Thank you for your hard w3ork! No, the web.whatsapp page simply reverts to the sign-in screen, as if I had not just been connected. Curiously, on my Iphone, the Whatsapp app shows that there is still an active session, although it identifies it as Windows, and not Firefox. Yes, I tried reopening FF with the previous session recovered, but that did not help. As for the Whatsapp desktop app, sigh, like so many other such apps, it does not play nice with the TTS software. Again, I do not want to be a whiner. I have the workaround on FF, clunky as it is, and I can also just open Edge, connect to web.whatsapp, and use that for my messagin while otherwise browsing with FF.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17759 solutions 160617 answers

Did you try to create a cookie allow exception for the Whatsapp website ?

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Permissions"
Did you try to create a cookie allow exception for the Whatsapp website ? *Options/Preferences -> Privacy & Security<br>Cookies and Site Data: "Manage Permissions"
Was this helpful to you? 0
Quote

Question owner

What a great idea! Sadly, I just tried it, and no, it made no difference. Thanks anyway.

What a great idea! Sadly, I just tried it, and no, it made no difference. Thanks anyway.
Was this helpful to you?
Quote
crankygoat
  • Top 25 Contributor
40 solutions 471 answers

Helpful Reply

I hope this works better in the future. Best wishes.

I hope this works better in the future. Best wishes.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.