Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video playback issues

  • 6 replies
  • 1 has this problem
  • 8 views
  • Last reply by Marc7

more options

I am currently having issues with Youtube, Netflix, and vrv.co, all video streaming sites over on Firefox, though only in full screen mode, and only on those particular video streaming sites, and I don't know why. As everything else works perfectly fine on my computer otherwise. Though curiously, running the browser in safe mode seems to remove those issues. However, I suspect this is some kind of glitch in the browser. Strangely, safe mode removes the issue, but again, not sure why. I did check another browser— Namely Waterfox Classic. That worked fine. And so far the only suggestion anyone has had from the tech service that I have on the machine has made that makes sense is that this might be a video driver issue. I did just recently update my drivers, this is true. However the issue did not start up until a few days after this had occurred. I tried reinstalling the driver to see if that would fix the issue. The issue itself is very weird. It seems like the first third of the top of the screen is suffering from some kind of distortion that looks somewhere between pixelation and screen tearing, while the rest of the video usually plays normally. What's weirder is that this isn't consistent. Sometimes it will occur near the bottom third of the screen, and sometimes it won't happen at all. The only things so far consistent is that a) it happens only in full screen, and b) it only occurs to me when I'm in the browser on those sites. Nothing text based (i.e. Fanfiction.net) has this occur, nor does it occur on my games that are on my system via steam. Even weirder, having a secondary monitor attached causes the playback issue to vanish, as does having a remote repair attempted on it—which I did try to do when this first started— only to return again when the remote connection is shut down or the external monitor is unplugged from the laptop.

Again, Waterfox does not seem to have this issue. At first it was suggested to me on another thread that the issue might be because Waterfox Classic doesn't use hardware acceleration, so I turned that off on Firefox. Which does allow things to play more or less okay, though at times when I scroll, it seems to mess with the screen in a similar fashion to the initial playback issues, and again, it's not consistent with that, just like it's not consistent with the video playback when the browser's Hardware acceleration is on.

However, I just learned that Waterfox Classic /does/ use hardware acceleration, though it seems to have a much lower content limit set by default. This makes me think that whatever is going on may be a glitch in Firefox itself that may have somehow come up. Though how and why I have no earthly clue, as prior to last Monday there was no issue, as I said earlier. More unusually sometimes the effect vanishes on videos where it's shown up.

I have tried to screenhot this and it /never/ appears in screenshots, and doesn't show up when paused either. I've even tried to take a picture of it with my phone or record it with said. Also no luck. I /have/ however, been able to find a video that does this affect deliberately, so I can at least present it here. Again, this is not consistent, seems to move around the screen, and only seems to occur on those three video sites as I stated. Apparently whatever the issue is, it's /NOT/ something to do with the hardware acceleration, as I learned, again, that WaterfoxClassic /does/ use it and it is active in that browser, and was active when I first tried it, so that narrows it down to some kind of glitch either with Firefox or Windows and how it interacts with either the former or the latter, depending on where the glitch is coming from.

Does anyone have any idea what's causing this?

The image attached is an example of what I'm seeing, however, bear in mind that this video is /deliberately/ showing this effect in an attempt to replicate the type of thing one might see on old video tapes being played after years of disuse, but it /is/ the same general appearance, more or less, of what I occasionally see on Firefox when using the videos on the above mentioned sites.

Attached screenshots

All Replies (6)

more options

Waterfox is not a good diagnostic comparison for... anything. Completely different animal now. :D

If Safe Mode resolves the issue, but turning off hardware acceleration does not, it is likely an extension or one of the other undefined settings that Safe Mode changes.

Not sure how Webroot works, but blocking something with NoScript or ABP which makes the sites unhappy can cause an issue (sometimes intentionally). You can try disabling extensions to see if that has an effect. If so, you can find out which one, then check it's settings.

Clearing cookies, site data, and the browser cache can also help if something was cached with non-optimal settings, causing it to persist.

One setting in the about:config page may be involved. media.media-capabilities.enabled https://support.mozilla.org/en-US/questions/1268819#answer-1251997

There are many prefs related to media, H264, and more in the about:config page. You might try searching these and set back to its default state any which has changed, one at a time. If there is a ↶ at the end of the pref line, it has been modified and clicking this will revert the modification.

more options

crankygoat said

Waterfox is not a good diagnostic comparison for... anything. Completely different animal now. :D If Safe Mode resolves the issue, but turning off hardware acceleration does not, it is likely an extension or one of the other undefined settings that Safe Mode changes. Not sure how Webroot works, but blocking something with NoScript or ABP which makes the sites unhappy can cause an issue (sometimes intentionally). You can try disabling extensions to see if that has an effect. If so, you can find out which one, then check it's settings. Clearing cookies, site data, and the browser cache can also help if something was cached with non-optimal settings, causing it to persist. One setting in the about:config page may be involved. media.media-capabilities.enabled https://support.mozilla.org/en-US/questions/1268819#answer-1251997 There are many prefs related to media, H264, and more in the about:config page. You might try searching these and set back to its default state any which has changed, one at a time. If there is a ↶ at the end of the pref line, it has been modified and clicking this will revert the modification.

I think you misunderstood what I was saying. Turning off Hardware acceleration /does/ fix the video playback issue. I'm just not sure why it did. I did try turning off the webroot extension. Didn't help. I tried turning off the others. Also didn't help. And yes I did shut down and restart the browser each time. But I will try your other idea and see what comes up. Because again, when hardware acceleration is on, at least on Firefox, that distortion effect is not consistent at all.

more options

Ok, I tried that, and it does not seem to have worked. I did notice a bunch of things were listed as having been modified and reverted them, but that didn't seem to help either. However, once again, turning hardware acceleration off in the browser does fix the video playback issue, but I don't know why. It also means I face a similar issue when scrolling— though again much like with the video playback this is entirely inconsistent, but that may just be the price of having video working without using a different browser. And again, last week it was perfectly fine. Though to be fair, I believe I was on either version 71 or 72 of Firefox rather than 72.0.1 at that time, as I did an update to 72.0.1 a few days before this glitch started up. Reinstalling 72.0.1 didn't help the issue either. Though I'm not sure if that's because it just dropped it into the same profile thing that Firefox now has or what.

Come to think of it, I'm not even sure how that works or how to switch profiles in Firefox.

Not sure what caused the glitch to begin with, and not sure how to fix it other than to just leave hardware acceleration off until the next browser update and pray that that fixes the issue. If anyone has any ideas, I'm open to suggestions.

more options

Incidentally, what is media.media-capabilites.screen.enabled?

more options

media.media-capabilites.screen.enabled -- I am not an expert on the Web APIs for media or anything else, but my guess is whether or not what capabilities the display reports are used along with other factors (the ability to decode the input, etc.) to determine what format video to send. I would think it is not so reliably implemented yet that turning it off might help in some edge cases. (The whole Web API is constantly undergoing construction itself, as far as i know.)

Yeah, I'm sorry i misunderstood your comments regarding the hardware acceleration. Sometimes it is best to leave it off when it does not work properly in a given application, so some applications have a setting for it somewhere, if autodetection is iffy or it just may not work well. (Similarly one might choose DirectX or OpenGL for certain things on a system and in a program where they are both options, where one just may work out better.)

more options

crankygoat said

media.media-capabilites.screen.enabled -- I am not an expert on the Web APIs for media or anything else, but my guess is whether or not what capabilities the display reports are used along with other factors (the ability to decode the input, etc.) to determine what format video to send. I would think it is not so reliably implemented yet that turning it off might help in some edge cases. (The whole Web API is constantly undergoing construction itself, as far as i know.) Yeah, I'm sorry i misunderstood your comments regarding the hardware acceleration. Sometimes it is best to leave it off when it does not work properly in a given application, so some applications have a setting for it somewhere, if autodetection is iffy or it just may not work well. (Similarly one might choose DirectX or OpenGL for certain things on a system and in a program where they are both options, where one just may work out better.)

No worries. We learned that turning off the hardware acceleration seemed to be the best option when I brought the issue up in another thread, one related to Waterfox when I ended up getting sent to this help forum when I clicked on Waterfox Help after downloading Waterfox Classic. Not sure what actually makes it 'classic' compared to whatever is regular Waterfox. But yeah, someone had suggested turning off the extensions one at a time, and seeing if any of them was the cause of the issue. Now unless I did it wrong, as I would turn one off, restart the browser, and if nothing had changed, I would turn that back on and repeat the process with the other two, none of the extensions seem to be the problem. I was even able to test adblock plus on Waterfox Classic, and that clearly was not the issue.No script didn't have a counterpart that worked on it, and my Webroot filtering extension doesn't even come up on the thing. Plus, none of those had ever been a problem on Firefox up until last Monday at around 8 or 9 pm eastern standard time. Prior to that, everything had worked fine. I had updated Firefox to version 72.0.1 just a few days before, and also updated my graphics card's drivers, and the day after, I had just put through the latest optional update to Windows 10. So at least we can rule the latter out as the problem.

Like I said, I have little idea what even caused the issue to begin with.

Oh, if it helps, my video card is the Nvidia GeForce GTX 965m.