Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF spellchecker dictionary periodically randomly switches to Australian

more options

Firefox 70.0.1 on Mint Linux 19.2, though this has been going on for several months now with older versions of FF:

Periodically, at unpredictable intervals, Firefox reverts my choice of spellcheck dictionary (English US) to English Australian. In the FF Preferences i don't even have Australian as an option: i have only UK, US, and Canada. Nonetheless, now and then, FF will start marking the word "color" as misspelled, at which point i know that the dictionary has once again been swapped out. Right-clicking the misspelled word and selecting "Languages..." reveals that Australian is always, without exception, the one it's been switched to.

My system-wide language is US English. Nothing, on any of my systems, is configured to use Australian, so FF making this particular choice of dictionaries completely befuddles me.

The "troubleshooting information" which was automatically attached to this post confirms that i don't have Australian English activated in FF.

How do i keep FF from randomly switching dictionaries on me?

Modified by Stephan Beal

All Replies (9)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

more options

i don't use any "helper" software which protects my system from me - those are Windows-isms, and this is Linux.

i explicitly set my spellchecker.dictionary to en_US the last time this happened to me (2-3 weeks ago), thinking that would resolve it. It's still set to that value.

layout.spellcheckDefault is set 1 (unmodified).

more options

Some Linux distro provided builds of Firefox can come with a long list of additional Dictionaries and Language Packs packages. You could try and uninstall what you do not need in the package manager.

The en-US locale of Firefox from www.mozilla.org/firefox/all/ only comes with the en-US dictionary for example.

Modified by James

more options

You can check these locations for globally installed dictionaries:

/usr/share/hunspell/
/usr/share/myspell/
more options

Mint Linux has apparently inexplicably installed a dozen or more language packs, including Australian English, but that doesn't tell me (A) why FF would switch dictionaries on me at random times and (B) why the one FF switches to isn't in the list of dictionaries it offers me in the preferences screen (that list only includes US, UK, and CA).

more options

Language packs (about:addons -> Languages) have nothing to do with dictionaries (about:addons -> Dictionaries).

See also "Language and Appearance":

more options

According to the "Languages" tool in Mint Linux, only 3 languages are installed: en_US, en_UK and de_DE (which is okay - i live in Germany). That information conflicts with the much larger pile of dictionary files under /usr/share/hunspell/.

i can do "apt remove hunspell-en-au", but that doesn't explain (nor excuse) FF's random dictionary-swapping behaviour.

more options

cor-el said

Language packs (about:addons -> Languages) have nothing to do with dictionaries (about:addons -> Dictionaries).

about:addons -> Dictionaries says i *only* have US English installed.

more options

Firefox just did it again - randomly swapped the spellchecker to Australian English. It seems unlikely that it's a coincidence that Australian is the first variant of English which appears in the spellcheck language selection list.

Update: the way i noticed is because *everything* in text fields suddenly got a red squiggly line under it... because i uninstalled the en_AU dictionary yesterday, hoping it would stop this behaviour from happening.

Modified by Stephan Beal