Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is reCAPTCHA not working on eBay login verification?

more options

I'm trying to log into eBay using FF 52.9 ESR, the last version that works on my old XP PC. It's always worked in the past, but now it's saying that I have to verify myself for security using a reCAPTCHA. After going through the interminable selection of pictures of buses, bridges and hydrants, it seems to work, but then this pops up -

"To display this page, Firefox must send information that will repeat any action (such as a search or order confirmation) that was performed earlier."

If I click to re-send, all that happens is that the reCAPTCHA page comes up again, and I have to restart the whole thing. If I click to cancel, nothing happens. Any idea what's going wrong here? I've tried several times with the same result, and basically I can't now log into eBay! Thanks, Dave.

All Replies (11)

more options

Did you take a look at the browser console? Maybe ebay itself requires some feature to work with recaptcha that may not work in your version, or the site has some other issue. If so, it should show up in the console.

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection

https://support.mozilla.org/en-US/kb/content-blocking

more options

Thanks guys! The problem is the same in safe mode. Firefox 52 ESR does not have the Tracking Protection feature, it was added in later versions. I'm getting this in the browser console -

onMessage : Object { type: "get_rapport_headers", requestId: "282", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "290", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "292", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "294", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "296", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "297", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "299", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "301", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "303", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "305", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "308", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "309", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "311", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "313", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "314", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "316", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "318", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "320", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "322", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "324", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "326", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "327", tabId: "2", data: "" } worker.js:22:3 2128506|329|is_url_blacklisted|2|https://signin.ebay.co.uk/distil_identify_cookie.html?httpReferrer=%2Fws%2FeBayISAPI.dll%3FSignIn%26UsingSSL%3D1%26pUserId%3D%26co_partnerId%3D2%26siteid%3D3%26ru%3Dhttps%253A%252F%252Fmy.ebay.co.uk%252Fws%252FeBayISAPI.dll%253FMyEbayBeta%2526MyeBay%253D%2526migrateVisitor%253D3%2526CurrentPage%253DMyeBaySummary%2526guest%253D1%26pageType%3D3984 worker.js:142:2 onMessage : Object { type: "tab_selected", requestId: "-1", tabId: "2", data: "false,signin.ebay.co.uk,false" } worker.js:22:3 onMessage : Object { type: "is_url_blacklisted", requestId: "329", tabId: "2", data: "false" } worker.js:22:3 onMessage : Object { type: "tab_location_changed", requestId: "329", tabId: "2", data: "false,false" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "329", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "tab_selected", requestId: "-1", tabId: "2", data: "false,signin.ebay.co.uk,false" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "333", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "334", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "335", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "336", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "338", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "341", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "342", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "344", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "349", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "350", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "tab_selected", requestId: "-1", tabId: "2", data: "false,signin.ebay.co.uk,false" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "351", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "353", tabId: "2", data: "" } worker.js:22:3 onMessage : Object { type: "get_rapport_headers", requestId: "354", tabId: "2", data: "" } worker.js:22:3

Any clues there? Thanks, Dave.

Modified by Dave-H

more options

Firefox 52 does have some form of tracking protection, but it is normally only enabled in Private Browsing mode windows. You can make it appear in "Options/Preferences -> Security" by modifying this pref on the about:config page.

  • privacy.trackingprotection.ui.enabled = true
  • privacy.trackingprotection.enabled
  • privacy.trackingprotection.pbmode.enabled
more options

Thanks @cor-el, I've enabled those settings. The settings seem to be in the Privacy section of the options, not the Security section, but I guess that's what you meant.

I asked on the eBay forum about the verification problem, and they gave me a URL that actually does allow me to log in, presumably bypassing the verification page. https://signin.ebay.co.uk/ws/eBayISAPI.dll That works fine, but I now get the verification page when I try to log out, and it still doesn't work!

-(
more options

Any recaptcha that requires me to click pictures fails 100% of the time, even if it shows as "Ok" once I click to proceed past the captcha I get an error message that it failed.

This doesn't happen in chrome or IE, specifically a firefox issue. I haven't messed with my about:config at all. A previous thread on this subject mentioned that it might be a javascript issue but following that instruction hasn't helped my problem. I have the latest version of Quantum installed.

This issue is specifically with image captcha, if I get a text based one I can pass it. If I click the headphones captcha button on the captcha I get a message about automated queries which only appears in Firefox. Starting in Safe Mode did not fix the problem.

more options

A possible workaround to get you signed in: When you get to the new sign-in page, delete everything in the URL after the .dll so that the address looks like this:


https://signin.ebay.co.uk/ws/eBayISAPI.dll


hit 'enter' to load that page, and you should see the old pre-Facebook sign-in page. After you enter username and password, if you are sent to a Captcha or a new sign-in page, click on the eBay logo to go to the main page. You should be signed in at that point. At least until eBay changes things again.


If you sign out and get the verification page, what happens if you click on the ebay logo or go to ebay.co.uk? If in the upper left corner you see a link to "sign in" -- that means you are already signed out. If you see a message that says "Hi, [firstname]!" then you are still signed in. If the former, that means you are signed out before you get to the verification page and you can simply close the browser tab at that point. If the latter, you are still signed in and must go through the verification to complete the sign out process.

more options

@alahakoonmewni That's exactly, word for word, what "eburtonlab" told me on the eBay forum! Are you the same person?! Interesting that the current versions of Firefox seem to have the same problem with picture reCAPTCHAs. My copy of Firefox 70 on Windows 10 has never asked me to verify myself on eBay, so I can't test whether the same problem is happening there or not. Cheers, Dave.

more options

trying changing the Compatibility Mode. You can easily do that by clicking on the "torn paper" icon in the upper right hand corner. It is located between the "magnifying glass" icon and the "curved arrow" icon. You can also click on TOOLS and then Compatibility View settings.

more options

Thanks, but I can't see the icon you mention. There is no "compatibility view" entry under "tools". Are you sure that the function exists on Firefox 52 ESR? Cheers, Dave.

more options

I have gotten the message someone else did about re sending information. ebay said they were aware of a problem. I get captcha loading but stuck there. chrome works.