Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Themes mysteriously change

  • 12 replies
  • 1 has this problem
  • 35 views
  • Last reply by Odin3

more options

When I install a theme that distinguishes the active tab by removing the bottom border line, I find that, with no apparent cause, before long that bottom border line will reappear. I can restore the correct appearance by restarting Fx, but pretty soon the fault will resurface. How can I cure this?

When I install a theme that distinguishes the active tab by removing the bottom border line, I find that, with no apparent cause, before long that bottom border line will reappear. I can restore the correct appearance by restarting Fx, but pretty soon the fault will resurface. How can I cure this?

All Replies (12)

more options

Usually there's no border line on the bottom side of the active tab. However, if you use an extension that places that tab into a Container, there should be a heavy line color-coded to the relevant container at the bottom of the tab (not completely edge-to-edge). Could that be the issue?

more options

jscher2000 said

Usually there's no border line on the bottom side of the active tab. However, if you use an extension that places that tab into a Container, there should be a heavy line color-coded to the relevant container at the bottom of the tab (not completely edge-to-edge). Could that be the issue?

I don't think so. I have no extensions involving containers, to the best of my knowledge.The two theme extensions where I've seen this issue are Internet Explorer Blue and SebaArt Blue Dream.

Modified by Odin3

more options

Containers are builtin, you do not need an extension.

Can you attach a screenshot?

more options

Here it is, cor-el. The bottom border line for the active tab--this one--should not be there. (This is not too bad with this theme, as the color change is pronounced. The same thing happens however with Internet Blue, which is my preferred theme.)

more options

Hi Odin3, I don't get the line when I test in a new profile (see attached). Could it be something in your userChrome.css file?

more options

jscher2000 said

Hi Odin3, I don't get the line when I test in a new profile
The line never appears from the outset, but only later. And restarting Fx will remove the line, but (unfortunately) only temporarily.

Is my userChrome the culprit? I don't know. I would show you my userChrome, but (a) a screenshot won't display the entire file and (b) copy-and-paste distorts the contents.

more options

Odin3 said

The line never appears from the outset, but only later. And restarting Fx will remove the line, but (unfortunately) only temporarily.

Can you see a pattern to it? Does it ever happen if you use the built-in Light theme?

Is my userChrome the culprit? I don't know. I would show you my userChrome, but (a) a screenshot won't display the entire file and (b) copy-and-paste distorts the contents.

Yes, please don't paste large amounts of CSS here. You can use a site like Pastebin and share the link back here. Below the box where you paste, there a way to specify that it is CSS, which adds syntax coloring to make it easier to read.

https://pastebin.com/

more options

jscher2000 said

Can you see a pattern to it? Does it ever happen if you use the built-in Light theme?
Don't know. I'd have to use the theme for a while before the fault appears.
You can use a site like Pastebin and share the link back here.
Thanks for the tip. You can see my userChrome at https://pastebin.com/RmkGLvZ4.
more options

You have several CSS rules related to tabs/the tab bar and the title bar. Tabs may appear in the "title bar" when you do not enable the optional Menu Bar or Title Bar. But off the top of my head I can't tell what the cumulative effect of those changes is.

If you are familiar with the Browser Toolbox, you could "inspect" the toolbar area to try and determine where the line comes from (for example, is it a border, or a drop-shadow, or something else). https://developer.mozilla.org/docs/Tools/Browser_Toolbox

more options

Thanks, jscher. Currently my preferred theme [Internet Explorer Blue] is running as it should--no bottom border line. If and when the fault reappears, I'll try your suggestion.

more options

Does toggling drag space in customize mode make a difference?

This could also be some border or box shadow added to the Navigation Toolbar and not a tab bar issue.

more options

Thanks, cor-el. For now I'm using SebaArt Blue Dream, which so far does not trigger the subject fault. Once the fault reappears I'll try to give you an answer.