X
Tap here to go to the mobile version of the site.

Support Forum

Will not display Captcha box on page where Safari does display it, yet both browers have the same add-on extentions for ad blocking.s.

Posted

Cannot leave a message on a mortuary website using FF. Submit requires completing a captcha, but the box to check is not displayed, only the word 'captcha' and the spinning icon. When using Safari, the box is also displayed. Safari and FF both use largely the same extensions.

Cannot leave a message on a mortuary website using FF. Submit requires completing a captcha, but the box to check is not displayed, only the word 'captcha' and the spinning icon. When using Safari, the box is also displayed. Safari and FF both use largely the same extensions.

Chosen solution

Like Fred said above, the problem could be the Content Blocking settings, especially if you have set them to be really strict. Safari doesn't have the same Content Blocking technology as Firefox, which could be why the issue isn't present there.

An easy way to see if it is related to Content Block would be to click the Turn Off Blocking For This Site button and then reloading the page.

A common problem has to do with the fact that Content Blocking sometimes tries to block tracking code that is from another website. Since most websites use a captcha from Google, it prevents Firefox from loading that captcha.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Privacy Badger Ghostery FB Container FB Purity Duck Duck Go Disconnect Avast AdBlock PLUS Define Bookmark Folder

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature:

https://support.mozilla.org/en-US/kb/content-blocking

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you? 1
Quote

Question owner

The only shield says Tracking Attempts Blocked.

The only shield says Tracking Attempts Blocked.
Was this helpful to you?
Quote

Question owner

Also, this problem so far as I know appears only with captcha and only on certain sites. Otherwise sites appear undamaged. The problem is absent in Safari.

Also, this problem so far as I know appears only with captcha and only on certain sites. Otherwise sites appear undamaged. The problem is absent in Safari.
Was this helpful to you?
Quote
Wesley Branton
  • Top 10 Contributor
590 solutions 4999 answers

Chosen Solution

Like Fred said above, the problem could be the Content Blocking settings, especially if you have set them to be really strict. Safari doesn't have the same Content Blocking technology as Firefox, which could be why the issue isn't present there.

An easy way to see if it is related to Content Block would be to click the Turn Off Blocking For This Site button and then reloading the page.

A common problem has to do with the fact that Content Blocking sometimes tries to block tracking code that is from another website. Since most websites use a captcha from Google, it prevents Firefox from loading that captcha.

Like Fred said above, the problem could be the Content Blocking settings, especially if you have set them to be really strict. Safari doesn't have the same Content Blocking technology as Firefox, which could be why the issue isn't present there. An easy way to see if it is related to Content Block would be to click the '''Turn Off Blocking For This Site''' button and then reloading the page. A common problem has to do with the fact that Content Blocking sometimes tries to block tracking code that is from another website. Since most websites use a captcha from Google, it prevents Firefox from loading that captcha.
Was this helpful to you? 1
Quote

Question owner

It was the setting in the DISCONNECT extension. I had it set to strict blocking of trackers. Evidently that included captcha. I'll try to get word to the DISCONNECT publisher.

It was the setting in the DISCONNECT extension. I had it set to strict blocking of trackers. Evidently that included captcha. I'll try to get word to the DISCONNECT publisher.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.