Search Support

"Firefox Private Network encountered an unknown issue. Try turning it off, and on again."

more options

I'm on my college campus trying this out so I'm unsure if that has anything to do with it, but considering it's using Cloudflare, I want to point out that I manually entered my DNS as 1.1.1.1(alt 1.0.0.1) to use the Cloudflare 1.1.1.1 service on my laptop. Would this have anything to do with it?

Attached screenshots

Chosen solution

I didn't try that, however, apparently my college network does NOT like it at all. It works here at home which is a good sign I guess? I cannot recall, but I have a feeling vpns are blocked at my college. I suppose that's the issue.

Read this answer in context 👍 0

All Replies (5)

more options

Hi SummerPlasma,

Could you try completely restarting Firefox to see if the issue continues?

Here's a quick and easy way to restart Firefox:

  • Type about:profiles into your address bar.
  • Towards the top right of the page, you should see a gray Restart box with two options in it.
  • Select Restart Normally. Do not choose to restart with add-ons disabled, as this will disable Firefox Private Network when it reboots.

Please let me know whether or not the issue is still there when your browser boots back up.

more options

The issue still persists and gives me the same message.

more options

Does it still occur after completely removing the FPN add-on and reinstalling it from the official site?

more options

YAY! NO MORE UNKNOWN ERROR! Go to Add-ons > find "Firefox Private Network" > CLICK on the "Three Dots" > Remove Then go to https://private-network.firefox.com/ (Firefox Private Network - Official Site) > CLICK > "+ Add to Firefox" DONE! NO MORE ERROR

more options

Chosen Solution

I didn't try that, however, apparently my college network does NOT like it at all. It works here at home which is a good sign I guess? I cannot recall, but I have a feeling vpns are blocked at my college. I suppose that's the issue.