X
Tap here to go to the mobile version of the site.

Support Forum

Extension menu is irresponsive at network stuck after 69.0b1

Posted

I'm a Firefox Developer Edition user. After upgrading my Firefox to 69.0b1, I see a problem about network and extension:

In the same network, the case when the browser stuck at loading the page content has been more frequent (especially on script-rich sites like Twitter). At that case, the extension menu is irresponsive (which means that when I click on it, it only shows a pop-up with nothing in it). Closing all loading tabs doesn't solve this. After a long time after the loading starts, the tabs suddenly continue to load and the extension pages come back responsive.

I'm a Firefox Developer Edition user. After upgrading my Firefox to 69.0b1, I see a problem about network and extension: In the same network, the case when the browser stuck at loading the page content has been more frequent (especially on script-rich sites like Twitter). At that case, the extension menu is irresponsive (which means that when I click on it, it only shows a pop-up with nothing in it). Closing all loading tabs doesn't solve this. After a long time after the loading starts, the tabs suddenly continue to load and the extension pages come back responsive.

Chosen solution

not sure what is cause and effect in the profile. can you reproduce the same problem (hangs on twitter) as well, when the Wappalyzer extension is disabled?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Aria2 Download Manager Integration CanvasBlocker Decentraleyes Firefox Multi-Account Containers HTTPS Everywhere Neat URL PassFF Privacy Badger Stylus Tampermonkey uBlock Origin uMatrix User-Agent Switcher Wappalyzer

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5269 solutions 23294 answers

Helpful Reply

hi, would it be possible for you to capture and share a performance profile while the issue is apparent? perhaps this would contain more clues as to what's going wrong: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem

thank you

hi, would it be possible for you to capture and share a performance profile while the issue is apparent? perhaps this would contain more clues as to what's going wrong: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem thank you
Was this helpful to you? 1
Quote

Question owner

I have taken some profilings with Gecko Profiler.

Profile #1:

Visited wtfismyip.com then Twitter. Extension menu begins to get irresponsive at load of Twitter, then pages don't load (no matter old pages or new pages) and extension menu irresponsive at about 2 minutes.

profiling url: https://profiler.firefox.com/public/ad24c78f22a6c22f3391c73023a0d72eff4941cf/network-chart/?globalTrackOrder=0-1&hiddenLocalTracksByPid=8158-0&localTrackOrderByPid=8158-2-0-1~&thread=0&v=4

The profile #1 seems not to be really informative, so I took a profile #2:

Visited url.fm then Twitter. Extension menu being irresponsive happened at about 21-23s when I dragged down the page fast, trying to reproduce the irresponsive extension menu.

profiling url: https://profiler.firefox.com/public/7ae56f5cf8e2b786c257f3c69b1565f5d2938d87/network-chart/?globalTrackOrder=0-1-2&localTrackOrderByPid=10113-1-0~25225-0~&thread=0&v=4

I have taken some profilings with Gecko Profiler. Profile #1: Visited wtfismyip.com then Twitter. Extension menu begins to get irresponsive at load of Twitter, then pages don't load (no matter old pages or new pages) and extension menu irresponsive at about 2 minutes. profiling url: https://profiler.firefox.com/public/ad24c78f22a6c22f3391c73023a0d72eff4941cf/network-chart/?globalTrackOrder=0-1&hiddenLocalTracksByPid=8158-0&localTrackOrderByPid=8158-2-0-1~&thread=0&v=4 The profile #1 seems not to be really informative, so I took a profile #2: Visited url.fm then Twitter. Extension menu being irresponsive happened at about 21-23s when I dragged down the page fast, trying to reproduce the irresponsive extension menu. profiling url: https://profiler.firefox.com/public/7ae56f5cf8e2b786c257f3c69b1565f5d2938d87/network-chart/?globalTrackOrder=0-1-2&localTrackOrderByPid=10113-1-0~25225-0~&thread=0&v=4
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5269 solutions 23294 answers

Chosen Solution

not sure what is cause and effect in the profile. can you reproduce the same problem (hangs on twitter) as well, when the Wappalyzer extension is disabled?

not sure what is cause and effect in the profile. can you reproduce the same problem (hangs on twitter) as well, when the Wappalyzer extension is disabled?
Was this helpful to you? 1
Quote

Question owner

Thanks for your reply!

When profiling is on with Wappalyzer enabled, I'm able to reproduce hanging on Twitter (more or less) almost every time. WIth Wappalayer disabled, it seems harder to reproduce this problem.

I'll continue using Firefox with Wappalyzer disabled. Once the hang is detected, I will upload the profiling data.

Thanks for your reply! When profiling is on with Wappalyzer enabled, I'm able to reproduce hanging on Twitter (more or less) almost every time. WIth Wappalayer disabled, it seems harder to reproduce this problem. I'll continue using Firefox with Wappalyzer disabled. Once the hang is detected, I will upload the profiling data.
Was this helpful to you?
Quote

Question owner

Tested for days without Wapplayzer. The problems seems to be solved, thanks!

Tested for days without Wapplayzer. The problems seems to be solved, thanks!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.