X
Tap here to go to the mobile version of the site.

Support Forum

Why were all my addons/extensions for FF v66.0.3 moved to 'Legacy Extensions' on one PC, when they weren't moved on in v.66.0.3 on another PC?

Posted

All of a sudden I found all of my addons/extensions in FF 66.0.3 have been disabled and moved to 'Legacy Extensions' on one of my Windows 7 PCs. I have FF 66.0.3 installed on a Windows 10 system with the same group of extensions, and none there have been disabled/moved. Here's a list:

F.B Purity 28.1.0.0 Flash Block (Plus) 0.1.9 Ghostery 8.3.3 New Tab Override 14.2.0 Save Page WE 14.0 uBlock Origin 1.18.6

Thanks for any feedback on what may be causing this, and any suggestions on how to restore these addons on the Windows 7 system.

All of a sudden I found all of my addons/extensions in FF 66.0.3 have been disabled and moved to 'Legacy Extensions' on one of my Windows 7 PCs. I have FF 66.0.3 installed on a Windows 10 system with the same group of extensions, and none there have been disabled/moved. Here's a list: F.B Purity 28.1.0.0 Flash Block (Plus) 0.1.9 Ghostery 8.3.3 New Tab Override 14.2.0 Save Page WE 14.0 uBlock Origin 1.18.6 Thanks for any feedback on what may be causing this, and any suggestions on how to restore these addons on the Windows 7 system.

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Helpful Reply

There is a problem with the certificate that is used to sign some extensions. This is being worked by the Add-ons team.

See:

At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail.
Our team is actively working on a fix. We will update as soon as we have more information.
There is a problem with the certificate that is used to sign some extensions. This is being worked by the Add-ons team. See: *[[/questions/1257928]] Will the disabling of add-ons be fixed, or is it the new way? *https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 <blockquote><pre>At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information.</pre></blockquote>
bestfather 0 solutions 6 answers

The exact same issue has occurred on my MAC Firefox QUANTUM v66.0.3 browser all of a sudden. I especially use LASTPASS and HONEY (amazon) extensions, but 95% of all my many extensions are unsafe according to Firefox message. This occurred suddenly. I mean this is CRAZY ... ALL MY EXTENSIONS ARE LEGACY NOW. ADDITIONAL ISSUE: I attempted to download other extensions that I don't need and Firefox error occurs that "download failed, check your connection" . There are NO new extensions I am able to download anymore. what the hell?

The exact same issue has occurred on my MAC Firefox QUANTUM v66.0.3 browser all of a sudden. I especially use LASTPASS and HONEY (amazon) extensions, but 95% of all my many extensions are unsafe according to Firefox message. This occurred suddenly. I mean this is CRAZY ... ALL MY EXTENSIONS ARE LEGACY NOW. ADDITIONAL ISSUE: I attempted to download other extensions that I don't need and Firefox error occurs that "download failed, check your connection" . There are NO new extensions I am able to download anymore. what the hell?
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40290 answers

mozfellow said

All of a sudden I found all of my addons/extensions in FF 66.0.3 have been disabled and moved to 'Legacy Extensions' on one of my Windows 7 PCs. I have FF 66.0.3 installed on a Windows 10 system with the same group of extensions, and none there have been disabled/moved.

I'm not sure why, but the Win10 PC probably didn't contact the server for extension verification just yet. I suppose in another hour or two that one will do the same thing.

''mozfellow [[#question-1257921|said]]'' <blockquote> All of a sudden I found all of my addons/extensions in FF 66.0.3 have been disabled and moved to 'Legacy Extensions' on one of my Windows 7 PCs. I have FF 66.0.3 installed on a Windows 10 system with the same group of extensions, and none there have been disabled/moved. </blockquote> I'm not sure why, but the Win10 PC probably didn't contact the server for extension verification '''''just yet'''''. I suppose in another hour or two that one will do the same thing.
barny20n3 0 solutions 3 answers

I have this issue as well. This is only happening in the FF-windows configuration, the extensions all work in FF-Mate 18.04 and they are working in windows machines using the WaterFox browser.

I have this issue as well. This is only happening in the FF-windows configuration, the extensions all work in FF-Mate 18.04 and they are working in windows machines using the WaterFox browser.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Hi bestfather, a critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing.

The Add-ons team is working on a fix for this. Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

Hi bestfather, a critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing. The Add-ons team is working on a fix for this. Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

You probably will have to delete extensions.json in the profile folder to make Firefox re-enable the extension if you would set back the clock on your computer.

You probably will have to delete extensions.json in the profile folder to make Firefox re-enable the extension if you would set back the clock on your computer.

Question owner

cor-el said

There is a problem with the certificate that is used to sign some extensions. This is being worked by the Add-ons team. See:
At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail.
Our team is actively working on a fix. We will update as soon as we have more information.

Thanks Cor-el. I see a lot of folks have been reporting this issue, keeping you guys pretty busy. I'll just sit back and make do for the time being. Meanwhile 6 hours after posting this, FF on my Windows 10 PC is still good. But as the-edmeister pointed out above, that can probably change at any moment.

''cor-el [[#answer-1218092|said]]'' <blockquote> There is a problem with the certificate that is used to sign some extensions. This is being worked by the Add-ons team. See: *[[/questions/1257928]] Will the disabling of add-ons be fixed, or is it the new way? *https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 <blockquote><pre>At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information.</pre></blockquote> </blockquote> Thanks Cor-el. I see a lot of folks have been reporting this issue, keeping you guys pretty busy. I'll just sit back and make do for the time being. Meanwhile 6 hours after posting this, FF on my Windows 10 PC is still good. But as the-edmeister pointed out above, that can probably change at any moment.
Chris Ilias
  • Moderator
357 solutions 1952 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
bestfather 0 solutions 6 answers

FIREFOX MAC BROWSER: Partially fixed. Pushing the update through “studies” seems to resolve the extensions issue. However I STILL HAVE AN ISSUE that I can’t log in to Firefox account using FIREFOX for MAC browser. I can easily log in using Safari, so I know the password is working just fine - the problem is Firefox . Also fixed is that I can install additional extensions again (just tried it). I just can NOT log into Firefox under its browser. Included a screen capture of the error message logging in.

FIREFOX MAC BROWSER: Partially fixed. Pushing the update through “studies” seems to resolve the extensions issue. However I STILL HAVE AN ISSUE that I can’t log in to Firefox account using FIREFOX for MAC browser. I can easily log in using Safari, so I know the password is working just fine - the problem is Firefox . Also fixed is that I can install additional extensions again (just tried it). I just can NOT log into Firefox under its browser. Included a screen capture of the error message logging in.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Hi bestfather, the same username and password should work in all browsers. It's very strange that isn't the case for you. Are you blocking cookies in Firefox?

Just to clarify one thing:

  • Mozilla Support accounts are only for this site
  • Unfortunately, they are not yet consolidated into one sign-on
Hi bestfather, the same username and password should work in all browsers. It's very strange that isn't the case for you. Are you blocking cookies in Firefox? Just to clarify one thing: * Firefox Accounts are used for Sync and other services ([[Access Mozilla Services with Firefox Account]]) * Mozilla Support accounts are only for this site * Unfortunately, they are not yet consolidated into one sign-on

Question owner

Chris Ilias said

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.

Good to hear Chris Ilias. For those as anal on specifics as me, I see the path to that option is actually a bit longer at: Options > Privacy & Security > Firefox Data Collection and Use > Allow Firefox to send technical and interaction data to Mozilla > Allow Firefox to install and run studies

''Chris Ilias [[#answer-1218439|said]]'' <blockquote> Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated. </blockquote> Good to hear Chris Ilias. For those as anal on specifics as me, I see the path to that option is actually a bit longer at: Options > Privacy & Security > Firefox Data Collection and Use > Allow Firefox to send technical and interaction data to Mozilla > Allow Firefox to install and run studies

Question owner

Chris Ilias said

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.

Wow... Has Mozilla already pushed the fix? It was only minutes after enabling that option that all my addons were enabled again. I disabled it and restarted FF, and they're all still working, at least so far.

''Chris Ilias [[#answer-1218439|said]]'' <blockquote> In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated. </blockquote> Wow... Has Mozilla already pushed the fix? It was only minutes after enabling that option that all my addons were enabled again. I disabled it and restarted FF, and they're all still working, at least so far.

Question owner

Yes... It looks like Mozilla has fixed this. This notice just appeared in the header of FF: "We rolled out a hotfix that re-enables affected add-ons. The fix will be automatically applied in the background within the next few hours. For more details, please check out the update at https://support.mozilla.org/en-US/kb/add-ons-failing-install-firefox"

Yes... It looks like Mozilla has fixed this. This notice just appeared in the header of FF: "We rolled out a hotfix that re-enables affected add-ons. The fix will be automatically applied in the background within the next few hours. For more details, please check out the update at https://support.mozilla.org/en-US/kb/add-ons-failing-install-firefox"

Modified by mozfellow

Terps 1 solutions 4 answers

All my Add-ons are also disabled as of May 3. It is now 8:00PM Central on May 4th and they are still not fixed. Should they be fixed by now? I have "Allow Firefox to install and run studies" checked.

In "about:studies" I have 2 active and non completed. See attached screenshot.

How long before I can expect a fix?

All my Add-ons are also disabled as of May 3. It is now 8:00PM Central on May 4th and they are still not fixed. Should they be fixed by now? I have "Allow Firefox to install and run studies" checked. In "about:studies" I have 2 active and non completed. See attached screenshot. How long before I can expect a fix?
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

You are missing the hotfix that installs the intermediate certificate.

  • hotfix-update-xpi-signing-intermediate-bug-1548973
  • hotfix-reset-xpi-verification-timestamp-1548973

You can temporarily set app.normandy.run_interval_seconds to a lower value (21600 => 60) to see whether that installs the hotfix. Close and restart Firefox and check about:studies.

  • hotfix-update-xpi-signing-intermediate-bug-1548973
  • hotfix-reset-xpi-verification-timestamp-1548973

You may have to refresh the about:studies page a few times.

Do NOT forget to reset app.normandy.run_interval_seconds when about:studies shows that the hotfix has been applied.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

You are missing the hotfix that installs the intermediate certificate. *hotfix-update-xpi-signing-intermediate-bug-1548973 *hotfix-reset-xpi-verification-timestamp-1548973 You can temporarily set <b>app.normandy.run_interval_seconds</b> to a lower value (21600 => 60) to see whether that installs the hotfix. Close and restart Firefox and check <b>about:studies</b>. *hotfix-update-xpi-signing-intermediate-bug-1548973 *hotfix-reset-xpi-verification-timestamp-1548973 You may have to refresh the about:studies page a few times. Do NOT forget to reset <b>app.normandy.run_interval_seconds</b> when <b>about:studies</b> shows that the hotfix has been applied. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/en-US/kb/add-ons-disabled-or-fail-to-install-firefox *https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/
elzach 0 solutions 28 answers

jscher2000 said

Hi bestfather, a critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing. The Add-ons team is working on a fix for this. Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

Thanks for the info. So this is akin to turning off the electricity and wondering why the food in it is going bad. It may not be a security flaw per se (which all browsers experience), but it's a huge black eye for Mozilla.

Btw, a lot of talk about "Studies", but many older versions don't even have that. So what about those folks?

''jscher2000 [[#answer-1218164|said]]'' <blockquote> Hi bestfather, a critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing. The Add-ons team is working on a fix for this. Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal. </blockquote> Thanks for the info. So this is akin to turning off the electricity and wondering why the food in it is going bad. It may not be a security flaw per se (which all browsers experience), but it's a huge black eye for Mozilla. Btw, a lot of talk about "Studies", but many older versions don't even have that. So what about those folks?
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

From what web page is this screenshot because this doesn't look like the Firefox Account website?

In case of issues try to log in to the Firefox Account via this website.

From what web page is this screenshot because this doesn't look like the Firefox Account website? In case of issues try to log in to the Firefox Account via this website. *https://accounts.firefox.com/signin *https://accounts.firefox.com/settings
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

elzach said

Btw, a lot of talk about "Studies", but many older versions don't even have that. So what about those folks?

All supported versions of Firefox for Windows, Mac, and Linux can use Studies. For your Firefox 52 ESR, I replied in your thread: https://support.mozilla.org/questions/1258242#answer-1219072

''elzach [[#answer-1219037|said]]'' <blockquote> Btw, a lot of talk about "Studies", but many older versions don't even have that. So what about those folks? </blockquote> All supported versions of Firefox for Windows, Mac, and Linux can use Studies. For your Firefox 52 ESR, I replied in your thread: https://support.mozilla.org/questions/1258242#answer-1219072
magnumquick 2 solutions 18 answers

Same issue as others, what really pisses me off is that my roboform won't work in Firefox either. Now, what was it, a month ago and Mozilla released the version that all of a sudden would no longer stop videos from autoplaying on websites. Mozilla needs to get it's act together or people will start going to another browser, at the very least flog the person responsible for effecting so many so frequently.

Same issue as others, what really pisses me off is that my roboform won't work in Firefox either. Now, what was it, a month ago and Mozilla released the version that all of a sudden would no longer stop videos from autoplaying on websites. Mozilla needs to get it's act together or people will start going to another browser, at the very least flog the person responsible for effecting so many so frequently.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40290 answers

elzach said

... Btw, a lot of talk about "Studies", but many older versions don't even have that. So what about those folks?

Install this "hot-fix" extension to get the fix that Mozilla has done. Supposedly works for older versions, too; but I cannot test it as my "older versions" pre-date the mandatory signing in the Fx 48 version.

''elzach [[#answer-1219037|said]]'' <blockquote> ... Btw, a lot of talk about "Studies", but many older versions don't even have that. So what about those folks? </blockquote> Install [https://storage.googleapis.com/moz-fx-normandy-prod-addons/extensions/hotfix-update-xpi-intermediate%40mozilla.com-1.0.2-signed.xpi this "hot-fix" extension] to get the fix that Mozilla has done. Supposedly works for older versions, too; ''but I cannot test it as my "older versions" pre-date the mandatory signing in the Fx 48 version.