X
Tap here to go to the mobile version of the site.

Support Forum

media buttons now changing web pages

Posted

Since suffering another forced update to 66.0.2 (none of the actions to prevent this actually work!) why do my keyboard sound mute, up and down keys force a drop out of the webpage and open a blank page instead? YouTube is now unusable!

Since suffering another forced update to 66.0.2 (none of the actions to prevent this actually work!) why do my keyboard sound mute, up and down keys force a drop out of the webpage and open a blank page instead? YouTube is now unusable!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Hi AnnieBody, could you describe the steps to re-create the problem? Possibly my keyboard doesn't have all the keys yours does, but it definitely has up arrow and down arrow.

So you load a page on YouTube that has a video. Does it start playing the video automatically or do you click the Play button first? And then what do you do with the keyboard that causes the issue?

Hi AnnieBody, could you describe the steps to re-create the problem? Possibly my keyboard doesn't have all the keys yours does, but it definitely has up arrow and down arrow. So you load a page on YouTube that has a video. Does it start playing the video automatically or do you click the Play button first? And then what do you do with the keyboard that causes the issue?
cor-el
  • Top 10 Contributor
  • Moderator
17525 solutions 158458 answers
See also: *https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly *https://support.mozilla.org/en-US/kb/mouse-shortcuts-perform-common-tasks

Question owner

My keyboard is a Logitech K330. It has an additional row of dedicated buttons for playing media, shortcuts etc. Normally I can use the mute, up and down keys to control music/sounds. When using Firefox, instead of controlling the sound, the webpage closes and defaults to a blank Google webpage, me default setting. I can then use the back button to reopen the original page. This has not been a problem with previous versions of Firefox. As I never use them, how can I turn off the Firefox shortcuts and get my functionality back?

My keyboard is a Logitech K330. It has an additional row of dedicated buttons for playing media, shortcuts etc. Normally I can use the mute, up and down keys to control music/sounds. When using Firefox, instead of controlling the sound, the webpage closes and defaults to a blank Google webpage, me default setting. I can then use the back button to reopen the original page. This has not been a problem with previous versions of Firefox. As I never use them, how can I turn off the Firefox shortcuts and get my functionality back?
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Hi AnnieBody, thank you for the additional details.

I don't know how a keyboard can directly control a music player embedded in a page. There must be some trick to getting the key press to the player instead of the page more generally or to Firefox's user interface area. And maybe that trick that stopped working in Firefox 66?

Maybe Logitech will post an article about this at some point. Until then, I have one guess:

Could you test whether this is caused by the new anti-autoplay feature? There is a checkbox on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type autop and Firefox should filter to the "Permissions" section.

If the box is checked next to "Block websites from automatically playing sound" uncheck the box to allow autoplay on YouTube and other sites.

Does the next YouTube page you open work with your keyboard buttons after that?

Hi AnnieBody, thank you for the additional details. I don't know how a keyboard can directly control a music player embedded in a page. There must be some trick to getting the key press to the player instead of the page more generally or to Firefox's user interface area. And maybe that trick that stopped working in Firefox 66? Maybe Logitech will post an article about this at some point. Until then, I have one guess: Could you test whether this is caused by the new anti-autoplay feature? There is a checkbox on the Options page: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''autop'' and Firefox should filter to the "Permissions" section. If the box is checked next to "Block websites from automatically playing sound" uncheck the box to allow autoplay on YouTube and other sites. Does the next YouTube page you open work with your keyboard buttons after that?

Question owner

The media player is a software program on my PC, in this case WinAmp. The sound card is installed on my PC. This has nothing to do with embedded web page software! Logitech does not have to provide any support for Firefox. It used to work correctly now it doesn't. That is the reason for not updating: don't fix it if it ain't broke; however, Firefox appears to be completely ignorant of settings and forces an update whatever you set! In doing so it has rendered itself no longer fit for purpose, but like all software providers the problem is not theirs! YouTube plays, as I expect it to, but if want to mute the sound then Firefox no longer works. But it is not just YouTube, if affects any site that plays music (Spotify and Deezer), although the latter now crashes regularly with a Firefox oops notice, which it never did before. No similar issues with Chrome or IE, so definitely an issue with Firefox introduced at the last forced update. Sick and tired of their forced updates which now has rendered it no longer fit for purpose. Sick and tired of having to make changes to keep my original settings. If new functionality is introduced it should be switched off. I should not have to search what has changed to get it working again.

The media player is a software program on my PC, in this case WinAmp. The sound card is installed on my PC. This has nothing to do with embedded web page software! Logitech does not have to provide any support for Firefox. It used to work correctly now it doesn't. That is the reason for not updating: don't fix it if it ain't broke; however, Firefox appears to be completely ignorant of settings and forces an update whatever you set! In doing so it has rendered itself no longer fit for purpose, but like all software providers the problem is not theirs! YouTube plays, as I expect it to, but if want to mute the sound then Firefox no longer works. But it is not just YouTube, if affects any site that plays music (Spotify and Deezer), although the latter now crashes regularly with a Firefox oops notice, which it never did before. No similar issues with Chrome or IE, so definitely an issue with Firefox introduced at the last forced update. Sick and tired of their forced updates which now has rendered it no longer fit for purpose. Sick and tired of having to make changes to keep my original settings. If new functionality is introduced it should be switched off. I should not have to search what has changed to get it working again.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

So let me see whether I understand.

Before the update, when you pressed a volume button on your keyboard (mute, up, down), this wasn't magically interacting with the YouTube player, it was modifying the Windows audio just like it does with every other program. Firefox 65 and earlier were blissfully unaware of the buttons and did nothing when you pressed them.

Now, after the update, if Firefox is the application that has the focus, when you press any of those buttons, Firefox behaves as though you have clicked the Home button, loading your home page in that tab in place of the page you had before.

That's very strange. Hopefully we'll get some more information about this that makes sense of it.

Meanwhile, I assume you have shut down and restarted Windows at least once since this problem started, so we can set aside any transient issues caused by unfinished installations.

So let me see whether I understand. Before the update, when you pressed a volume button on your keyboard (mute, up, down), this wasn't magically interacting with the YouTube player, it was modifying the Windows audio just like it does with every other program. Firefox 65 and earlier were blissfully unaware of the buttons and did nothing when you pressed them. Now, after the update, if Firefox is the application that has the focus, when you press any of those buttons, Firefox behaves as though you have clicked the Home button, loading your home page in that tab in place of the page you had before. That's very strange. Hopefully we'll get some more information about this that makes sense of it. Meanwhile, I assume you have shut down and restarted Windows at least once since this problem started, so we can set aside any transient issues caused by unfinished installations.

Question owner

Yes, it behaves the same each and every time.

Yes, it behaves the same each and every time.
WestEnd 60 solutions 5387 answers

AnnieBody said

My keyboard is a Logitech K330. It has an additional row of dedicated buttons for playing media, shortcuts etc. Normally I can use the mute, up and down keys to control music/sounds. When using Firefox, instead of controlling the sound, the webpage closes and defaults to a blank Google webpage, me default setting. I can then use the back button to reopen the original page. This has not been a problem with previous versions of Firefox. As I never use them, how can I turn off the Firefox shortcuts and get my functionality back?

With Logitech keyboards did you update to the latest version driver? I have a Logitech media keyboard and have no issue using the buttons on it.

''AnnieBody [[#answer-1211368|said]]'' <blockquote> My keyboard is a Logitech K330. It has an additional row of dedicated buttons for playing media, shortcuts etc. Normally I can use the mute, up and down keys to control music/sounds. When using Firefox, instead of controlling the sound, the webpage closes and defaults to a blank Google webpage, me default setting. I can then use the back button to reopen the original page. This has not been a problem with previous versions of Firefox. As I never use them, how can I turn off the Firefox shortcuts and get my functionality back? </blockquote> With Logitech keyboards did you update to the latest version driver? I have a Logitech media keyboard and have no issue using the buttons on it.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

I don't have access to a K330. When I try the mute and volume buttons on my Microsoft keyboard, Windows 10 is showing me a volume slider. Is this the kind of thing your keyboard does when another app is active, not Firefox?

I don't have access to a K330. When I try the mute and volume buttons on my Microsoft keyboard, Windows 10 is showing me a volume slider. Is this the kind of thing your keyboard does when another app is active, not Firefox? <center><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-04-05-17-38-07-4bab47.png" width="400"></center>
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

I get the same little sliders overlay with a Logitech k740 I found. Not sure if there is some difference in the driver software, or your Firefox installation has become corrupted. You could try:

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement at your next startup?

I get the same little sliders overlay with a Logitech k740 I found. Not sure if there is some difference in the driver software, or your Firefox installation has become corrupted. You could try: '''Clean Reinstall''' This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data. (A) Download a fresh installer for Firefox to a convenient location: https://www.mozilla.org/firefox/all/ (B) Exit out of Firefox (if applicable). ''If you use '''Microsoft Office''', please change your default browser to Internet Explorer temporarily before the next step.'' (C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both): C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Any improvement at your next startup?

Question owner

Here we ago again! Another forced update has given me problems! Uninstall and reinstall then waste more time setting it up again, only to find the next forced update crashes something else. Given the amount of times that Firefox updates cause problems, and given that it still ignores all settings and updates regardless there should be a restore option, by now. The solution would be for Firefox to leave me be when it is working and I have tried everything to stop it updating. Time to abandon this crap and move onto chrome.

Here we ago again! Another forced update has given me problems! Uninstall and reinstall then waste more time setting it up again, only to find the next forced update crashes something else. Given the amount of times that Firefox updates cause problems, and given that it still ignores all settings and updates regardless there should be a restore option, by now. The solution would be for Firefox to leave me be when it is working and I have tried everything to stop it updating. Time to abandon this crap and move onto chrome.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Hi AnnieBody, there have not been any Firefox releases since 66.0.2 on March 27th.

Do you have any third party updaters that may be juggling the software on your PC? These often come with free software downloads and shovel unwanted programs onto your system. If you haven't done a malware scrub-down recently, it may be worth a try: Troubleshoot Firefox issues caused by malware.

Hi AnnieBody, there have not been any Firefox releases since 66.0.2 on March 27th. Do you have any third party updaters that may be juggling the software on your PC? These often come with free software downloads and shovel unwanted programs onto your system. If you haven't done a malware scrub-down recently, it may be worth a try: [[Troubleshoot Firefox issues caused by malware]].
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

It turns out a Firefox 66.0.3 build is coming later today, but as far as I can tell, it hasn't been put into the release/update channel yet, so Firefox's internal updater should not see it yet. As of this moment, I don't see any release notes here: https://www.mozilla.org/firefox/releases/ It's very surprising that you got it already.

You can instruct Firefox never to check for updates:

Enterprise Option

As part of its increased Enterprise support, Mozilla provided an option to block Firefox from checking for updates via an external Policy file. This was designed for companies that manage updates centrally, and is not intended for people who would allow their software to fall behind and become vulnerable to attacks from the web.

For details, see:

Users who have tested this approach report it is a complete block: Firefox cannot discover updates even if you click the button in the About Firefox dialog. Extra work is required to update with this approach.

If you decide to try this, for your security, please monitor the release notes index page for new releases, or subscribe to updates from a site that keeps up with Firefox news:

Then if you still get updates, I would definitely suspect an external updater.

It turns out a Firefox 66.0.3 build is coming later today, but as far as I can tell, it hasn't been put into the release/update channel yet, so Firefox's internal updater should not see it yet. As of this moment, I don't see any release notes here: https://www.mozilla.org/firefox/releases/ It's very surprising that you got it already. You can instruct Firefox never to check for updates: '''''Enterprise Option''''' As part of its increased Enterprise support, Mozilla provided an option to block Firefox from checking for updates via an external Policy file. This was designed for companies that manage updates centrally, and is not intended for people who would allow their software to fall behind and become vulnerable to attacks from the web. For details, see: * [[Customizing Firefox Using policies.json]] * https://github.com/mozilla/policy-templates/blob/master/README.md (look for DisableAppUpdate) Users who have tested this approach report it is a complete block: Firefox cannot discover updates even if you click the button in the About Firefox dialog. Extra work is required to update with this approach. If you decide to try this, for your security, please monitor the release notes index page for new releases, or subscribe to updates from a site that keeps up with Firefox news: * https://www.mozilla.org/firefox/releases/ * https://www.ghacks.net/category/firefox/ Then if you still get updates, I would definitely suspect an external updater.

Question owner

First of all I do not have the software version you are referring to. Secondly, YOU CANNOT PREVENT FIREFOX FROM FORCING AN UPDATE. This has been covered by me several times. Changing options, about: config etc. does nothing. Each time Firefox updates and overwrites my settings. Th only time I know about it is when I get a message telling me to turn it off and then on again. I have complained most bitterly about this on previous support queries. If I had my way then I would be using a version that 1. Works 2. Works with Roboform. I finished up having to pay for a Roboform upgrade to continue using Firefox. Sick of it now, and sick of being told I can syop updates when Firefox clearly ignores everything I put in its way to stop them from occurring. My policy is "if it ain't broke, don't fix it". So when it works, I want it left alone. The same policy for my programs. I don't see why I have to put up with updates that stop it working properly. Why anybody would want to use Firefox for a business is beyond me! CRAP CRAP CRAP!

First of all I do not have the software version you are referring to. Secondly, YOU CANNOT PREVENT FIREFOX FROM FORCING AN UPDATE. This has been covered by me several times. Changing options, about: config etc. does nothing. Each time Firefox updates and overwrites my settings. Th only time I know about it is when I get a message telling me to turn it off and then on again. I have complained most bitterly about this on previous support queries. If I had my way then I would be using a version that 1. Works 2. Works with Roboform. I finished up having to pay for a Roboform upgrade to continue using Firefox. Sick of it now, and sick of being told I can syop updates when Firefox clearly ignores everything I put in its way to stop them from occurring. My policy is "if it ain't broke, don't fix it". So when it works, I want it left alone. The same policy for my programs. I don't see why I have to put up with updates that stop it working properly. Why anybody would want to use Firefox for a business is beyond me! CRAP CRAP CRAP!
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

AnnieBody said

First of all I do not have the software version you are referring to.

When you originally posted, it indicated Firefox 66 and you mentioned 66.0.2. What version do you have?

Secondly, YOU CANNOT PREVENT FIREFOX FROM FORCING AN UPDATE.

The method I mentioned works in Firefox 60 ESR or in recent regular releases. I don't know what version you use.

Each time Firefox updates and overwrites my settings.

Routine updates should not overwrite your settings. When you are going from an ancient version to a newer one, Firefox may suggest a Refresh, which moves your profile folder with your settings to your desktop inside a folder named Old Firefox Data. If you have that scenario, you can do a little copy/pasting as described here: https://support.mozilla.org/questions/1152951

I have complained most bitterly about this on previous support queries.

The last thread I see referring to upgrades was when Firefox 57 was released and you wanted to stay on Firefox 56. Are you trying to stay on Firefox 56 forever? Don't do that; either use new Firefox releases or migrate your Firefox 56 profile to Waterfox, which is a third party evolution of Firefox 56 (while it lasts; who knows how long it will be maintained).

''AnnieBody [[#answer-1212751|said]]'' <blockquote> First of all I do not have the software version you are referring to.</blockquote> When you originally posted, it indicated Firefox 66 and you mentioned 66.0.2. What version do you have? <blockquote>Secondly, YOU CANNOT PREVENT FIREFOX FROM FORCING AN UPDATE.</blockquote> The method I mentioned works in Firefox 60 ESR or in recent regular releases. I don't know what version you use. <blockquote>Each time Firefox updates and overwrites my settings.</blockquote> Routine updates should not overwrite your settings. When you are going from an ancient version to a newer one, Firefox may suggest a Refresh, which moves your profile folder with your settings to your desktop inside a folder named Old Firefox Data. If you have that scenario, you can do a little copy/pasting as described here: https://support.mozilla.org/questions/1152951 <blockquote>I have complained most bitterly about this on previous support queries.</blockquote> The last thread I see referring to upgrades was when Firefox 57 was released and you wanted to stay on Firefox 56. Are you trying to stay on Firefox 56 forever? Don't do that; either use new Firefox releases or migrate your Firefox 56 profile to Waterfox, which is a third party evolution of Firefox 56 (while it lasts; who knows how long it will be maintained).

Question owner

I am sorry you cannot view the attachment. Another problem with Firefox perhaps? Thank you for confirming that it is not possible to fix Firefox updates, meaning I have to put up with it breaking a working system. Although, It would have been nice to be told the truth before. As I have stated, I'll stick with Chrome from now on. It works!

I am sorry you cannot view the attachment. Another problem with Firefox perhaps? Thank you for confirming that it is not possible to fix Firefox updates, meaning I have to put up with it breaking a working system. Although, It would have been nice to be told the truth before. As I have stated, I'll stick with Chrome from now on. It works!
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

AnnieBody said

I am sorry you cannot view the attachment. Another problem with Firefox perhaps?

Do you mean on this post? The attachment is very visible. As far as I can tell, it is your first attachment in this thread. Was there another one?

Thank you for confirming that it is not possible to fix Firefox updates, meaning I have to put up with it breaking a working system.

I didn't say that. Also, Firefox 66.0.2 should not update to itself. Many things appear to be going wrong on your system, judging from where this thread started.

If you are not interested in further troubleshooting Firefox, please enjoy your experience with Google Chrome.

If you decide you want to resume using Firefox, here are my suggestions:

(1) Delete the updates folder to cancel any staged updates in case one is stuck there. See the solution in this thread: https://support.mozilla.org/questions/1227920

(2) Use the option to control when updates install, which is on the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type updat and Firefox should filter to the "Firefox Updates" section.

Select the radio button for "Check for updates but let you choose to install them" to manage update timing. When an update is available, Firefox should drop the following doorhanger from the menu button:

If it's bad timing, you can click "Not Now" to snooze it for 12 hours.

(3) If you do not want to receive those notifications, you can use the Enterprise Option in my second post of this morning to apply a "never check for updates" policy to your Firefox 66.0.2.

''AnnieBody [[#answer-1212782|said]]'' <blockquote> I am sorry you cannot view the attachment. Another problem with Firefox perhaps?</blockquote> Do you mean on this post? The attachment is very visible. As far as I can tell, it is your first attachment in this thread. Was there another one? <blockquote>Thank you for confirming that it is not possible to fix Firefox updates, meaning I have to put up with it breaking a working system.</blockquote> I didn't say that. Also, Firefox 66.0.2 should not update ''to itself''. Many things appear to be going wrong on your system, judging from where this thread started. If you are not interested in further troubleshooting Firefox, please enjoy your experience with Google Chrome. If you decide you want to resume using Firefox, here are my suggestions: (1) Delete the updates folder to cancel any staged updates in case one is stuck there. See the solution in this thread: https://support.mozilla.org/questions/1227920 (2) Use the option to control when updates install, which is on the Options page: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''updat'' and Firefox should filter to the "Firefox Updates" section. Select the radio button for "Check for updates but let you choose to install them" to manage update timing. When an update is available, Firefox should drop the following doorhanger from the menu button: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-04-10-10-14-00-6a228d.png"> If it's bad timing, you can click "Not Now" to snooze it for 12 hours. (3) If you do not want to receive those notifications, you can use the Enterprise Option in [https://support.mozilla.org/questions/1255353#answer-1212730 my second post of this morning] to apply a "never check for updates" policy to your Firefox 66.0.2.

Question owner

Just for the record. I have had to restore a previous Windows 7 backup. This used version 65.0.1 which worked without problem. Now Firefox has forced another automatic update to 66.0.2 it no the sound and Deezer no longer works. But, apparently the Firefox update is not the issue. Now, if only there were a way to prevent Firefox from forcing updates, then I would not have a problem. Go figure!

Just for the record. I have had to restore a previous Windows 7 backup. This used version 65.0.1 which worked without problem. Now Firefox has forced another automatic update to 66.0.2 it no the sound and Deezer no longer works. But, apparently the Firefox update is not the issue. Now, if only there were a way to prevent Firefox from forcing updates, then I would not have a problem. Go figure!

Question owner

Did I also mention that this version no longer works for many websites too, including this one!! Instead of nice graphics etc. you just get stream of text. If Firefox is aiming for a retro feel for an internet experience it has succeeded. In the meantime, I prefer a better user experience. Can someone please advise how I get this crap off my PC.

Did I also mention that this version no longer works for many websites too, including this one!! Instead of nice graphics etc. you just get stream of text. If Firefox is aiming for a retro feel for an internet experience it has succeeded. In the meantime, I prefer a better user experience. Can someone please advise how I get this crap off my PC.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

If you are not interested in making Firefox work on your system, see: Uninstall Firefox from your computer.

If you are not interested in making Firefox work on your system, see: [[Uninstall Firefox from your computer]].