Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search, irrelevant suggestions in address bar

  • 7 replies
  • 1 has this problem
  • 81 views
  • Last reply by McCoy

more options

Firefox keeps suggesting me absolutely irrelevant and rubbish sites when I start using the address bar. For example, when I start to type in "dpt" to get to https://cordis.europa.eu/dpt that I use every day, I get "http://dptnt.com/" first, that is a website that I have never used. Note that unchecking the option "Show search suggestions ahead of browsing history in address bar results" or even unchecking the "Provide search suggestions" in the Search Options of firefox, simply does nothing. The suggestions come out as usual. The site "http://dptnt.com/" does not exist in my bookmarks and in my history. It is annoying, because for some texts, inapropriate sites such as porn sites come out as suggestions. My system has been checked for viruses, cache and history has been cleaned up. I even did a clean firefox install.

Attached screenshots

Chosen solution

Hello zanxion72,

In case you don't want to see any suggestions under the address bar, would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar : keyword.enabled

and set its value to false

Then close and restart Firefox.


Should you not want to see anything appear under the address bar - go to the about:config page and type in the search bar :

browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

Then close and restart Firefox.

Read this answer in context 👍 1

All Replies (7)

more options

See this: https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs

The Firefox address bar displays a page's web address (URL). We call it the Awesome Bar because it remembers the pages you’ve visited before and also allows you to search and navigate the web.

And in that support article is says:

Firefox will also suggest popular search suggestions from the default search engine.

What you are seeing is probably search suggestions. https://support.mozilla.org/en-US/kb/search-suggestions-firefox

You can disable the display of search suggestions as shown in that 2nd support article. Un-check Show search suggestions in the address bar results.

more options

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0.156

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Chosen Solution

Hello zanxion72,

In case you don't want to see any suggestions under the address bar, would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar : keyword.enabled

and set its value to false

Then close and restart Firefox.


Should you not want to see anything appear under the address bar - go to the about:config page and type in the search bar :

browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

Then close and restart Firefox.

more options

the-edmeister said

See this: https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs
The Firefox address bar displays a page's web address (URL). We call it the Awesome Bar because it remembers the pages you’ve visited before and also allows you to search and navigate the web.

And in that support article is says:

Firefox will also suggest popular search suggestions from the default search engine.

What you are seeing is probably search suggestions. https://support.mozilla.org/en-US/kb/search-suggestions-firefox

You can disable the display of search suggestions as shown in that 2nd support article. Un-check Show search suggestions in the address bar results.

Could you please get in the trouble reading my problem? It seems that you are missing the problem here.

1. I have a problem with the suggestions!

2. If I uncheck the "Show search suggestions ahead of browsing history in address bar results", I still get the suggestions ahead of browsing history. That means the option "Show search suggestions ahead of browsing history in address bar results" simply does not work.

3. If I uncheck the "Provide search suggestions" option, the suggestions keep coming up! Which means that this option does not work too!

more options

McCoy said

Hello zanxion72, In case you don't want to see any suggestions under the address bar, would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar : keyword.enabled and set its value to false Then close and restart Firefox.

Should you not want to see anything appear under the address bar - go to the about:config page and type in the search bar :

browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

Then close and restart Firefox.

Setting the keyword.enabled to false did not work either. I do not want to disable anything, I just want to get rid of the silly ffox suggestions.

more options

McCoy said

Hello zanxion72, In case you don't want to see any suggestions under the address bar, would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar : keyword.enabled and set its value to false Then close and restart Firefox.

Should you not want to see anything appear under the address bar - go to the about:config page and type in the search bar :

browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

Then close and restart Firefox.

The first option did the trick! I had to kill Ffox task to get in effect! THANK YOU!

more options

zanxion72 said

The first option did the trick! I had to kill Ffox task to get in effect! THANK YOU!

My pleasure  ! Must be a relief .....