Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window.

  • 9 replies
  • 1 has this problem
  • 7333 views
  • Last reply by rongtw

more options

Hi I have firefox 64.0 ,,64 bit win10 Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window. is a regular occurrence almost daily now , i have tried several clean installs and i uninstall with revo uninstaller and remove all leftover files , then clean with Ccleaner . even removed files manually from Regit , done firefox refresh several time run with no no add ons, run in safe mode . But still i get , same error ???

Chosen solution

I've run into your problem in the past. Others gave good ideas to try. In addition,

If you update firefox and use a desktop shortcut to launch it, the command to start Fx in the shortcut has to match the exact path to the executable file - in Windows, "firefox.exe", if you accidentally or intentionally changed the install location. Always check that the path in the old shortcut vs. the path of newly installed firefox.exe.

In Fx profile manager (from Start > run line, enter: firefox.exe -p, If you ever specified a particular Fx version (in a given location to be the default Fx version AND / OR selected a profile in the profile mgr, & checked "use the selected profile w/o asking at startup," it will use that.

Sometimes for apparent reasons (or not), something is different in the shortcut start command (stuff happens).

The profiles.ini file holds all the different profiles' names, locations (sometimes old, non-existing profiles, which usually aren't a problem) and only ONE profile can be set as the default (will show Default=1 in profiles.ini). I've seen the wrong (unwanted) profile get marked as default in profiles.ini, when it's not the one you wanted. Profiles.ini is a simple text file you can edit, BUT MAKE A BACKUP COPY, before you open it & make changes.

IF... you create a new profile using Profile Mgr, you need to select that profile in Profile Mgr. IF... there's > 1 firefox installation, the one already marked "default browser" in Prefences/General, is the one it will use - until you change that. You MAY have launch the new Firefox version manually, then check in Preferences/General: "Make this the default browser," if it's not already the default.

Even to test a new profile, you need to open profile manager, create a new profile, GIVE IT a name, or it will use "Default." Select the new profile to use, or it will keep using the profile last selected as default. If the profile works, go back & select it in Profile Mgr

First close ALL existing firefox versions - even instances only shown as running in Task Manager (I assume that still exists in Win 10? press Ctrl + Alt + Del (ONLY once), or R-click the task bar & open Task Manager)

Read this answer in context 👍 1

All Replies (9)

more options

No Support yet :(

more options

Try to remove the parent.lock file in the profile folder.

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

See also:

more options

Sorry Cor-el , if you read previously i had done this without result . 2 days ago fresh installed win 10 and it happened today  :(

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Some possibilities to try:

  1. Are you running multiple installs of Firefox? (Check the applications folder )
  2. Do you have more than one profile enabled on this computer? Profiles - Where Firefox stores your bookmarks, passwords and other user data Using Multiple Profiles
  3. Are you clicking on the icon on the desktop or on the start menu, or Start screen (https://s3.amazonaws.com/quicklaptopcash/blog/4_splash_screen.jpg from Noah_SUMO)?
  4. Check in your Task Manger if you have more than one Firefox application running/

These are some of the situations where this might happen, but we want to find out what you are pressing to open a new window to get this message.

Than you, looking forward to your reply!

more options

Thanks for you responses , i have now created new profile, see it it works this time . Guigs i have task-bar shortcut where i start FF from :)

more options

Ok New profile and only one showing :( it just did it again

more options

Chosen Solution

I've run into your problem in the past. Others gave good ideas to try. In addition,

If you update firefox and use a desktop shortcut to launch it, the command to start Fx in the shortcut has to match the exact path to the executable file - in Windows, "firefox.exe", if you accidentally or intentionally changed the install location. Always check that the path in the old shortcut vs. the path of newly installed firefox.exe.

In Fx profile manager (from Start > run line, enter: firefox.exe -p, If you ever specified a particular Fx version (in a given location to be the default Fx version AND / OR selected a profile in the profile mgr, & checked "use the selected profile w/o asking at startup," it will use that.

Sometimes for apparent reasons (or not), something is different in the shortcut start command (stuff happens).

The profiles.ini file holds all the different profiles' names, locations (sometimes old, non-existing profiles, which usually aren't a problem) and only ONE profile can be set as the default (will show Default=1 in profiles.ini). I've seen the wrong (unwanted) profile get marked as default in profiles.ini, when it's not the one you wanted. Profiles.ini is a simple text file you can edit, BUT MAKE A BACKUP COPY, before you open it & make changes.

IF... you create a new profile using Profile Mgr, you need to select that profile in Profile Mgr. IF... there's > 1 firefox installation, the one already marked "default browser" in Prefences/General, is the one it will use - until you change that. You MAY have launch the new Firefox version manually, then check in Preferences/General: "Make this the default browser," if it's not already the default.

Even to test a new profile, you need to open profile manager, create a new profile, GIVE IT a name, or it will use "Default." Select the new profile to use, or it will keep using the profile last selected as default. If the profile works, go back & select it in Profile Mgr

First close ALL existing firefox versions - even instances only shown as running in Task Manager (I assume that still exists in Win 10? press Ctrl + Alt + Del (ONLY once), or R-click the task bar & open Task Manager)

more options

Yes :) JoeBt now that makes sence , i had used the same shortcut to start Firefox , as you say its odd how firefox shorcut will not match , anyhow i uninstalled removed the shortcut . Hopefully its fixed Thanks