X
Tap here to go to the mobile version of the site.

Support Forum

Content getting white spaces while scrolling in firefox browser alone.

Posted

White spaces occurring while scrolling the content with virtual scrolling feature. If we can check this issue with inspect mode it will be working properly there is no white spaces occurred. But in default, it won't be work properly. Can you please tell me how to resolve this?

White spaces occurring while scrolling the content with virtual scrolling feature. If we can check this issue with inspect mode it will be working properly there is no white spaces occurred. But in default, it won't be work properly. Can you please tell me how to resolve this?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.110 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4195 solutions 58545 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
cor-el
  • Top 10 Contributor
  • Moderator
17350 solutions 156825 answers

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting for changes to take effect. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

Thanks for the update. This solution is not work for me. My problem is the inspect element mode is in opened then the scrolling will works properly. But it is not in open white spaces occurred and latterly update the content.

Thanks for the update. This solution is not work for me. My problem is the inspect element mode is in opened then the scrolling will works properly. But it is not in open white spaces occurred and latterly update the content.

Question owner

Please refer the below link https://jpg3ck-a3azuq.stackblitz.io/

Please refer the below link https://jpg3ck-a3azuq.stackblitz.io/
FredMcD
  • Top 10 Contributor
4195 solutions 58545 answers

While I do see 'blank' areas, the board works fine. Can you post a screenshot of what you see?


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

While I do see 'blank' areas, the board works fine. Can you post a screenshot of what you see? In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!

Question owner

Hi

Thanks for the response.

Kindly scroll the content to see the problem. And refer the below screenshot.

Note: When we scroll the content initially the white space occurs and laterlly the content will rendered. But this same process has worked well in other browser like Google Chrome.

Thank you!

Hi Thanks for the response. Kindly scroll the content to see the problem. And refer the below screenshot. Note: When we scroll the content initially the white space occurs and laterlly the content will rendered. But this same process has worked well in other browser like Google Chrome. Thank you!

Modified by Vengatesh_Maniraj

FredMcD
  • Top 10 Contributor
4195 solutions 58545 answers

Your screenshot is blurred. I bounced all over the https://jpg3ck-a3azuq.stackblitz.io/ table and had no problem.


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Your screenshot is blurred. I bounced all over the https://jpg3ck-a3azuq.stackblitz.io/ table and had no problem. Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link}

Question owner

Hi

Kindly check the below image. That was occurred when we scroll the content through mouse wheel/touch move actions.

Here, content will be rendered. Its not a problem. but while scrolling the content, white space occurred until the content render.

Thank you

Hi Kindly check the below image. That was occurred when we scroll the content through mouse wheel/touch move actions. Here, content will be rendered. Its not a problem. but while scrolling the content, white space occurred until the content render. Thank you

Modified by Vengatesh_Maniraj

FredMcD
  • Top 10 Contributor
4195 solutions 58545 answers

This is what I am seeing. Did you follow the instructions in my last post?

This is what I am seeing. Did you follow the instructions in my last post?

Question owner

Yes.

Content will be rendered without white spaces when the scroll action has stopped and this is what you are seeing. But before rendering the content, white spaces occurs for some seconds and then render the content. That is my problem.

Yes. Content will be rendered without white spaces when the scroll action has stopped and this is what you are seeing. But before rendering the content, white spaces occurs for some seconds and then render the content. That is my problem.

Modified by Vengatesh_Maniraj

jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Interesting. When I hold the mouse pointer down in a blank area of the scrollbar to repeatedly scroll the table rows down (page after page), there are no gaps, but when I flick on the touchpad to scroll quickly, there is a noticeable lag (at least half a second) in filling in the new table rows.

How long is the lag on yours, or are they never filling in?

Interesting. When I hold the mouse pointer down in a blank area of the scrollbar to repeatedly scroll the table rows down (page after page), there are no gaps, but when I flick on the touchpad to scroll quickly, there is a noticeable lag (at least half a second) in filling in the new table rows. How long is the lag on yours, or are they never filling in?

Question owner

Can anybody tell me how to fix it?

Can anybody tell me how to fix it?

Modified by Vengatesh_Maniraj

jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

This page design is way too complicated for me. Do you know whether this issue is specific to your project or is a general issue with these Syncfusion components in Firefox? Can they provide support?

https://www.syncfusion.com/

This page design is way too complicated for me. Do you know whether this issue is specific to your project or is a general issue with these Syncfusion components in Firefox? Can they provide support? https://www.syncfusion.com/

Question owner

In this layout some kind of conditions are used. When this condition is satisfied then the next set of rows will be prepared and rendered on the dom. While preparing and rendering the rows it will take some times so that the white space occurs until the rows render. But this scenario has been worked in other browsers like Google Chrome(without white space).

Is there any specific animations to manage those kind of time delay for Firefox browser?

In this layout some kind of conditions are used. When this condition is satisfied then the next set of rows will be prepared and rendered on the dom. While preparing and rendering the rows it will take some times so that the white space occurs until the rows render. But this scenario has been worked in other browsers like Google Chrome(without white space). Is there any specific animations to manage those kind of time delay for Firefox browser?

Modified by Vengatesh_Maniraj

Question owner

when the "inspect element" has in opened then this problem is not occurred. can you please provide a better animation for this?

when the "inspect element" has in opened then this problem is not occurred. can you please provide a better animation for this?

Question owner

How do I attach a video here?

How do I attach a video here?
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Vengatesh_Maniraj said

when the "inspect element" has in opened then this problem is not occurred. can you please provide a better animation for this?

I don't understand what you mean by this request.

If you mean you need someone to create a video for you, I think it makes more sense for you to do that.

If you mean that you want Firefox to work differently, that is beyond the scope of this support forum. You could file a bug, but please assume it will be at least three months and potentially longer before any changes are released.

https://bugzilla.mozilla.org/

If you need help fixing your app now, please try the vendor as I suggested before.

''Vengatesh_Maniraj [[#answer-1217030|said]]'' <blockquote> when the "inspect element" has in opened then this problem is not occurred. '''can you please provide a better animation for this?''' </blockquote> I don't understand what you mean by this request. If you mean you need someone to create a video for you, I think it makes more sense for you to do that. If you mean that you want Firefox to work differently, that is beyond the scope of this support forum. You could file a bug, but please assume it will be at least three months and potentially longer before any changes are released. https://bugzilla.mozilla.org/ If you need help fixing your app now, please try the vendor as I suggested before.
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Vengatesh_Maniraj said

How do I attach a video here?

Provide a link to the site where you are hosting the video.

''Vengatesh_Maniraj [[#answer-1217031|said]]'' <blockquote> How do I attach a video here? </blockquote> Provide a link to the site where you are hosting the video.

Question owner

Thank you @jscher2000.

Here I have attached two GIF files.

Without_Inspect_Element.gif - In this gif, we are facing white space problem while scrolling.

With_Inspect_Element.gif - In this gif, white space is not occurs.

In my case I need the behavior like With_Inspect_Element.gif . How can I achieve this?

Thank you @jscher2000. Here I have attached two GIF files. '''Without_Inspect_Element.gif''' - In this gif, we are facing white space problem while scrolling. '''With_Inspect_Element.gif''' - In this gif, white space is not occurs. In my case I need the behavior like '''With_Inspect_Element.gif''' . How can I achieve this?
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

I will add one thing to my earlier comment --

jscher2000 said

This page design is way too complicated for me. Do you know whether this issue is specific to your project or is a general issue with these Syncfusion components in Firefox? Can they provide support? https://www.syncfusion.com/

-- and that is a link to this article: Where to go for developer support.

I will add one thing to my earlier comment -- ''jscher2000 [[#answer-1215676|said]]'' <blockquote> This page design is way too complicated for me. Do you know whether this issue is specific to your project or is a general issue with these Syncfusion components in Firefox? Can they provide support? https://www.syncfusion.com/ </blockquote> -- and that is a link to this article: [[Where to go for developer support]].