Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I changed my computer time temporarily to 2015 then my firefox addons are now "legacy" although they are working perfectly fine before

  • 2 replies
  • 1 has this problem
  • 24 views
  • Last reply by cor-el

more options

So this is what happened: 1. I changed my date to December 2015 (to try and troubleshoot a crashing program) 2. Gave up and tried to search for other answers 3. Noticed that my addons are missing and are now "Legacy" 4. Fixed the date to the current date and restarted firefox 5. Addons still Legacy

Steps tried to fix issue 1. Update addons (nope) 2. Tweak about:config?filter=extensions.legacy to try and allow legacy (nope) 3. Ask the community (Ongoing)

Any ideas?

So this is what happened: 1. I changed my date to December 2015 (to try and troubleshoot a crashing program) 2. Gave up and tried to search for other answers 3. Noticed that my addons are missing and are now "Legacy" 4. Fixed the date to the current date and restarted firefox 5. Addons still Legacy Steps tried to fix issue 1. Update addons (nope) 2. Tweak about:config?filter=extensions.legacy to try and allow legacy (nope) 3. Ask the community (Ongoing) Any ideas?

Chosen solution

Try to delete the extensions.* files (extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder with Firefox closed to reset the extensions registry.

New files will be created when required.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 0

All Replies (2)

more options

Hi Barkbark, Firefox considers an extension to be a Legacy extension if it uses older interfaces instead of the "WebExtensions" API. It shouldn't matter what the date is on your computer; Legacy extensions don't run In Firefox 57+.

Do you think newer extensions are being mislabeled? Do you want to share your extensions list? You can copy/paste it from the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down past "Application Basics" and "Firefox Features" to "Extensions". Then you can select and copy the table that follows (not the entire page, please, that's too much information) using either Ctrl+c or right-click > Copy and then paste it into a reply. It will be messy, but we're used it.

more options

Chosen Solution

Try to delete the extensions.* files (extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder with Firefox closed to reset the extensions registry.

New files will be created when required.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.