Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I am getting a "Performing a tls handshake" when I'm trying to view a webpage. How can I fix this?

  • 8 replies
  • 2 have this problem
  • 5706 views
  • Last reply by Pj

more options

I have Firefox 63.0.1 64 bit using Win 7. After the latest update, I frequently get the "performing a tls handshake" when trying to view a webpage. After 7 to 8 minutes I get a message saying "Secure Connection Failed. The connection to the server was reset while the page was loading. The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem." I've researched this problem and haven't come up up with an answer as to how to correct this. Does anyone know how to correct this?

Attached screenshots

Chosen solution

I have Avast security software installed. I followed the instructions under: “Troubleshoot the Secure Connection Failed error message Security software conflict AVAST and AVG security products” I went into the Avast settings, then into Components. On Customize, I unchecked the ‘Enable HTTPS Scanning’. It worked. I can now view webpages again almost instantaneously. Thank you for your help.

Read this answer in context 👍 0

All Replies (8)

more options
more options

Chosen Solution

I have Avast security software installed. I followed the instructions under: “Troubleshoot the Secure Connection Failed error message Security software conflict AVAST and AVG security products” I went into the Avast settings, then into Components. On Customize, I unchecked the ‘Enable HTTPS Scanning’. It worked. I can now view webpages again almost instantaneously. Thank you for your help.

more options

Glad to help. Safe Surfing.

more options

dutchjim said

I have Avast security software installed. I followed the instructions under: “Troubleshoot the Secure Connection Failed error message Security software conflict AVAST and AVG security products.” I went into the Avast settings, then into Components. On Customize, I unchecked the Enable HTTPS Scanning. It worked. I can now view webpages again almost instantaneously. Thank you for your help.

Avast fixed that a while back. Are you running the latest Avast? Avast does not recommend leaving HTTPS un-scanned.


~ Pj

more options

Yes, I have the latest version of Avast.

I sent a message to Avast technical support explaining the problem and the fact that I disabled HTTPS Scanning.

Abbreviated message to Avast: "Since Avast doesn’t recommend leaving HTTPS un-scanned, can you offer me a solution to this?"

I am waiting to see what they say.

Thank you for the information you provided.

more options

Avast told me to repair and update Avast security in the Control Panel. I did that, then re-started my computer. I then enabled HTTPS scanning in Avast. It seems to work now. I can view webpages without getting the 'performing a tls handshake' and then getting the message 'secure connection failed'. I posted a picture of the Avast settings, with some notes on how I got to the main settings window. Thank you pj.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

more options

dutchjim said

  • Avast told me to repair and update Avast security in the Control Panel. I did that, then re-started my computer.
  • I then enabled HTTPS scanning in Avast. It seems to work now.
  • I can view webpages without getting the 'performing a TLS handshake' and then getting the message 'secure connection failed'.
  • I posted a picture of the Avast settings, with some notes on how I got to the main settings window.
  • Thank you Pj.

So, your Avast was out-of-date and/or you had to 'Repair' Avast?

~Pj