Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop Firefox to eat RAM?

  • 2 replies
  • 1 has this problem
  • Last reply by Shadow110

more options


this is Michael from Germany, please use simple English.

I have 32 GB RAM installed in my Computer. I am used to have open more than 100 Tabs at a time. Firefox happens to eat my RAM each time. Right now the top 5 RAM using processes on my Computer are:

firefox.exe -> 7.063.744 K firefox.exe -> 6.026.804 K firefox.exe -> 4.479.864 K firefox.exe -> 1.130.908 K firefox.exe -> 907.720 K

I live like this since few years so its not a new problem. I updated my Computer from 16 GB RAM to 32 GB RAM 3 years ago because Firefox was eating RAM and i thought it might have a maximum eating amount. But it doesn't.

Well yes how i read in few articels about this issue: Yes RAM should be used otherwise RAM ist wasted.

But: It should not be used so much RAM that other programms don't have anything left. When my Computer reaches 31GB used RAM Windows and all programs begin to lag.

Yes Firefox should use RAM to be faster but i wish it to stop at 15 GB. I installed the extension "Auto Tab Discard" and told it to discard all tabs not used since 10 minutes. Only all active tabs (one tab per window) cannot be discarded.

But "Auto Tab Discard" didn't reduce the RAM-usage. about:memory -> "Minimize memory usage" didn't too.

Is there any option to limit the RAM usage to 15 GB?

Thanks - Enomine

All Replies (2)

more options


The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

HI, I think you were looking for some more info on ram and processes. The Refresh may tone things down but please look at this : To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :