Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pages only partially loading

  • 6 replies
  • 1 has this problem
  • 2109 views
  • Last reply by FredMcD

more options

I have Firefox Quantum 59.0.3 (64-bit) on a Windows 8.1 desktop PC. I have noticed that not all the windows on some web pages are loading correctly in Firefox but do load correctly in IE11. Attached is one example from today. From this you can see that using IE11 there is a section 'Your Details' that is completely missing from the Firefox screen. As this is a screen to do online voting it was very obvious that something was missing. I cannot find any questions to do with this issue in version 59 hence my submission.

Attached screenshots

Chosen solution

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Read this answer in context 👍 1

All Replies (6)

more options

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.140

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Chosen Solution

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Removed Flash Player and then reinstalled it for Firefox. Problem still there. Didn't understand part about install Active X for IE and plugin for Firefox, sorry. Onboard graphics driver updated, problem still exists. Safe mode solved the problem but an inconvenient solution every time a site does not display some part. Tracking protection had kicked in and there was a shield icon. Pity this function does not display a more obvious message that blocking of page content has occured. Disabled tracking protection for this secure known site and problem solved. Thank you for your time and effort, well done.

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

I disabled hardware acceleration, all extensions, add ons and plugins. Problem persists. The only solution was, as I previously advised, to disable tracking protection for this secure known site and problem solved. I will stick with this solution.

more options

That was very good work. Well done.