Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Win 10 is forcing Edge use blocks FF and Chrome from running how do you fix this? FF will not start

  • 4 replies
  • 1 has this problem
  • 1 view
  • Last reply by Shadow110

more options

Win 10 is stopping all browsers except Edge from running. I have 2 puters with this problem. I have fully removed and reinstalled to no avail. How do I get my firefox to run again? It will not even start. Microsoft is forcing users to use Edge

Win 10 is stopping all browsers except Edge from running. I have 2 puters with this problem. I have fully removed and reinstalled to no avail. How do I get my firefox to run again? It will not even start. Microsoft is forcing users to use Edge

All Replies (4)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

MICROSOFT IS FORCING THE USE OF EDGE BY NOT ALLOWING OTHER BROWSERS TO LOAD ! THIS WAS DONE IN THE LAST UPDATE

more options
more options

Hi, will not help If Firefox will not start.

Please do this :

  • Repair System Registry and Files

Find the Dos Prompt or Powershell then Right Click and Run as Administrator then : Copy/Paste to Dos Window : DISM /Online /Cleanup-Image /RestoreHealth then hit Enter. Reboot when completed. Note : DISM goes up to Microsoft for new files.

Then : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Do not start Firefox if can help it.

At this point we are hoping that after installing the above you can now do below. Please follow this to try and change that. In Win 10 --> Settings --> Apps --> Default Apps --> Web Browser

If it is showing Edge please Click on Edge and you should then get the list of what to change to, Firefox.

At this point we are now hoping Firefox starts and is your default browser.

Please let us know if this solved your issue or if need further assistance.