X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

How can I permanently disable the following firefox warning: "Your Firefox is critically out of date. An update is required to stay secure"

Posted

Is there any way to permanently deactivate the "Your Firefox is critically out of date. An update is required to stay secure" warning, despite the obvious of updating Firefox, which in my case is not an option?

Kind regards, Marco

Is there any way to permanently deactivate the "Your Firefox is critically out of date. An update is required to stay secure" warning, despite the obvious of updating Firefox, which in my case is not an option? Kind regards, Marco

Chosen solution

More on Heartbeat here, including an "Opting out" section to disable it: Rate your Firefox experience, surveys and out of date messages (Heartbeat)

Read this answer in context 18

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.89 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4396 solutions 61664 answers

What is your current Firefox? How and where are you getting this message?

. Whenever you get a message / popup that software / files need to be updated;

DO NOT USE ANY OF THE PROVIDED LINKS

While this may be a legitimate message, it could also be Malware or a Virus. Anytime you want or need to check for upgrades, go to the website of the True Owner of the program in question. For example, to check out Firefox, go to https://www.mozilla.org {web link}

You can report such a site at; Google Report Phishing Page {web link} which is the same when done while on site by going to Help > Report Web Forgery

Help us safeguard Mozilla’s trademarks by reporting misuse {web link}

For over a year, an epidemic of Fake Update Notices have been popping up all over the place. https://support.mozilla.org/en-US/kb/forum-response-i-found-fake-firefox-update

What is your current Firefox? How and where are you getting this message? . '''Whenever you get a message / popup that''' '''software / files need to be updated;''' <u>'''DO NOT USE ANY OF'''</u> <u>'''THE PROVIDED LINKS'''</u> While this may be a legitimate message, it could also be <u>'''Malware or a Virus'''</u>. Anytime you want or need to check for upgrades, go to the website of the <u>'''True Owner'''</u> of the program in question. For example, to check out Firefox, go to '''https://www.mozilla.org''' {web link} You can report such a site at; '''[http://www.google.com/safebrowsing/report_phish/ Google Report Phishing Page]''' {web link} which is the same when done while on site by going to '''Help > Report Web Forgery''' '''[http://www.mozilla.org/en-US/legal/fraud-report/ Help us safeguard Mozilla’s trademarks by reporting misuse]''' {web link} For over a year, an epidemic of '''Fake Update Notices''' have been popping up all over the place. https://support.mozilla.org/en-US/kb/forum-response-i-found-fake-firefox-update

Question owner

I am using Firefox 55 (portable version) and the warning is triggered a few seconds after Firefox is launched. I've added a screenshot. The starting website is created by myself and only showing some localhost information, so I can rule out any malware or virus.

I am using Firefox 55 (portable version) and the warning is triggered a few seconds after Firefox is launched. I've added a screenshot. The starting website is created by myself and only showing some localhost information, so I can rule out any malware or virus.
Mkll 314 solutions 1978 answers

Get the latest portable version from here: https://portableapps.com/apps/internet/firefox_portable

Your version 55, is out of date -- the latest version is 57.0.1. You cannot disable this warning.

Get the latest portable version from here: https://portableapps.com/apps/internet/firefox_portable Your version 55, is out of date -- the latest version is 57.0.1. You cannot disable this warning.

Modified by Mkll

FredMcD
  • Top 10 Contributor
4396 solutions 61664 answers

I was just told by Tylerdowner that Heartbeat (see the symbol on the message) is part of Firefox.

I was just told by '''[https://support.mozilla.org/en-US/user/Tylerdowner Tylerdowner]''' that '''Heartbeat''' (see the symbol on the message) is part of Firefox.
AliceWyman
  • Moderator
241 solutions 2619 answers

Chosen Solution

More on Heartbeat here, including an "Opting out" section to disable it: Rate your Firefox experience, surveys and out of date messages (Heartbeat)

More on Heartbeat here, including an "Opting out" section to disable it: [[Rate your Firefox experience (Heartbeat)]]
FredMcD
  • Top 10 Contributor
4396 solutions 61664 answers

Thank you, Alice.

Thank you, Alice.

Question owner

AliceWyman said

More on Heartbeat here, including an "Opting out" section to disable it: Rate your Firefox experience, surveys and out of date messages (Heartbeat)

Thank you Alice, that solved my problem!

''AliceWyman [[#answer-1044929|said]]'' <blockquote> More on Heartbeat here, including an "Opting out" section to disable it: [[Rate your Firefox experience (Heartbeat)]] </blockquote> Thank you Alice, that solved my problem!
user633449 1539 solutions 10745 answers

Note, you should not use old versions of firefox. We would almost rather you use another browser that you keep up to date than an out of date Firefox. Please update ASAP

Note, you should not use old versions of firefox. We would almost rather you use another browser that you keep up to date than an out of date Firefox. Please update ASAP
Ooker 0 solutions 12 answers

I can't find the `browser.selfsupport.url` option, only `browser.selfsupport.enabled` which is already disabled. The preference `extensions.shield-recipe-client.enabled` is there though

I can't find the `browser.selfsupport.url` option, only `browser.selfsupport.enabled` which is already disabled. The preference `extensions.shield-recipe-client.enabled` is there though
FredMcD
  • Top 10 Contributor
4396 solutions 61664 answers

Try looking for just; browser.selfsupport

Try looking for just; '''browser.selfsupport'''
AliceWyman
  • Moderator
241 solutions 2619 answers

Ooker said

The preference `extensions.shield-recipe-client.enabled` is there though

That's the one you should disable. Ref: ("Opting out" section) Rate your Firefox experience, surveys and out of date messages (Heartbeat)


  1. In the address bar, type about:config and press Enter.
    The about:config "This might void your warranty!" warning page may appear. Click I accept the risk! to continue to the about:config page.
  2. Find the preference extensions.shield-recipe-client.enabled
  3. Set the value of the preference to "false" by double clicking on it.

If you need more help, please ask a new question since this one is for helping marco.castrucci and it's been marked "solved".

I'll close this thread.

''Ooker [[#answer-1088320|said]]'' <blockquote> The preference `extensions.shield-recipe-client.enabled` is there though </blockquote> That's the one you should disable. Ref: ("Opting out" section) [[Rate your Firefox experience (Heartbeat)]] ----- # In the address bar, type '''about:config''' and press Enter.<br>The about:config "This might void your warranty!" warning page may appear. Click I accept the risk! to continue to the about:config page. #Find the preference ''extensions.shield-recipe-client.enabled'' #Set the value of the preference to "false" by double clicking on it. ----- If you need more help, please ask a new question since this one is for helping marco.castrucci and it's been marked "solved". I'll close this thread.