Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Version 57 is not working on only ONE computer (iMac mid-2011) Can Someone HELP?

  • 6 replies
  • 1 has this problem
  • 33 views
  • Last reply by kevsfox1

more options

I'm just a Firefox USER, not a developer. Although I don't like a lot of things, it is not working on my iMac.

It works fine on my Macbook Pro, and my Dell Inspiron. However on my iMac, which is my primary device, websites don't seem to have a CSS sheet attached.

What would cause this on a single computer? What can I do to make Firefox work? I don't want to change browsers now.

I have a basic understanding of web page HTML and CSS, so if you have a cure and instructions to apply universally on my iMac, I would REALLY appreciate it.

Chosen solution

Thanks for your input. Let's see:

  • Page style is "basic page style"
  • The layout isn't correct either-but probably due to CSS
  • After cache clearing still no color
  • My iMac is current running iOS Sierra 10.12.6

And... Finally The winner is NEVER on the Colors selector THANK YOU SO MUCH!!!

Read this answer in context 👍 0

All Replies (6)

more options

Can you check if the stylesheets are loading correctly?

  1. Go to a page that has the problem.
  2. Go to Tools menu > Web Developer > Network
  3. Reload the page.
  4. Click on the CSS tab.
  5. Take a screenshot of what you see, and attach it here.
more options

The above may be very illuminating! Two other initial thoughts:

Have you noticed any errors related to HTTPS connections?

Sometimes users will get errors and make exceptions for the site, only to realize the site displayed in an unstyled form because the exception doesn't cover the support servers the site uses.

In that scenario, we request that you take a pause and let us diagnose what is causing the certificate issues.

Have you already tried clearing Firefox's cache?

In case cached style sheets have become corrupted, see: How to clear the Firefox cache

more options

Thanks for responding. Something DOES seem wrong. see attached image. I also have an image for the same page from my Macbook Pro

more options

kevsfox1 said

Thanks for responding. Something DOES seem wrong. see attached image. I also have an image for the same page from my Macbook Pro

A "200" code with a green dot indicates a fresh retrieval. (A "200" code with an empty circle indicates it was retrieved from cache.)

A "304" code indicates the file was in cache, Firefox asked the server if there was a newer version and there wasn't, so the cached file was used.

So I don't think there is a problem there. It leaves the question, why isn't the style sheet being applied?

There is a "switch" to turn off styles in the current tab here:

menu bar: View > Page Style > No Style

Is that turned on?


Do you still have layout but no color? To check whether something related to color settings is amiss:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the Language and Appearance section, click the Colors button.

Set the selector below "Override the colors specified by the page with your selections above:" to Never and click OK.

Any improvement?


By the way, what version of MacOS runs on the iMac?

more options

jscher2000, I cleared the cache... reloaded the page. The warning signs changed to GREEN. See 2 images above and this iMac 2 image below

Thanks...

more options

Chosen Solution

Thanks for your input. Let's see:

  • Page style is "basic page style"
  • The layout isn't correct either-but probably due to CSS
  • After cache clearing still no color
  • My iMac is current running iOS Sierra 10.12.6

And... Finally The winner is NEVER on the Colors selector THANK YOU SO MUCH!!!