Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get rid of the annoying new tab page and have it just show me a blank page?

  • 20 replies
  • 16 have this problem
  • 3635 views
  • Last reply by Happy112

more options

I don't care for the new Tabs with the fancy photos, search bar, and little annoying icons. I've researched on here but none of the answers seem to apply to me. I have no "settings" icon in the upper right corner to set to "blank page". Going to about:config doesn't help me either as all that shows is the something I don't understand. How can I get just a blank page again please?

Chosen solution

Oh boy - I asked you if Yahoo was your home page, because in your last post, all of a sudden, you mentioned Yahoo, while you were initially talking about the 'New Tab' page (in the header of your first post), which led us to believe that you were talking about Firefox New Tab page.

Apparantly you don't like Yahoo's New Tab design - Mozilla has nothing to do with Yahoo's design.

But if you've always had Firefox New Tab page : the 'old' design you can get back when you follow the instructions that Moses gave you in his first post.

I now get the feeling that somehow Yahoo has taken over your New Tab page and that you're dealing with malware. I may be completely wrong, but better safe than sorry.

Since Yahoo is your search engine, I can't ask you to remove anything that has to do with Yahoo in Add-ons => Extensions, but I will ask you to do this :

Go to the 3-bar menu (or   'Tools') => Addons => Extensions and (besides CouponXplorer) look for any unfamiliar or suspicious looking extensions, like e.g. :

SafeSearch Incognito SearchAssist Incognito Search for Fire Fox 1.6 SafeSearch ch SafeSearch net Converter.onesearch org File Convertor and Search Addon Findwide Search Engine 1.7

When you find any : remove them.

Do the same in Windows Control Panel.

However :   most malware will be 'hiding' somewhere , so let's run malware scans :

Further information can be found in this article :
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners.
They all work differently   -   what one program doesn't pick up, the other might.

Read this answer in context 👍 1

All Replies (20)

more options

about:config is not for the faint of heart. Some serious breakage can happen if you mess with the wrong prefs. Lucky for you, you know what you are looking for. Set browser.newtabpage.activity-stream.enabled to false in about:config, select the gear icon in the old new tab page and select Show Blank Page.

more options

Well I set it to false and still get exactly What I had before. Anything else I can try?

more options

Disabling that pref works immediately. You may need to open a new tab several times to see the old new tab page.

more options

I've opened "new tab" enough to make a career out of it! I've even closed and reopened Firefox a number of times. Still get that new tab with all the crap I want to get rid of.

more options
  • After you set browser.newtabpage.activity-stream.enabled to FALSE, you will be reverted to the OLD new tab page which STILL has tiles.
  • You need to click the GEAR ICON in the TOP RIGHT CORNER of the new tab page and select Show Blank Page. I'm adding screenshots for clarification.

1) Setting to false http://prntscr.com/hblaqy 2) This is the old new tab page http://prntscr.com/hblb7m 3) Click the gear icon and show blank page http://prntscr.com/hblbj0

If you cannot follow these instructions, then I will not assist any further. This is as straightforward as I can tell you.

Modified by Moses

more options

@ wildchild1954 :

As you mention in your original post that you don't have a 'settings icon' (cog wheel) in the upper right corner, and as the screenshot you attached shows a bookmarks dropdown, I'm thinking that we may not be talking about the New Tab page here.

Would you be so kind as to provide a screenshot of the whole page that you are talking about  ?

more options

Moses I DID follow your instructions exactly but I'm still not getting a cog gear in the upper right corner. And I'm not sure what screenshot attachment you're talking about as I never attached anything to my message. I don't even know how to get a screenshot on this little laptop!

more options

Happy112 would like a screen shot of the New Tab Page you now have. You can do this by clicking the 2 Dots in the Address Bar and use Tak A Screenshot. Or follow this as need to dig the pic out : https://support.mozilla.org/en-US/kb/firefox-screenshots

more options

wildchild1954 said

And I'm not sure what screenshot attachment you're talking about as I never attached anything to my message. I don't even know how to get a screenshot on this little laptop!

Look at your initial post .......

If you didn't attach that screenshot, then Stephen King must be working on a new book .......

But I'm going to have to take your word for it - that screenshot doesn't make sense anyway.

Are you sure though, that on the New Tab page you don't see something that looks like a cog wheel in the upper right corner  ?

Edit :

I was going to show you how to take a screenshot, but I see that, while I was typing this, Pkshadow posted something that should help you take a screenshot ......

Modified by Happy112

more options

OK, I'm going to take a stab at this following Pkshadow's instructions. So here goes. All I get is a message that says: We can's screenshot this page. This isn't a standard web page, so you can't take a screenshot of it.

I looked but there photo editing program on here either. (I bought this from my neighbor and there's only 3.52 GB free of 70.5 GB. I've deleted everything I can think of but can't free up more room than that. And it won't let me load my photo program.

And as for cog wheels on something that says New Tab by Yahoo the only cog wheel is on the lower right corner. Gives the options to Show Search, Show Trending Now, Edit Favorites and Feedback. That so-called New Tab by Yahoo is all I can get when I click on the new tab +

more options

Okay, now I'm going to do what I was planning to do before - please see  :

How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box.

And please, take all the time you need - no rush  ! If you can't do it today : we'll still be here tomorrow (or any other day).

more options

wildchild1954 said

And as for cog wheels on something that says New Tab by Yahoo the only cog wheel is on the lower right corner. Gives the options to Show Search, Show Trending Now, Edit Favorites and Feedback. That so-called New Tab by Yahoo is all I can get when I click on the new tab +

I had read the part about you not being able to take a screenshot, and wanted to get that out off the way first - and posted 'How to take a screenshot'.

Then I read the second part of your last post and : you're not even on a Firefox New Tab page, or Firefox Homepage - you're on a Yahoo page, which is nothing like the Firefox New Tabe page (or Home page)  !

Question : Do you even want a Firefox New Tab page  ?

more options

Another question for you :

Do you even use Yahoo as your search engine - is Yahoo your home page  ?

more options

Yes, Happy112 I DO want a Firefox new tab like I always had with older versions of Firefox. Yes, I do use Yahoo as my search engine and it's the only one I use. No, Yahoo is definitely not my home page - that would be MSN.com! So can I get rid of the New Tab by Yahoo and just go back to the original new tabs?

more options

Try using the extension New Tab Override. It actually still works in 57.

New Tab Override

more options

Chosen Solution

Oh boy - I asked you if Yahoo was your home page, because in your last post, all of a sudden, you mentioned Yahoo, while you were initially talking about the 'New Tab' page (in the header of your first post), which led us to believe that you were talking about Firefox New Tab page.

Apparantly you don't like Yahoo's New Tab design - Mozilla has nothing to do with Yahoo's design.

But if you've always had Firefox New Tab page : the 'old' design you can get back when you follow the instructions that Moses gave you in his first post.

I now get the feeling that somehow Yahoo has taken over your New Tab page and that you're dealing with malware. I may be completely wrong, but better safe than sorry.

Since Yahoo is your search engine, I can't ask you to remove anything that has to do with Yahoo in Add-ons => Extensions, but I will ask you to do this :

Go to the 3-bar menu (or   'Tools') => Addons => Extensions and (besides CouponXplorer) look for any unfamiliar or suspicious looking extensions, like e.g. :

SafeSearch Incognito SearchAssist Incognito Search for Fire Fox 1.6 SafeSearch ch SafeSearch net Converter.onesearch org File Convertor and Search Addon Findwide Search Engine 1.7

When you find any : remove them.

Do the same in Windows Control Panel.

However :   most malware will be 'hiding' somewhere , so let's run malware scans :

Further information can be found in this article :
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners.
They all work differently   -   what one program doesn't pick up, the other might.

more options

Thank you Happy112!! I don't know which one of them did it but I now have the old Firefox blank pages back.

more options

The solution proposed by Moses (first reply) does not work.

I did "Set browser.newtabpage.activity-stream.enabled to false in about:config, select the gear icon in the old new tab page and select Show Blank Page." On clicking the gear the Show Blank Page item was preselected, but I never get a blank page. There are always icons in the upper corners.

more options

wildchild1954 said

Thank you Happy112!! I don't know which one of them did it but I now have the old Firefox blank pages back.

My pleasure wildchild  ! Huge relief, eh  ?

more options

Mik3e said

The solution proposed by Moses (first reply) does not work. I did "Set browser.newtabpage.activity-stream.enabled to false in about:config, select the gear icon in the old new tab page and select Show Blank Page." On clicking the gear the Show Blank Page item was preselected, but I never get a blank page. There are always icons in the upper corners.

Yours sounds like a different problem than the OP had - maybe you'd like to start your own thread : Click on the 'Ask a question' at the top of this page and post your question. Please be specific about the problem and if at all possible, attach a screenshot.