X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

How to get back the curvy tabs, and other aesthetic problems with quantum.

Posted

With firefox quantum the usual curvy tabs are now lame and rectangular, like microsoft edge, which is almost as square as being square. Is there a way to return to that layout, with the curvy tabs and the refresh button inside the address bar, or will I have to reinstall an earlier version of firefox? Would a theme be able to change that, (which I realize wouldn't have been created yet), or would the "firefox won't support complete themes after v57" thing stop that from happening, since it messes with the tab shape? Since firefox is open-source, if I wanted to learn how to make a theme including the curvy tabs, would I be able to get code to salvage from mozilla? Also, I can't get the refresh button back inside the address bar. File image gives example of preferred tab curve and refresh button location.

I know this seems like a minor thing, but thanks for help.

With firefox quantum the usual curvy tabs are now lame and rectangular, like microsoft edge, which is almost as square as being square. Is there a way to return to that layout, with the curvy tabs and the refresh button inside the address bar, or will I have to reinstall an earlier version of firefox? Would a theme be able to change that, (which I realize wouldn't have been created yet), or would the "firefox won't support complete themes after v57" thing stop that from happening, since it messes with the tab shape? Since firefox is open-source, if I wanted to learn how to make a theme including the curvy tabs, would I be able to get code to salvage from mozilla? Also, I can't get the refresh button back inside the address bar. File image gives example of preferred tab curve and refresh button location. I know this seems like a minor thing, but thanks for help.
Attached screenshots

Chosen solution

Hi, try this: https://github.com/wilfredwee/photon-australis

If this solved your problem, mark as solution!

Read this answer in context 20

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Mkll 314 solutions 1978 answers

Chosen Solution

Hi, try this: https://github.com/wilfredwee/photon-australis

If this solved your problem, mark as solution!

Hi, try this: https://github.com/wilfredwee/photon-australis If this solved your problem, mark as solution!

Modified by Mkll

Question owner

Mkll said

Hi, try this: https://github.com/wilfredwee/photon-australis If this solved your problem, mark as solution!

Thanks, this looks like it's what I wanted. I can probably end up just dealing with the refresh button being next to the address bar, so I think I'm all good now.

''Mkll [[#answer-1028747|said]]'' <blockquote> Hi, try this: https://github.com/wilfredwee/photon-australis If this solved your problem, mark as solution! </blockquote> Thanks, this looks like it's what I wanted. I can probably end up just dealing with the refresh button being next to the address bar, so I think I'm all good now.
Ashkevron 1 solutions 20 answers

that looks like it would work, problem is I use a customized theme...

Abstract Electric, so no idea how to get the rounded edges while keeping my current theme

that looks like it would work, problem is I use a customized theme... Abstract Electric, so no idea how to get the rounded edges while keeping my current theme
tinman9898 0 solutions 5 answers

I have changed the tabs in 57 to curved using a chrome file, however the horrible, jaggy cornered rectangles now sit behind the rounded tabs and a dark rectangle expands across the top as tabs are open. How do I get that area to be transparent in windows 7 so it doesn't look so bad?

I have changed the tabs in 57 to curved using a chrome file, however the horrible, jaggy cornered rectangles now sit behind the rounded tabs and a dark rectangle expands across the top as tabs are open. How do I get that area to be transparent in windows 7 so it doesn't look so bad?
thankon 0 solutions 1 answers

If you can live without aero theme, a temporary solution is to choose the classic windows theme in Control Panel - Personalization.

If you can live without aero theme, a temporary solution is to choose the classic windows theme in Control Panel - Personalization.
jaybub 0 solutions 1 answers

Helpful Reply

So someone at mozilla decided they were going to have squared-off tabs instead of rounded tabs. This affects millions, but they don't have an option for having round or square tabs. Ludicrous!

So someone at mozilla decided they were going to have squared-off tabs instead of rounded tabs. This affects millions, but they don't have an option for having round or square tabs. Ludicrous!
jscher2000
  • Top 10 Contributor
8957 solutions 73389 answers

tinman9898 said

I have changed the tabs in 57 to curved using a chrome file, however the horrible, jaggy cornered rectangles now sit behind the rounded tabs and a dark rectangle expands across the top as tabs are open. How do I get that area to be transparent in windows 7 so it doesn't look so bad?

Try:

/* Show Windows 7 background on tabs bar */
.tabbrowser-tab {
  background-color: transparent !important;
}

Sample screenshot attached.

The white text titles of background tabs are a little less visible, but probably still work for you. You could give those a little shape this way (in addition to the first rule):

/* 10% gray inactive tab shadows to contrast with white text */
.tabbrowser-tab:not([selected="true"]):not(:hover) .tab-content {
  background-color: rgba(0,0,0,.1) !important;
  border-radius: 16px 16px 0px 0px / 60% 60% 0px 0px !important;
}

Sample screenshot attached. Couldn't match the height exactly, but close.

''tinman9898 [[#answer-1041215|said]]'' <blockquote> I have changed the tabs in 57 to curved using a chrome file, however the horrible, jaggy cornered rectangles now sit behind the rounded tabs and a dark rectangle expands across the top as tabs are open. How do I get that area to be transparent in windows 7 so it doesn't look so bad? </blockquote> Try: <pre>/* Show Windows 7 background on tabs bar */ .tabbrowser-tab { background-color: transparent !important; } </pre> Sample screenshot attached. The white text titles of background tabs are a little less visible, but probably still work for you. You could give those a little shape this way (in addition to the first rule): <pre>/* 10% gray inactive tab shadows to contrast with white text */ .tabbrowser-tab:not([selected="true"]):not(:hover) .tab-content { background-color: rgba(0,0,0,.1) !important; border-radius: 16px 16px 0px 0px / 60% 60% 0px 0px !important; } </pre> Sample screenshot attached. ''Couldn't match the height exactly, but close.''

Modified by jscher2000

rbhall52 0 solutions 8 answers

How do I do this for firefox quantum on windows 7?

How do I do this for firefox quantum on windows 7?
Pratyush Tewari 0 solutions 5 answers
You can also check out https://github.com/pratyushtewari/firefox-like-chrome
FrankCo 4 solutions 20 answers

If you would like rounded top corners as in the below image, see https://github.com/FrankConijn/Firefox-Quantum-Rounded-Tabs.

If you would like rounded top corners as in the below image, see https://github.com/FrankConijn/Firefox-Quantum-Rounded-Tabs.