X
Tap here to go to the mobile version of the site.

Support Forum

Site does not display properly in Firefox, It is OK in IE, Opera, Chrome, and Safari for Windows

Posted

Example: https://www.stuftpizzabarandgrill.com/catering/ AND MANY OTHERS

Pages do not display properly and are difficult or impossible to read only in FF. This is a regular problem on many sites, not just this one.

In this particular page, FF displays black text on a very dark gray background. I just checked it in IE, Chrome, Opera, and Safari for Windows and they all show white text, making it readable.

This is obviously a problem with the way FF displays pages and ONLY FF.

Using Vista but that should not be an issue. All the other browsers checked show the page properly.

Example: https://www.stuftpizzabarandgrill.com/catering/ AND MANY OTHERS Pages do not display properly and are difficult or impossible to read only in FF. This is a regular problem on many sites, not just this one. In this particular page, FF displays black text on a very dark gray background. I just checked it in IE, Chrome, Opera, and Safari for Windows and they all show white text, making it readable. This is obviously a problem with the way FF displays pages and ONLY FF. Using Vista but that should not be an issue. All the other browsers checked show the page properly.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 23.0 r0
  • 5.1.50906.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158023 answers

Does this still happen if you reset these prefs via the right-click context menu to the default value?

  • browser.display.use_system_colors
  • browser.display.document_color_use
Does this still happen if you reset these prefs via the right-click context menu to the default value? *browser.display.use_system_colors *browser.display.document_color_use

Question owner

dehe25 said

If you're only not updating because you do need some programs which arent supported under WIn7, you should consider using them in a virtual machine like vmware or virtualbox. back to your problem: please try going to about:settings and changing security.block_script_with_wrong_mime to false

That is not the problem with upgrading. All programs need to be reinstalled and some are not available anymore and cannot be installed on a new computer.

Entered about:settings in FF and got the message address not valid

''dehe25 [[#answer-1008875|said]]'' <blockquote> If you're only not updating because you do need some programs which arent supported under WIn7, you should consider using them in a virtual machine like vmware or virtualbox. back to your problem: please try going to about:settings and changing security.block_script_with_wrong_mime to false </blockquote> That is not the problem with upgrading. All programs need to be reinstalled and some are not available anymore and cannot be installed on a new computer. Entered about:settings in FF and got the message address not valid

Question owner

waynec444 said

dehe25 said
If you're only not updating because you do need some programs which arent supported under WIn7, you should consider using them in a virtual machine like vmware or virtualbox. back to your problem: please try going to about:settings and changing security.block_script_with_wrong_mime to false

That is not the problem with upgrading. All programs need to be reinstalled and some are not available anymore and cannot be installed on a new computer.

Entered about:settings in FF and got the message address not valid

Microsoft says I cannot upgrade this computer. The above has to do with getting a new computer. Some programs are no longer available.

''waynec444 [[#answer-1009033|said]]'' <blockquote> ''dehe25 [[#answer-1008875|said]]'' <blockquote> If you're only not updating because you do need some programs which arent supported under WIn7, you should consider using them in a virtual machine like vmware or virtualbox. back to your problem: please try going to about:settings and changing security.block_script_with_wrong_mime to false </blockquote> That is not the problem with upgrading. All programs need to be reinstalled and some are not available anymore and cannot be installed on a new computer. Entered about:settings in FF and got the message address not valid </blockquote> Microsoft says I cannot upgrade this computer. The above has to do with getting a new computer. Some programs are no longer available.

Question owner

dehe25 said

Last idea except copying your config: 1.) Open the pizza page 2.) hit ctrl+shift+J 3.) copy the content of the window that comes up and paste it here

What part of this window do you want me to post?

''dehe25 [[#answer-1008851|said]]'' <blockquote> Last idea except copying your config: 1.) Open the pizza page 2.) hit ctrl+shift+J 3.) copy the content of the window that comes up and paste it here </blockquote> What part of this window do you want me to post?

Question owner

cor-el said

Does this still happen if you reset these prefs via the right-click context menu to the default value?
  • browser.display.use_system_colors
  • browser.display.document_color_use

How do I do this? Have had several settings with use system colors on and off and had the same problem either way. don't know how to change the document color use but that may be part of the same setting. Advise. Thanks.

''cor-el [[#answer-1008908|said]]'' <blockquote> Does this still happen if you reset these prefs via the right-click context menu to the default value? *browser.display.use_system_colors *browser.display.document_color_use </blockquote> How do I do this? Have had several settings with use system colors on and off and had the same problem either way. don't know how to change the document color use but that may be part of the same setting. Advise. Thanks.

Question owner

dehe25 said

I used to have eset but it is not in use now. I don't know if it is still "installed" on my computer. I know it is not active.

ESSET does sometimes destroy SSL certificates, which can lead to CSS files not being loaded.

The info by clicking on the lock says it is not secure. Some elements have been blocked by FF but images have been displayed. Hope this is what you want, cannot copy/paste.

Lock->Right Arrow Button->"Deactivate protection" or something like that.


here's another bug in esset which can cause this error, too: https://support.eset.com/kb3126/


more likely it's about mime-types in about:config "please try going to about:settings and changing security.block_script_with_wrong_mime to false"

last possiblity: create a shortcut to firefox.exe and add [space]-ProfileManager (hit spacebar instead of [space] this allows you to create a new profile. You can backup your old profile by saving the top profiles folder from where prefs.js file has been copied.

I already had another profile (with no modifications) and decided to check the url in that one (before I read this message). The url works fine there so it is SOME setting in my regular profile.

I would rather not reset to default values in my regular profile as i would lose all my settings I have made over time.

''dehe25 [[#answer-1008882|said]]'' <blockquote> <blockquote> I used to have eset but it is not in use now. I don't know if it is still "installed" on my computer. I know it is not active. </blockquote> ESSET does sometimes destroy SSL certificates, which can lead to CSS files not being loaded. <blockquote> The info by clicking on the lock says it is not secure. Some elements have been blocked by FF but images have been displayed. Hope this is what you want, cannot copy/paste. </blockquote> Lock->Right Arrow Button->"Deactivate protection" or something like that. here's another bug in esset which can cause this error, too: https://support.eset.com/kb3126/ more likely it's about mime-types in about:config "please try going to about:settings and changing security.block_script_with_wrong_mime to false" last possiblity: create a shortcut to firefox.exe and add [space]-ProfileManager (hit spacebar instead of [space] this allows you to create a new profile. You can backup your old profile by saving the top profiles folder from where prefs.js file has been copied. </blockquote> I already had another profile (with no modifications) and decided to check the url in that one (before I read this message). The url works fine there so it is SOME setting in my regular profile. I would rather not reset to default values in my regular profile as i would lose all my settings I have made over time.

Question owner

I hope I have seen and read and done what was suggested. There were so many replies that I may have missed something.

Since I have now determined that the problem is with SOME FF setting somewhere I will not be doing "sfc /scannow".

Still need to do the suggestion in about.settings but as i said it is not coming up. It says invalid address.

I hope I have seen and read and done what was suggested. There were so many replies that I may have missed something. Since I have now determined that the problem is with SOME FF setting somewhere I will not be doing "sfc /scannow". Still need to do the suggestion in about.settings but as i said it is not coming up. It says invalid address.
dehe25 2 solutions 35 answers

You should correct that font color overwrite, it's wrong in you config. goto about:config (please note that it's config, not settings) and reset those values to default by rightclicking on them, then clicking reset:

browser.display.document_color_use browser.display.use_system_colors

You should correct that font color overwrite, it's wrong in you config. goto about:config (please note that it's config, not settings) and reset those values to default by rightclicking on them, then clicking reset: browser.display.document_color_use browser.display.use_system_colors

Modified by dehe25

Question owner

This is what I get when entering about:settings in the address bar:

The address isn’t valid The URL is not valid and cannot be loaded.

This is what I get when entering about:settings in the address bar: The address isn’t valid The URL is not valid and cannot be loaded.
dehe25 2 solutions 35 answers

Helpful Reply

it's about:config not about:settings

it's about:config not about:settings

Question owner

Found the problem.

On the content menu it gives me a choice of using different colors on links (which I am using because the two standard colors are too close and I can do my research work faster when the links in Google search are much different from visited and not visited.

The problem is that the window ALSO requires me to set the text color. The default is black text on a white background. DO NOT WANT THIS. I want the text to display as the site wants but the links in colors I choose.

Checking or not checking "use system colors" does not make any difference.

Is there a way to change the link colors WITHOUT changing the text colors?

Found the problem. On the content menu it gives me a choice of using different colors on links (which I am using because the two standard colors are too close and I can do my research work faster when the links in Google search are much different from visited and not visited. The problem is that the window ALSO requires me to set the text color. The default is black text on a white background. DO NOT WANT THIS. I want the text to display as the site wants but the links in colors I choose. Checking or not checking "use system colors" does not make any difference. Is there a way to change the link colors WITHOUT changing the text colors?

Question owner

waynec444 said

Found the problem. On the content menu it gives me a choice of using different colors on links (which I am using because the two standard colors are too close and I can do my research work faster when the links in Google search are much different from visited and not visited. The problem is that the window ALSO requires me to set the text color. The default is black text on a white background. DO NOT WANT THIS. I want the text to display as the site wants but the links in colors I choose. Checking or not checking "use system colors" does not make any difference. Is there a way to change the link colors WITHOUT changing the text colors?

The setting also says black text on a white background which does not happen. Only the black text setting is applied. However, I do not want to change the site's background color either. Just change the link colors.

''waynec444 [[#answer-1009063|said]]'' <blockquote> Found the problem. On the content menu it gives me a choice of using different colors on links (which I am using because the two standard colors are too close and I can do my research work faster when the links in Google search are much different from visited and not visited. The problem is that the window ALSO requires me to set the text color. The default is black text on a white background. DO NOT WANT THIS. I want the text to display as the site wants but the links in colors I choose. Checking or not checking "use system colors" does not make any difference. Is there a way to change the link colors WITHOUT changing the text colors? </blockquote> The setting also says black text on a white background which does not happen. Only the black text setting is applied. However, I do not want to change the site's background color either. Just change the link colors.
dehe25 2 solutions 35 answers
you could try this addon: https://addons.mozilla.org/de/firefox/addon/color-toggle/

Question owner

dehe25 said

it's about:config not about:settings

OK. The post said the other.

''dehe25 [[#answer-1009061|said]]'' <blockquote> it's about:config not about:settings </blockquote> OK. The post said the other.

Question owner

waynec444 said

dehe25 said
it's about:config not about:settings

OK. The post said the other.

Will wait to make any changes here until I see what can be done with the content color settings which I referred to earlier.

I DO want to be able to use either special link colors or regular colors (be able to easily switch between the two.

''waynec444 [[#answer-1009067|said]]'' <blockquote> ''dehe25 [[#answer-1009061|said]]'' <blockquote> it's about:config not about:settings </blockquote> OK. The post said the other. </blockquote> Will wait to make any changes here until I see what can be done with the content color settings which I referred to earlier. I DO want to be able to use either special link colors or regular colors (be able to easily switch between the two.

Question owner

dehe25 said

you could try this addon: https://addons.mozilla.org/de/firefox/addon/color-toggle/

Looked. Here is what it says:


Has nice features but breaks browser style Bewertet mit 1 von 5 Sternen

von Eik-S am June 30, 2017 · Permanentlink

The Add-On does what it should. It gives websites a darker background/style and brighter text and different configurations can be used for different websites.

Until you try to remove it... Then for a lot of websites some elements stay black, like the searchbar in most search-engines like startpage, yahoo. Even purging firefox, deleting the usersfolder and reinstalling is not solving the problem.

Be careful with this addon and if you got any solutions to the problem send me a message. Die Antwort des Entwicklers auf diese Bewertung anzeigen Отличное расширение, но Bewertet mit 5 von 5 Sternen

von Barsukk am May 27, 2017 · Permanentlink

Почините, перестало работать в FF 53 Broken Bewertet mit 1 von 5 Sternen

von ChrisK am April 24, 2017 · Permanentlink

Broken and even removal doesn't revert pages to non-dark style. Developer appears unwilling to fix it.


Guess it is not a good idea to use this.

''dehe25 [[#answer-1009065|said]]'' <blockquote> you could try this addon: https://addons.mozilla.org/de/firefox/addon/color-toggle/ </blockquote> Looked. Here is what it says: Has nice features but breaks browser style Bewertet mit 1 von 5 Sternen von Eik-S am June 30, 2017 · Permanentlink The Add-On does what it should. It gives websites a darker background/style and brighter text and different configurations can be used for different websites. Until you try to remove it... Then for a lot of websites some elements stay black, like the searchbar in most search-engines like startpage, yahoo. Even purging firefox, deleting the usersfolder and reinstalling is not solving the problem. Be careful with this addon and if you got any solutions to the problem send me a message. Die Antwort des Entwicklers auf diese Bewertung anzeigen Отличное расширение, но Bewertet mit 5 von 5 Sternen von Barsukk am May 27, 2017 · Permanentlink Почините, перестало работать в FF 53 Broken Bewertet mit 1 von 5 Sternen von ChrisK am April 24, 2017 · Permanentlink Broken and even removal doesn't revert pages to non-dark style. Developer appears unwilling to fix it. Guess it is not a good idea to use this.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158023 answers

For Google there is this WebExtension:

For Google there is this WebExtension: *Custom Google Visited Link Color:<br>https://addons.mozilla.org/en-US/firefox/addon/google-link-color/

Question owner

Now I have a new problem while trying to fix the original one. I changed the text to white on white. It fixed the original problem but now I cannot see anything in the FF options section as it is displaying white on white. It is also preventing the viewing of a any text on any white page, including Google search listings. What a mess!

I also cannot read anything in the FF support section for the same reason.

How can I get to (read) the content settings (colors) so that I can fix the setting? I have tried to click all over the content page but with no success of seeing anything except some scrolling bars and the color part does not display anything if it comes up at all.

Now I have a new problem while trying to fix the original one. I changed the text to white on white. It fixed the original problem but now I cannot see anything in the FF options section as it is displaying white on white. It is also preventing the viewing of a any text on any white page, including Google search listings. What a mess! I also cannot read anything in the FF support section for the same reason. How can I get to (read) the content settings (colors) so that I can fix the setting? I have tried to click all over the content page but with no success of seeing anything except some scrolling bars and the color part does not display anything if it comes up at all.

Question owner

waynec444 said

Now I have a new problem while trying to fix the original one. I changed the text to white on white. It fixed the original problem but now I cannot see anything in the FF options section as it is displaying white on white. It is also preventing the viewing of a any text on any white page, including Google search listings. What a mess! I also cannot read anything in the FF support section for the same reason. Got this fixed, finally. How can I get to (read) the content settings (colors) so that I can fix the setting? I have tried to click all over the content page but with no success of seeing anything except some scrolling bars and the color part does not display anything if it comes up at all.
''waynec444 [[#answer-1009412|said]]'' <blockquote> Now I have a new problem while trying to fix the original one. I changed the text to white on white. It fixed the original problem but now I cannot see anything in the FF options section as it is displaying white on white. It is also preventing the viewing of a any text on any white page, including Google search listings. What a mess! I also cannot read anything in the FF support section for the same reason. Got this fixed, finally. How can I get to (read) the content settings (colors) so that I can fix the setting? I have tried to click all over the content page but with no success of seeing anything except some scrolling bars and the color part does not display anything if it comes up at all. </blockquote>

Question owner

cor-el said

For Google there is this WebExtension:

Did this. Not only did it not work, now my Google search results are in very large text. Disabling the add-on did not fix it. I want the text size to go back to what it was. ONLY Google search text results size is larger. Everything else seems to be normal as it was before.

''cor-el [[#answer-1009272|said]]'' <blockquote> For Google there is this WebExtension: *Custom Google Visited Link Color:<br>https://addons.mozilla.org/en-US/firefox/addon/google-link-color/ </blockquote> Did this. Not only did it not work, now my Google search results are in very large text. Disabling the add-on did not fix it. I want the text size to go back to what it was. ONLY Google search text results size is larger. Everything else seems to be normal as it was before.