Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to remove EBAY from Mac laptop

  • 7 replies
  • 3 have this problem
  • 113 views
  • Last reply by jscher2000

more options

I'm only concerned about eBay popping up as though it's my browser. I can't get rid of it. How can I accomplish that? Please help me; I don't want to use eBay again.

Thanks, Kath

Chosen solution

fThank you so much for saving my sanity. I never, ever want to see eBay again. They are inefficient, non-responsive and a convoluted program to get what and where is wanted. Kath

Read this answer in context 👍 1

All Replies (7)

more options

Hi Kath, where is eBay appearing on your Firefox?

If you have new eBay icons in the toolbar area, or if eBay has taken over your home page, please start by checking for any add-ons related to eBay or shopping, etc. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable or feel free to remove if possible.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Then to update your home page (start page), see: How to set the home page.

Can you get it running the way you want it?

more options

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB
more options

jscher2000 said

Hi Kath, where is eBay appearing on your Firefox? If you have new eBay icons in the toolbar area, or if eBay has taken over your home page, please start by checking for any add-ons related to eBay or shopping, etc. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:
  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable or feel free to remove if possible. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement? Then to update your home page (start page), see: How to set the home page. Can you get it running the way you want it?
more options

Chosen Solution

fThank you so much for saving my sanity. I never, ever want to see eBay again. They are inefficient, non-responsive and a convoluted program to get what and where is wanted. Kath

more options

Guess what! I was logging in GE and here comes the Ebay thing in the upper left corner and the eBay site again.  !@#$%@!!!

Now what? K

more options

What is the address of the page where you saw the problem?

Can you capture an image of what you're seeing and attach it to a reply? This article has tips on the capturing part: How do I create a screenshot of my problem? Please cut out or blur any sensitive information in the image before posting it.

more options

Oh, one other thought. Did your default search engine change from a normal search site to eBay? When you type something into the address bar or a search bar that needs to be searched, Firefox will use the default search engine. You can check that setting on the Preferences page, Search panel, right at the top (ignore the box further down): Change your default search settings in Firefox.