Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by jscher2000

more options

Going back maybe 60-90 days - so this would be starting with FF 47 or 48, guessing, my browser at work crashes almost daily. My browsing habits or computer hardware or software have not changed.

I've not used safe mode. My extensions are up to date. This is for Windows 7, and both it and the browser are automatically updated as soon as the updates are pushed to me.

bp-abbe6fec-9f2f-48c3-ae9b-2772c2161221 is the latest of lots of crashes.

Not every crash results in a submitted report. But for comparison sake, I have:

- 5 submitted crash reports in 2014 - 18 in 2015 - 34 this year

Of the reported crashes this year, 11 have been since 10/24. This was preceeded by a 15-week period with zero reported crashes.

I hope someone can troubleshoot this, because I have not knowingly changed anything of substance, other than updating Windows and FF.

All Replies (1)

more options

Sorry to hear about the crashes. Can you post several more of those crash report IDs so we can get a sense of whether they are all the same, similar/related, or random? Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, or if necessary, from disk.

Also and/or meanwhile, could you test in Firefox's Safe Mode? That temporarily deactivates extensions, hardware acceleration, and some other advanced features of Firefox that might make it more prone to crashing on some systems.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?