Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I do NOT want firefox to clear cache

  • 3 replies
  • 1 has this problem
  • 712 views
  • Last reply by FredMcD

more options

I get this message: ""Document Expired

This document is no longer available.

The requested document is not available in Firefox's cache.

   As a security precaution, Firefox does not automatically re-request sensitive documents.
   Click Try Again to re-request the document from the website.

"" So, after clicking try again 20 times to get back to the page that I could always go back to before, it gets tiresome. Is there a way to have firefox NOT protect my security quite so aggressively, so it WILL automatically re-request the socalled sensitive document? OR which version of firefox will I have to go backto to avoid this hassle? AND is there a way to KEEP that older version? And thisa is not the first time firefox is doing something which is really really annoying formy benefit

Chosen solution

I see. This is a common problem. What I do is; Right-click a link you want to check out and select Open New Window/Tab. Once you are done, close it and you are back where you started from.

Read this answer in context 👍 1

All Replies (3)

more options

Is there a reason you are using an old version? https://support.mozilla.org/en-US/kb/update-firefox-latest-version 49

What type of document, and how long ago was it accessed? And when was it removed?

It would be better to download a file you want to keep.

more options

hmm, I'm using 37.0.2 Probably because there was something else it did that didn't work for me, most likely mess with the usability of the "plain old favorites" add-on when updating. that is the most frequent reason I would go through the trouble of down-dating Which is the latest version that supports plain old favorites? ( I can not use bookmarks, no matter how much you tell me how nice it is)

Anyway, this is something new that has started happening all by itself without me up-or downdating. This is the web site I'm talking about: http://mcle1.co.mendocino.ca.us/NewWorld.Aegis.WebPortal/Corrections/InmateInquiry.aspx

You enter from and to dates, and get to a list of inmates. then click on an individual, which comes up, then you look at it that person for a moment, and TRY to go back to the list of inmates, which is where the message comes. and if you look at 20 people, you have to "try again" 20 times which out here in the country where even high speed internet is slow, takes 1-2minutes to reload. But - isn't there a way for me to control when it keeps things in the cache? Everything I find on the internet is about purging the cache.

more options

Chosen Solution

I see. This is a common problem. What I do is; Right-click a link you want to check out and select Open New Window/Tab. Once you are done, close it and you are back where you started from.