Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

NOT SECURE CONNECTION, HOW TO ADD TRUSTED SITE TO REMOVE THE (i)?

  • 8 replies
  • 3 have this problem
  • 5 views
  • Last reply by jscher2000

more options

I use excel with hyperlinks for the web at work, but each link to out internal intranet has a pop-up that says it is an unsecure address because FireFox does not recognize it as being secure. I need a way to make the (i) in the upper corner saying that the "connection is Not secure" to go away. How do i make that happen?

All Replies (8)

more options

I'm not sure I understand the problem.

I think you are seeing an i-in-a-circle to the left of the website address in Firefox's address bar, and no padlock. Is that correct?

Does your intranet use HTTPS addresses? If not, Firefox is simply informing you that you are connecting via HTTP instead of HTTPS and no action is required on your part.

Is there a problem viewing the content?

more options

correct there is not a green pad lock.


it is an internal "web.***.intranet.*************.local/"

and there is no problem viewing the content but there are pop-up security question that i can not bypass for quicker work. i want to add my personal intranet to a "trusted" or "secure" status so that i no longer have to go through security pop-ups.

more options

I assume you get that warning one of these two ways:

(1) In a Firefox download dialog, choose Open and select an Office application; or (2) After saving a download to disk, open it in an Office application.

I believe that Office warning is triggered by a file being marked as having a non-local origin. It seems your Firefox is marking your intranet downloads the same way it marks downloads from the internet.

I can't replicate the problem using "one-word" host names (e.g., http://intranet/). Maybe it's something about the dotted host name?? If no one else knows how that works, I can look into it more this evening.

more options

Actually, is this before Excel retrieves the linked page/file? In that case, it might be a generic hyperlink warning that would apply to any link and any default browser. In that case, see if this helps: How to enable or disable hyperlink warning messages in 2007 Office programs and in Office 2010 programs.

more options

It is excel 2016 and have gone through the steps to turn off the warnings in excel, excel help point to the non-trusted nature comes from my default internet, which is firefox. That is what i am seeking to fix.

more options

KAZMCGEHEE said

It is excel 2016 and have gone through the steps to turn off the warnings in excel, excel help point to the non-trusted nature comes from my default internet, which is firefox.

I haven't tried Excel 2016.

What do the links retrieve: web pages, files, etc.?

Do the warnings go away if you change your default browser to Internet Explorer? If that works and you don't get any other suggestions, you might have to do that.

more options

How do i make firefox acknowledge a site to be: safe, secure, or trusted?

more options

KAZMCGEHEE said

How do i make firefox acknowledge a site to be: safe, secure, or trusted?

It depends on the problem. Did you try pasting the link directly into Firefox's address bar and pressing Enter to load it directly? That would provide more information about whether Firefox believes there is a problem with the connection or content.

Could you let me know the answer to this question:

Do the warnings go away if you change your default browser to Internet Explorer?