Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Visited links color is stuck on red.

  • 2 replies
  • 2 have this problem
  • 23 views
  • Last reply by Nohow Nemo

more options

On many (most?) websites, my Firefox visited links color is red for no apparently logical reason. It seems to be left over from a previous setting and is stuck there. I have searched in about:config and researched online, but find nothing that helps me.

I'll mention that in [Tools > Content > Colors], if the [Override the colors specified by the page with my selections above] is set to [Always], this is the only time that the visited links color is not red (and *is* whatever is set in the [Unvisited Links] field).

But when [Override...] is set to [Never] or [Only with High Contrast themes], the visited links color is red. So, even when the [Unvisited Links] and [Visited Links] are set to colors other than red, and [Override...] is set to [Never], the actual live visited links are red. Where is it getting this red? How can I change it?

I was just coping with this seeing-red issue on the many sites that I visit online (and also with the left-side label links in Gmail, of which I have over a hundred). But recently I have published my own website (haltvote.com), and now it's a real problem.

On my own PC, my site's colors are the plan: hyperlinks are light purple text, and hovering causes white text against reddish background.

But on the live version, the visited links are the leftover red color, which means that hovering has red text with red background: yuck! (The 2 reds are not identical but too close for readability.)

The hyperlink colors are what they should be in Chrome and Edge. But I only like Firefox! And I need to be able to test my own site live. If someone could help me, I'd be grateful.

The uploaded image segment shows 2 site visits. The lower colors are correct. The upper ones are incorrect. Both show me hovering over the "Next Page" hyperlink during the screen capture. See how the upper ones have the stuck red?

Nohow Nemo

Attached screenshots

Chosen solution

Could it be an add-on? You probably would know if you have any extensions that modify website colors or try to improve visibility of links, but you could double check on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side.

If you have the Stylish extension, also check the User Styles category (a separate button in the left column.

Some users may have created a userContent.css file in their profile folder, but this is uncommon. Does it ring a bell?

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Could it be an add-on? You probably would know if you have any extensions that modify website colors or try to improve visibility of links, but you could double check on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side.

If you have the Stylish extension, also check the User Styles category (a separate button in the left column.

Some users may have created a userContent.css file in their profile folder, but this is uncommon. Does it ring a bell?

more options

Hi, jscher2000. That was a very good instinct you had. Yes, I do use the Stylish extension. But it's set up to only change the unread and read email colors in Gmail. Just to be sure that wasn't causing my problem, I disabled it. And that didn't solve it.

However, the overall principle of your idea was absolutely right on! I just found this other installed add-on that I didn't even know I had. It's called "Visited" and once I disabled it, my persistent red-link problem went away. I don't remember adding that add-on whatsoever; I'm not familiar with it. So I'd been looking for solutions in all the wrong places.

That is, until I thought to ask my question in this fine establishment, and you were kind enough to reply. Thank you jscher2000!!!

Now I'm just left with my own website's wacky colors. But you know, at least they are *my* wacky colors.

Thanks again. May you live well and prosper, and may "the FORCE" be neutralized.

Nohow Nemo