X
Tap here to go to the mobile version of the site.

Support Forum

Recently started having redirection problems with Amazon

Posted

I have recently started having the redirection issue with Amazon. I click on a product link on the Amazon website and now I get the message that this page is not properly redirecting. I try Chrome and it works fine. I have cleared my cache, insured that cookies are accepted and I have searched for solutions. I did find several others reporting this problem, but none of their solutions worked for me. The odd thing is that some links on Amazon still work properly. But others don't. Here is a link that is not working for me: https://www.amazon.com/ChickenFuel-OMRI-Listed-Organic-Compost-Fertilizer/dp/B0102PAT9O?ie=UTF8&fpl=fresh&redirect=true&ref_=s9_cartx_gw_g86_i3_r

Here is another link that works fine: https://www.amazon.com/gp/product/B00VOLHKHA/ref=br_asw_pdt-2?pf_rd_m=ATVPDKIKX0DER&pf_rd_s=desktop-4&pf_rd_r=57NDHMP0ADH9BCSMAPX8&pf_rd_t=36701&pf_rd_p=4ccd27f1-4604-40d9-92c7-3318b57f8ba8&pf_rd_i=desktop

And, as I wrote above, all these links work in other browsers, i.e. Chrome. But I hate switching to Chrome so I can use Amazon. As far as I can tell, Amazon is the only website that has this issue. I browse a lot, so that seems strange to me.

I have recently started having the redirection issue with Amazon. I click on a product link on the Amazon website and now I get the message that this page is not properly redirecting. I try Chrome and it works fine. I have cleared my cache, insured that cookies are accepted and I have searched for solutions. I did find several others reporting this problem, but none of their solutions worked for me. The odd thing is that some links on Amazon still work properly. But others don't. Here is a link that is not working for me: https://www.amazon.com/ChickenFuel-OMRI-Listed-Organic-Compost-Fertilizer/dp/B0102PAT9O?ie=UTF8&fpl=fresh&redirect=true&ref_=s9_cartx_gw_g86_i3_r Here is another link that works fine: https://www.amazon.com/gp/product/B00VOLHKHA/ref=br_asw_pdt-2?pf_rd_m=ATVPDKIKX0DER&pf_rd_s=desktop-4&pf_rd_r=57NDHMP0ADH9BCSMAPX8&pf_rd_t=36701&pf_rd_p=4ccd27f1-4604-40d9-92c7-3318b57f8ba8&pf_rd_i=desktop And, as I wrote above, all these links work in other browsers, i.e. Chrome. But I hate switching to Chrome so I can use Amazon. As far as I can tell, Amazon is the only website that has this issue. I browse a lot, so that seems strange to me.

Chosen solution

pawnslinger said

jscher2000 said
If the problem occurs without any extension (for example, in Firefox's Safe Mode), and after Amazon cookies are cleared, possibly Firefox stored a "strict HTTPS" instruction from the server. My understanding is that all such instructions are stored in a single settings file that you could remove and see whether that resolves it. If you want to try it, here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it). Start Firefox back up again. Any change with Amazon?

YES! Renaming this file did the trick!! Amazon now is working properly.

Is this something that I will routinely have to fix?? Or is this a 1 time kind of thing?

I think it must be some remote corner of Amazon that set strict transport security on your Firefox, since as far as I know this is an uncommon problem and the result obviously is very dysfunctional.

Do you use any less common features, such as being a vendor or an affiliate?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • npdivxplayerplugin
  • DivX Web Player version 1.5.0.52
  • Garmin Communicator Plug-In 4.0.4.0
  • Version 5.41.3.0
  • Google Update
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 5.1.41212.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • NewTabURL 2.2.3.1-signed.1-signed (newtaburl@sogame.cat)
  • Pocket 1.0 (firefox@getpocket.com)
  • Delta Toolbar 1.5.0 (ffxtlbr@delta.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • RealDownloader 1.3.3 ({DF153AFF-6948-45d7-AC98-4FC4AF8A08E2}) (Inactive)
  • Widevine Media Transformer Plugin 5.0.0.4679 (widevinemediatransformer@widevine) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 285
  • adapterDescription2:
  • adapterDeviceID: 0x05e3
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 12813842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23845
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; MFT_MESSAGE_SET_D3D_MANAGER failed with code C00D6D60
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 285 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
Andrew
  • Moderator
322 solutions 4071 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

No apparent change was observed in Safe mode. Except that it disabled the menu and bookmark bars. The redirection problem on Amazon remained unchanged.

No apparent change was observed in Safe mode. Except that it disabled the menu and bookmark bars. The redirection problem on Amazon remained unchanged.
FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

Separate Security Issue: Update your Adobe Reader Version 2015.016.20039 Note: Other Software is offered in the download.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

Separate Security Issue: Update your '''[http://get.adobe.com/reader/ Adobe Reader Version 2015.016.20039]''' '''Note: Other Software''' is offered in the download. ----------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems? Then restart.

Question owner

I am sure that I tried all of this already, but just to be sure, I foolowed your instructions (again). Sorry, no change was observed. Redirection issue still happens on Amazon. As for the Adobe add-on... I should just disable it, I don't use it.

I am sure that I tried all of this already, but just to be sure, I foolowed your instructions (again). Sorry, no change was observed. Redirection issue still happens on Amazon. As for the Adobe add-on... I should just disable it, I don't use it.

Question owner

Hmmmm... I couldn't find Adobe Reader in add-ons. Are you sure I am using it in Firefox? If so, how can I disable it? I know that I used to use it to read library books, but I have not used it in a long time -- hence out-of-date, as you noted. Perhaps I should just uninstall it.

Hmmmm... I couldn't find Adobe Reader in add-ons. Are you sure I am using it in Firefox? If so, how can I disable it? I know that I used to use it to read library books, but I have not used it in a long time -- hence out-of-date, as you noted. Perhaps I should just uninstall it.
FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

Adobe software is listed under plugins.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Adobe software is listed under plugins. Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

FredMcD said

Adobe software is listed under plugins. Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there? Starting The Computer In Safe Mode;
Free Online Encyclopedia

I don't see Adobe Reader under plugins or add-ons. I have Adobe Acrobat, but that is not the same as Adobe Reader. Adobe Reader is an ebook program that is installed on my computer, unused for a long time, because I no longer borrow from the public library.

I have tried Safe mode several times, no change in the Amazon redirection issue.

''FredMcD [[#answer-880543|said]]'' <blockquote> Adobe software is listed under plugins. Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' </blockquote> I don't see Adobe Reader under plugins or add-ons. I have Adobe Acrobat, but that is not the same as Adobe Reader. Adobe Reader is an ebook program that is installed on my computer, unused for a long time, because I no longer borrow from the public library. I have tried Safe mode several times, no change in the Amazon redirection issue.
FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' ----------- You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Question owner

FredMcD said

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there? Starting The Computer In Safe Mode;
Free Online Encyclopedia

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Okay, I guess I have tired of this. Perhaps I am the only one with this issue, or few others have it. I have decided to fall back to my stable configuration -- running Chrome. It works and I need to do productive work. I will retry Firefox at a later date.

''FredMcD [[#answer-880552|said]]'' <blockquote> Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' ----------- You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up. </blockquote> Okay, I guess I have tired of this. Perhaps I am the only one with this issue, or few others have it. I have decided to fall back to my stable configuration -- running Chrome. It works and I need to do productive work. I will retry Firefox at a later date.

Question owner

Alright, I gave Firefox another shot, I really do not want to use Chrome. So on the off chance, I opened a "private window" and manually logged into the Amazon site. Everything worked!!

So what is different about a private window? Why would it work there, but not in a regular window? Is it that tracking is disabled in a private window? Can I turn off tracking in a regular window? Maybe that would work? Lots of questions... guess I will give it a try.

Is there a downside to turning off tracking in a regular window?

Alright, I gave Firefox another shot, I really do not want to use Chrome. So on the off chance, I opened a "private window" and manually logged into the Amazon site. Everything worked!! So what is different about a private window? Why would it work there, but not in a regular window? Is it that tracking is disabled in a private window? Can I turn off tracking in a regular window? Maybe that would work? Lots of questions... guess I will give it a try. Is there a downside to turning off tracking in a regular window?

Question owner

Well, the tracking isn't the problem. I set "Do Not Track" in regular Firefox windows and still the redirection failed there.

So why would this work fine in a "private window" and not in a regular window? Besides the Do Not Track what else is different that might have an effect? I know, cookies are treated differently.

Am I stuck using "private windows" for Amazon shopping?

Well, the tracking isn't the problem. I set "Do Not Track" in regular Firefox windows and still the redirection failed there. So why would this work fine in a "private window" and not in a regular window? Besides the Do Not Track what else is different that might have an effect? I know, cookies are treated differently. Am I stuck using "private windows" for Amazon shopping?
lindaandron 0 solutions 11 answers

I have this exact issue. It started 5/23 or 5/24. I have tried most of these solutions without and sucess. Someone at Mozilla needs to run this down.

I have this exact issue. It started 5/23 or 5/24. I have tried most of these solutions without and sucess. Someone at Mozilla needs to run this down.
FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

I have used Amazon and had no problem. I've called the big guys to help you. Good luck.

I have used Amazon and had no problem. I've called the big guys to help you. Good luck.

Question owner

FredMcD said

I have used Amazon and had no problem. I've called the big guys to help you. Good luck.

Thank you.

Please bear in mind, not all links at Amazon fail. A large number of links work just fine for me. Obviously, the broken links require redirection... and the working links do not. But still, that can't be the whole answer... because not all the links fail.

Did you try the link I showed in the first message above? It fails consistently for me, except in "private" windows.

''FredMcD [[#answer-880826|said]]'' <blockquote> I have used Amazon and had no problem. I've called the big guys to help you. Good luck. </blockquote> Thank you. Please bear in mind, not all links at Amazon fail. A large number of links work just fine for me. Obviously, the broken links require redirection... and the working links do not. But still, that can't be the whole answer... because not all the links fail. Did you try the link I showed in the first message above? It fails consistently for me, except in "private" windows.
FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

I tried both links with no problem.

I tried both links with no problem.
lindaandron 0 solutions 11 answers

Right now if I use the Private window Amazon works normally. If I try to use the normal window I get the Firefox window stating a redirecting issue. So until there is a fix I will just use the private window. I hope a resolution will be coming.

Right now if I use the Private window Amazon works normally. If I try to use the normal window I get the Firefox window stating a redirecting issue. So until there is a fix I will just use the private window. I hope a resolution will be coming.

Modified by lindaandron

lindaandron 0 solutions 11 answers

Please bear in mind, not all links at Amazon fail. A large number of links work just fine for me. Obviously, the broken links require redirection... and the working links do not. But still, that can't be the whole answer... because not all the links fail.

Did you try the link I showed in the first message above? It fails consistently for me, except in "private" windows.

I agree with the above explanation. This is exactly what I experience. Curious this all started just this week.

Please bear in mind, not all links at Amazon fail. A large number of links work just fine for me. Obviously, the broken links require redirection... and the working links do not. But still, that can't be the whole answer... because not all the links fail. Did you try the link I showed in the first message above? It fails consistently for me, except in "private" windows. I agree with the above explanation. This is exactly what I experience. Curious this all started just this week.
cynicscorner 0 solutions 2 answers

Helpful Reply

I'm having the same issue with Amazon, including the fact that it works fine in a private window. Thought I was losing my mind and relieved that I am not the only one with this weird issue.

But I'm only having this issue on one machine (Fx 46.0.1, Win 8.1). On two other machines (Fx 46.0.1, Win 7), all is well. Comparing the Firefox-Amazon behavior on these three machines, I think I’ve found what’s wrong, but I don’t know why it is happening or how to fix it:

On the machines that work right, when I visit the main Amazon page while logged on (either from bookmark, Google, or typing), I end up at http://www.amazon.com/. From there if I click shopping cart or order history I go to a secure (https) page. From there if I click a product page, I get an unsecured (http) page. If I visit a product page directly from Google (whether logged on or not), I get an unsecured (http) page.

However on my problem machine, every Amazon page comes up https including the home page, and nothing I do can change that. If I hard-type www.amazon.com, I am taken to https://www.amazon.com/. Pages that are supposed to be secure (like shopping cart, order history, etc.) work fine, but the product pages, which normally would have http links instead show https links and they cause the redirect error; manually changing the address to http results in the browser sitting there “Waiting…” (as does trying to access a product page directly from Google).

It seems the https versions of those pages don’t exist or don’t work right, but why does this Firefox now demand them? What has changed to cause this behavior since last week (when I know things worked properly)? I’ve gone through every conceivable setting (including anything coming up as non-default in about:config) and came up empty.

I'm having the same issue with Amazon, including the fact that it works fine in a private window. Thought I was losing my mind and relieved that I am not the only one with this weird issue. But I'm only having this issue on one machine (Fx 46.0.1, Win 8.1). On two other machines (Fx 46.0.1, Win 7), all is well. Comparing the Firefox-Amazon behavior on these three machines, I think I’ve found what’s wrong, but I don’t know why it is happening or how to fix it: On the machines that work right, when I visit the main Amazon page while logged on (either from bookmark, Google, or typing), I end up at http://www.amazon.com/. From there if I click shopping cart or order history I go to a secure (https) page. From there if I click a product page, I get an unsecured (http) page. If I visit a product page directly from Google (whether logged on or not), I get an unsecured (http) page. However on my problem machine, every Amazon page comes up https including the home page, and nothing I do can change that. If I hard-type www.amazon.com, I am taken to https://www.amazon.com/. Pages that are supposed to be secure (like shopping cart, order history, etc.) work fine, but the product pages, which normally would have http links instead show https links and they cause the redirect error; manually changing the address to http results in the browser sitting there “Waiting…” (as does trying to access a product page directly from Google). It seems the https versions of those pages don’t exist or don’t work right, but why does this Firefox now demand them? What has changed to cause this behavior since last week (when I know things worked properly)? I’ve gone through every conceivable setting (including anything coming up as non-default in about:config) and came up empty.
lindaandron 0 solutions 11 answers

I am experiencing the exact problem. I am not able to make any progress in solving this issue. I cant believe there is not a simple fix for this.

I am experiencing the exact problem. I am not able to make any progress in solving this issue. I cant believe there is not a simple fix for this.

Question owner

lindaandron said

I am experiencing the exact problem. I am not able to make any progress in solving this issue. I cant believe there is not a simple fix for this.

The simple fix... I am using "private window" for all my Amazon shopping. It is becoming 2nd nature by now, I just open it automatically.

''lindaandron [[#answer-882524|said]]'' <blockquote> I am experiencing the exact problem. I am not able to make any progress in solving this issue. I cant believe there is not a simple fix for this. </blockquote> The simple fix... I am using "private window" for all my Amazon shopping. It is becoming 2nd nature by now, I just open it automatically.