Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to access secure (HTTPS) site since Firefox 44 update for 32/64bit versions of Windows

  • 13 replies
  • 12 have this problem
  • 1904 views
  • Last reply by orangepulp78

more options

Since 44.0 update, I can not access live.com and some secure (http) sites. How do I overcome this problem as I'm a loyal fan of firefox and never had any problems until now?

Chosen solution

I have figured out the solution based on the some of the information you provided, cor-el.

As a Kaspersky Internet Security user, scanning of encrypted connections is required to operate Safe Money, Parental Control, URL Advisor and Private browsing. Default setting, as attached, prevents access to the above domain names. Change to 'Do not scan encrypted connections'. You will get a warning message from kaspersky about the operating problems without it enabled. Ignore and press continue and retry websites.

Read this answer in context 👍 0

All Replies (13)

more options

cat2k1 said

Since 44.0 update, I can not access live.com and some secure (http) sites. How do I overcome this problem as I'm a loyal fan of firefox and never had any problems until now?

Greetings cat2k1 This problem is known, and its decision was announced in this article or this blog . The best solution: download the latest version Firefox! I hope this answer will help you!

more options

The latest version is 44.0, which I already have and it doesn't solve anything.

I get this error message when I click on advanced for the following websites:

mail.live.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

www.google.co.uk uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

onedrive.live.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

Modified by Cat2k1

more options

cat2k1 said

The latest version is 44.0, which I already have and it doesn't solve anything.

cat2k1, when you try to go to the site, what error do you see??

more options

Anticisco Freeman said

cat2k1 said
The latest version is 44.0, which I already have and it doesn't solve anything.

cat2k1, when you try to go to the site, what error do you see??

Check my amended previous reply.

more options

There is security software like Avast and Kaspersky and BitDefender and ESET that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer.

more options

cor-el said

There is security software like Avast and Kaspersky and BitDefender and ESET that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content. If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field of this window type or paste the URL of the website.
  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer.

How will doing this help?

more options

cat2k1 said

cor-el said
There is security software like Avast and Kaspersky and BitDefender and ESET that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content. If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field of this window type or paste the URL of the website.
  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer.

How will doing this help?

Alternative route is Options>Advanced>View Certificates>Servers>Add Exception... :-P

I added the certificate as exception but still getting same error message.

Modified by Cat2k1

more options

Chosen Solution

I have figured out the solution based on the some of the information you provided, cor-el.

As a Kaspersky Internet Security user, scanning of encrypted connections is required to operate Safe Money, Parental Control, URL Advisor and Private browsing. Default setting, as attached, prevents access to the above domain names. Change to 'Do not scan encrypted connections'. You will get a warning message from kaspersky about the operating problems without it enabled. Ignore and press continue and retry websites.

more options

Hi, try disabling your CookieKeeper extension - Add-ons Manager (Ctrl+Shift+A) > Extensions.

Also see How to troubleshoot security error codes on secure websites.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Scribe said

Hi, try disabling your CookieKeeper extension - Add-ons Manager (Ctrl+Shift+A) > Extensions. Also see How to troubleshoot security error codes on secure websites. If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Its a internet security issue as demonstrated in my previous post.

more options

I have this issue as well. When I go to a site like Lego.com I get Unable to connect

BUT, if I use fire fox on my tablet it works. I have never had an issue until this update. I have tried all the suggestions.....but I'm lost

Modified by orangepulp78

more options

Hi orangepulp78

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.

What security software do you have?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

more options

Hi there! I am using Windows 10 Add blocker for Gmail Add block ultimate Open H246 video codec Primetime Content Decryption Module provided by Adobe Systems, Incorporated Shockwave flash The suggestions offered did not help. I have a windows firewall but it is not enabled.