X
Tap here to go to the mobile version of the site.

Support Forum

Is firefox being adversely affected by the latest windows 10 upgrade - since upgrade firefox been slow/not responding and asking to be closed - microsoft ARRGH

Posted

Why is it whenever there is a microsift upgrade everything else seems to get mucked up - one could almost imagine this is programmed in so regular is the problem - since the free upgrade windows 10 seems to be problems problems ........ mozilla keeps chucking up not responding etc - anyone any ideas?

Why is it whenever there is a microsift upgrade everything else seems to get mucked up - one could almost imagine this is programmed in so regular is the problem - since the free upgrade windows 10 seems to be problems problems ........ mozilla keeps chucking up not responding etc - anyone any ideas?

Chosen solution

Firefox's Windows 10 support will be more fully realized in version 40 than it is in version 39.

Firefox 40 won't be finalized for a couple of weeks, but if you already are running Windows 10 perhaps you are an "early adopter" and won't mind using a beta test version.

First, I suggest a backup of your main settings (profile) folder. This article has tips on that: Back up and restore information in Firefox profiles.

Then the beta version is available on the following page (scroll down to your preferred language): https://www.mozilla.org/firefox/beta/all/

In case you are wondering, the traditional 32-bit test version will support all your regular plugins; the 64-bit test version hardly has any plugins available and may have a few other compatibility issues to work through.

Read this answer in context 25

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • GEPlugin
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Chosen Solution

Firefox's Windows 10 support will be more fully realized in version 40 than it is in version 39.

Firefox 40 won't be finalized for a couple of weeks, but if you already are running Windows 10 perhaps you are an "early adopter" and won't mind using a beta test version.

First, I suggest a backup of your main settings (profile) folder. This article has tips on that: Back up and restore information in Firefox profiles.

Then the beta version is available on the following page (scroll down to your preferred language): https://www.mozilla.org/firefox/beta/all/

In case you are wondering, the traditional 32-bit test version will support all your regular plugins; the 64-bit test version hardly has any plugins available and may have a few other compatibility issues to work through.

Firefox's Windows 10 support will be more fully realized in version 40 than it is in version 39. Firefox 40 won't be finalized for a couple of weeks, but if you already are running Windows 10 perhaps you are an "early adopter" and won't mind using a beta test version. First, I suggest a backup of your main settings (profile) folder. This article has tips on that: [[Back up and restore information in Firefox profiles]]. Then the beta version is available on the following page (scroll down to your preferred language): https://www.mozilla.org/firefox/beta/all/ In case you are wondering, the traditional 32-bit test version will support all your regular plugins; the 64-bit test version hardly has any plugins available and may have a few other compatibility issues to work through.
James
  • Moderator
1596 solutions 11248 answers

Only 64-bit Flash player will be the only Plugin white listed in Win64 Firefox for now.

Only 64-bit Flash player will be the only Plugin white listed in Win64 Firefox for now.
foxyfoxy58 0 solutions 8 answers

Helpful Reply

I have tried to fix "Firefox not responding" error since the upgrade to Windows 10. It looks like I've found a simple solution. I used Compatibility Mode. I tried Windows 8 setting but had the same problem. I used XP mode and that's working fine at the moment, no "not responding" and much quicker. I hope this helps. Bob.

I have tried to fix "Firefox not responding" error since the upgrade to Windows 10. It looks like I've found a simple solution. I used Compatibility Mode. I tried Windows 8 setting but had the same problem. I used XP mode and that's working fine at the moment, no "not responding" and much quicker. I hope this helps. Bob.
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Hi foxyfoxy58/Bob, what that does is cause Firefox to turn off any advanced features of Firefox that don't work in XP, so it seems that one of those is the culprit, possibly something video or Flash related.

Hi foxyfoxy58/Bob, what that does is cause Firefox to turn off any advanced features of Firefox that don't work in XP, so it seems that one of those is the culprit, possibly something video or Flash related.
foxyfoxy58 0 solutions 8 answers

Thank you, I've tried Firefox 40 Beta, I'm still running now and tried safe mode. It used to run fine with Windows 8.1 but won't run in that with compatibility mode, only runs in XP mode. This morning even this configuration will not run smoothly, video is pausing and spell checker is pausing while writing this message, it's very frustrating. Bob.

Thank you, I've tried Firefox 40 Beta, I'm still running now and tried safe mode. It used to run fine with Windows 8.1 but won't run in that with compatibility mode, only runs in XP mode. This morning even this configuration will not run smoothly, video is pausing and spell checker is pausing while writing this message, it's very frustrating. Bob.
ifginov 0 solutions 1 answers

Helpful Reply

Even on firefox 41.x.x this is still an issue. It's become a big nuisance as I have trusted firefox with all my bookmarks and other internet browsing information for more than 10 years. I can't believe this is happening.

Even on firefox 41.x.x this is still an issue. It's become a big nuisance as I have trusted firefox with all my bookmarks and other internet browsing information for more than 10 years. I can't believe this is happening.
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Hi ifginov and others in this thread, could you summarize your current problems on Windows 10?

Since Flash can cause responsiveness issues with Firefox 41, and is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Hi ifginov and others in this thread, could you summarize your '''current problems''' on Windows 10? Since Flash can cause responsiveness issues with Firefox 41, and is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting: (1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.) The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. (2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
foxyfoxy58 0 solutions 8 answers

I've been running Firefox 4.2 beta for weeks now in XP compatibility mode and it works fine for me except the spellchecker it takes ages to drop the box down. This may happen in other applications such as word but haven't checked.

I've been running Firefox 4.2 beta for weeks now in XP compatibility mode and it works fine for me except the spellchecker it takes ages to drop the box down. This may happen in other applications such as word but haven't checked.