Search Support

This thread was closed and archived. Please ask a new question if you need help.

As of today (6/07/15), Firefox will not allowed to access Google, Mozilla, etc? Suspected Avast and disabled it.

  • 4 replies
  • 22 have this problem
  • 259 views
  • Last reply by jscher2000

more options

Now everything's OK, but no anti-virus. Was there some kind of update to Firefox, or Avast?

All Replies (4)

more options

First, check for any updates for Avast.

Second, open Avast settings and have it leave the browsers alone.

If you think there is still a problem, contact Avast Support.

more options

Do you mean every site that uses an HTTPS address is reported as not having a valid security certificate? This probably is caused by the avast! Web Shield feature, which intercepts your web traffic for filtering. In order to read secure traffic, avast! must present "fake" certificates to Firefox, so naturally they are considered invalid. There is a way to set up Firefox to trust avast! as the issuer of all secure site certificates if you want to use this feature, but off the top of my head, I don't know the steps.

But whether you use Web Shield or not, you do not need to disable the other features of avast!

more options

I did everything I was told to do and yet Avast is still not working. Avast and I have been in contact and according to Avast the problem is with Firefox not recognizing Avast. I have the fastest updates from Avast and Firefox. Please help.

more options

Hi Krava, I can't find a thread where we have been working with you on an Avast issue, and this thread started by someone else back in June using Firefox 38 doesn't have specific steps, so I'm not sure what you have done.

Could you start a new question with those details at the following link. Scroll down past the suggestions to continue submitting your question: https://support.mozilla.org/questions/new/desktop/fix-problems