Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashing AGAIN !

  • 30 replies
  • 5 have this problem
  • 1815 views
  • Last reply by FredMcD

more options

Over the last week Firefox has been crashing , for no reason , i will be on a webpage for a few minutes , then the next thing a pop-up says Firefox has crashed , so i send a report , and all is well , then maybe the same day , maybe 2 days later , it crashes again

The only thing that has been changed in my system is a new video card and 2 new games , BUT , they were just installed last night and this morning , so i dont see how this would be any factor with the crashing

Any help would be appreciated , i can't duplicate the issue , so i can't really test because its so random when it happens

Chosen solution

Hmm, when I was on Craigslist, the drop-down at the top of that dialog said "Latin" instead of "Other Writing Systems". Firefox will apply one or the other to most pages depending on what character set they specify or your default. Could you try changing it to Latin and then modifying the font sizes there to see whether that works on yours?

Read this answer in context 👍 0

All Replies (20)

more options

Can you please post the id's from the crashes so we can understand why it is crashing?

Type "about:crashes" in the url bar. You should see a list of crash id's that start with "bp-". (If they do not start with bp-, click on them first). Can you copy and paste the 5 topmost id's into the forum?

more options

bp-35beaeb8-1011-4a8b-81a3-e45322150405 bp-9abf3fb1-68f0-4498-ac1c-9a9cb2150404 bp-3c4c49a6-10ae-4160-849e-47cf82150402 bp-1397e2a3-f43c-4064-8ce9-432272150401 bp-16331765-8cfc-4401-9fac-949a12150315

Modified by cor-el

more options

Just crashed again , a little while ago , also noticing something really weird , when i go to Craigslist (any city/state) , the main page looks normal , but when i go to a add page , like Motorcycles

Each add

         looks like its 
                    going across the 
                                page like this , so 
                                             each add is farther
                                                         over on the page then
                                                                       the prior add , it only does
                                                                                     this in Firefox , IE , and Google Chrome , look normal , and it only seems to be happening on Craigslist  , i tried clearing the Cache , Cookies and History , and even restarted the PC  , it still does it , and again , ONLY in Firefox

Example: (without the sliders obviously)

Apr 6 '87 kawasaki kx250 pic map
                 Apr 6 1981 Piaggio Vespa P200E $1900 (Boise) pic
                             Apr 6 2005 iron eagle custom chopper $25000 (cottonwood) pic map
                                        Apr 6 2008 CRF450R * lightly used* $3000 pic map
                                                   Apr 6 2006 Softail Night Train Loaded W/Extras (Meridian) pic map
                                                                      Apr 6 1994 Honda Xr200r Dirt Bike $850 (meridian) pic
                                                                                           Apr 6 2007 Yamaha Royal Star Tour Deluxe $6200 (Caldwell) pic map
                                                                                                                Apr 6 Vintage 360         Yamaha enduro $360 (mccall) pic

Modified by JimDirt

more options

These crash reports don't seem to point to a single cause for this problem. I hate to provide only generalities, but at this point, it's all I've got. Steps for these suggestions will follow:

  1. Try a clean reinstall in case one of the 36.0.x updates corrupted a program file
  2. Try running in Firefox's Safe Mode (however, due to the intermittent nature of the problem, this isn't as useful as usual)
  3. Scan for malware
  4. Test your memory

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean and undamaged. As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 37.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any difference?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?


Our support article: Troubleshoot Firefox issues caused by malware lists scanning/cleaning tools other Firefox users have found helpful. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.


Memory test -- most sites suggest this utility: http://www.memtest86.com/

more options

For Craigslist, could you post a screenshot? This article has tips on capturing screenshots: How do I create a screenshot of my problem?. You can attach a saved image file (e.g., PNG or JPG format) to a reply using the Browse... button below the text box.

more options

OK first pic is what it looks like in Google Chrome and what it used to look like in Firefox , and what it normally always looked like in Firefox up until now , the second pic is the exact same page and what it now looks like in Firefox no matter what i do

Modified by JimDirt

more options

jscher2000 said

These crash reports don't seem to point to a single cause for this problem. I hate to provide only generalities, but at this point, it's all I've got. Steps for these suggestions will follow:
  1. Try a clean reinstall in case one of the 36.0.x updates corrupted a program file
  2. Try running in Firefox's Safe Mode (however, due to the intermittent nature of the problem, this isn't as useful as usual)
  3. Scan for malware
  4. Test your memory
Clean Reinstall We use this name, but it's not about removing your settings, it's about making sure the program files are clean and undamaged. As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 37.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder (64-bit Windows folder names) C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (32-bit Windows folder names) C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any difference? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:
  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
OK , i did the reinstall and everything looks the same as in like the Craigslist pics i posted in my post above , it will be a while till i know if the crashes stop , so bare with me if it does not change then i will try Safe Mode , the memory sticks are all brand new as i did have some bad ram a few weeks ago , so the ram , video card , and hard drive as well as the install of the OS are all new within the last few weeks , no spyware , malware or viruses detected

Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?


Our support article: Troubleshoot Firefox issues caused by malware lists scanning/cleaning tools other Firefox users have found helpful. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.


Memory test -- most sites suggest this utility: http://www.memtest86.com/

Modified by JimDirt

more options

On your Craigslist screen shot, the star images and checkboxes are out of proportion to the text. This may be creating line height problems that case paragraphs not to wrap all the way to the left margin.

I can re-create the problem by injecting a style rule into the page that reduces the body text size to 65% of normal. (Screen shot attached.) But I don't know why your Firefox would have this disproportion. Do you have any zoom-related extensions, whether for images or text or both?

more options

Well pretty much every page i have to zoom , because if i set the font to normal (i think its 16 ?) , then the font is huge and the page is all shrunk into the middle of the screen , so i set the font to 10 , then zoom in and its better , but images are still scrunched and distorted , but not as much , the weird thing is , Craigslist (so far) is the only website that does this , so that really puzzles me

I am not sure i follow what you mean by , do i have "Zoom Related Extensions"

When i look at the page (that looks diagonal like in the pics) , and go to Options , it says the page size is 150% , and again , the main Craigslist page where all the category's are , and the next page the give "All ,Owner,Dealer", look normal as well , so its only the pages with the actual adds , and its in all category's , so Motorcycles , Furniture , etc , and it does not matter what state i click on , its the same no matter what

And for some reason , any website i go to , i have to zoom the page if i have not been on it before , otherwise , everything is in the middle , there is no "Master Zoom" , that you zoom once and all pages are the same , which would be nice , , so the whole thing is screwy , and it all started when i went to a 25" HD Wide Screen Monitor , so that confuses me even more , plus the fact that i just(within the last few weeks ) have replaced the Hard Drive , OS , Ram , and Video Card , and Monitor , so i have almost replaced everything on my PC , and now i am having all these graphic and crash issues

Modified by JimDirt

more options

Okay, let's review the zoom situation from scratch.

First, please go back to the default setting of letting pages choose the font size.

"3-bar" menu button (or Tools menu) > Options > Content > "Advanced" button

  • Check the box for "Allow pages to choose their own fonts"
  • If the minimum font size is larger than 9, change it to 9 or less
  • Change the selector at the top to from Latin to Other Writing Systems (or the other way around if applicable) and repeat

Then OK out of the dialog.

Next, what is your Windows text size percentage? It's commonly 125% or so, but with a 25" monitor, you might have it at 100%.

Whatever you set in Windows becomes Firefox's baseline size. You can adjust that by editing an obscure setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Check the value of the layout.css.devPixelsPerPx preference:

  • Default value is -1.0, which uses the Windows text size
  • A value of 1.0 uses the classic 96dpi proportions for fonts
  • Other values are proportional: 1.25 => 125% zoom

If this value is bolded and "user set" I would start by trying right-click > Reset to see what kind of size that yields.

If you want smaller, try 0.9

If you want bigger, try 1.25

Can you find a value that looks good in general? You can still fine-tune sites from the default using zoom as normal.

more options

Ok i am up to 1.75 and its looking more normal as far as how the page looks , though i had to adjust the zoom on pages i had changed the zoom on before , if i "reset" the zoom everything is scrunched again into the center of the screen and pics are distorted and the font is real small , pics are just a little off , but not bad now , so i dont know if this is it or not , also i notice everything is real grainy like its low graphics the more its zoomed (to fit everything to fill across the screen), and i have a 2gb video card and 8 gb of ram so that should not be a issue

So do i need to do something else ?? , or is this all that can be done ?? , its better , but the Craigslist page is still diagonal across the screen like in my pics (just the actual adds , the main Craigslist page looks "normal")

more options

Maybe Firefox isn't fully compatible with your new graphics card? If you check the Graphics section of the support information page, does it show that Firefox is applying hardware acceleration? You can check that using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics section and look for "GPU Accelerated Windows" to see whether all windows are being accelerated?

If not:

  • You might check whether an update is available for your graphics card/chipset drivers.
  • If you disabled hardware acceleration in the Options dialog previous to getting this new card, you could try turning it back on.

    "3-bar" menu button (or Tools menu) > Options > Advanced

    On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

    This takes effect the next time you exit Firefox and start it up again. Any difference?

If yes:

This would be a good time to try Firefox's Safe Mode as mentioned before, in case an extension is modifying the images.

more options

it says

1/1 Direct3D 11 (OMTC)

So what does that mean ??

Modified by JimDirt

more options

That means Firefox using hardware acceleration, using your graphics card, on 1 of your 1 open windows (all of them).

Could you try the Safe Mode test when you get time?

more options

Now to get it back from safe mode what do i do, just restart Firefox ??

Also it was not on the 3 bar icon , it is only in the "Help" , when i use the "Menu" across the top of the window (old style Windows Menu *File,Edit,View, etc*)

I did try it , and the Craigslist page still is diagonal , so it did not fix or change that (so far nothing has) , as far as the crashing goes , it can take some time , since its so random

more options

You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 You can adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

You can look at this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

more options

Thanks for testing in Safe Mode. When you close Firefox and start it up again, it will start normally again.

I'm puzzled that the text on the Craiglist page is so small relative to the images, for no apparent reason, and also that you still need to zoom a lot with the 1.75 setting. Something is messing with the text size but I'm at a loss to identify it.


Do you run Firefox with any "compatibility" settings? You can check here:

right-click the shortcut you use to start Firefox > Properties > Compatibility tab

(for pinned shortcuts, right-click the shortcut, then right-click Mozilla Firefox, then Properties > Compatibility)

For best results, deselect everything here, nothing selected, nothing checked. Then Firefox will use the full capabilities of Windows 7.


Could you try this experiment? It takes about 5 minutes:

Create a new Firefox profile

This is in addition to and does not replace your existing settings.

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should come with completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run) -- type or paste the following and press Enter:

firefox.exe -P

Don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like April7, and ignore the option to change the folder location. Then start Firefox in the new profile you created.

If you go to Craigslist in the new profile, does it lay out any better? If so, that suggests there is something in your settings we need to clear out. If not, it could be a problem with Firefox's program files or something else on your system.

After the test, you can close Firefox, and call up the profile manager again to return to your normal settings.

more options

OK although everything was still scrunched into the middle and pictures were distorted as they have been , the adds were not diagonal any more , so it did fix that , but nothing else , the font is tiny and everything is scrunched into the middle like the first pics i attached

So mostly everything looks crappy , but at least Craigslist is straight again , but i would still have to zoom in on EVERY page , but since none of my Bookmarks were in the profile , i did not feel like looking at every site i frequent , i just switched profiles back to default and came back here , and went to Craigslist again and it was back to diagonal

So what do i do now ??

Modified by JimDirt

more options

Could you paste a list of your modified preferences (in your normal profile)? The easiest way is to select and copy the table under "Important Modified Preferences" on this page (either):

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Many of the rows usually relate to printer settings, which are not relevant and can be deleted. If you want to remove lines relating to your home page or other things that look like sensitive information, you could do that to.

Maybe we'll be able to spot something that could cause this disproportion problem.

more options

If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

  1. 1
  2. 2