Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some forms cannot be completed in Firefox and require swith to ie tab.

  • 12 replies
  • 3 have this problem
  • 1308 views
  • Last reply by PHChat

more options

For some major sites (example Familysearch.org) query fields do not work in "native" Firefox but are OK if I switch to IE Tab. I am not sure but sites may be using some sort of Adobe forms

Chosen solution

Fire IE (FireIE, Enhanced IE) {web link} Embeds Internet Explorer(IE) to use the powerful Firefox add-ons. Not only an enhanced IE Tab, but also an enhanced Internet Explorer with Adblock Plus and FireGestures support. Switch to the IE engine in one click and dismiss your IE.

Read this answer in context 👍 0

All Replies (12)

more options

If you think they are PDF forms, I suggest switching from the built-in PDF viewer to Adobe's PDF plug-in if you haven't already tried that.

This article has the steps: View PDF files in Firefox or choose another viewer.

Any difference?

more options

Sorry for the misunderstanding. It is not pdfs that cause the problem. I think the sites that casue problems are using Flash or similar to create input fields and display data.

more options

Please post the link you are having trouble with.

more options

This is the most common variation of the problem. https://familysearch.org/search/record/results?count=20&query=%2Bgivenname%3Awilliam~%20%2Bsurname%3Awestwood~%20%2Brecord_country%3AEngland%20%2Brecord_subcountry%3AEngland%2CStaffordshire&birth_year1=1800~1830 On the left are some filters that only seem to allow one selection that cannot be removed or a lower level selected. They work fine in IE. On other sites I have had problems entering data in forms. I can't remember which but they were mainstream sites with sophisticated web.

more options

Chosen Solution

Fire IE (FireIE, Enhanced IE) {web link} Embeds Internet Explorer(IE) to use the powerful Firefox add-ons. Not only an enhanced IE Tab, but also an enhanced Internet Explorer with Adblock Plus and FireGestures support. Switch to the IE engine in one click and dismiss your IE.

more options

It seams to work for me. Is this what you get ?

more options

It's possible that one of your ad blockers or privacy-related extensions is affecting the page. One way to rule out possible interference by extensions is to test the page in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

Problem disappears in safe mode and (this may be my imagination) the response and rendering time has speeded up. "Security" Add-ons are AdBlock plus 2.6.6 Ads Removal 1.0.0 Advance System Care Surfing Protection 1.0.0. Ghostery 5.4.1 AVG site safety plugin 18.0.5.292

Thanks

more options

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

more options

Do you have any suggestions which add-ons are known to cause this type of problem. I am very reluctant to disable any security feature and I don't want to switch to IE.

more options

I haven't tried it recently, but I think Ghostery can show you a list of what it is blocking and may let you unblock them. Can you find a toolbar button or in-page icon for that?

Adblock Plus is pretty comprehensive, so Ads Removal may be unnecessary and I would try disabling that one in general.

more options

I disabled Ads Removal with no change. Ghostery was blocking 4 sites so I tried unblocking them in turn. Problem seems to be caused by Adobe Tagmanager being blocked.I will try running for a few days with Tagmanager unblocked.

Thanks