Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Gmail and Firefox 34.0.5

  • 18 replies
  • 13 have this problem
  • 1167 views
  • Last reply by nongmin

more options

Since installing Firefox 34.0.5, I have only been able to use basic HTML in gmail. This type of issue has never happened with prior versions of Firefox. I run Win7, fully updated. I have checked for viruses (ESET Security, including root directory), and malware (Malwarebytes, root search also). I use a VPN service from China (Express VPN), which I have also separately checked for viruses and malware.

The similar topics referred me to "about:config", but there I cannot reset -- that function is not work for any of the useragent files. There are four such files....all "default" status, boolean, boolean, string and boolean. I could not paste the screen shot here (sorry).

Can anyone help with this? I really don't want to switch browsers (been faithful to Firefox since dirt) or email.

Many thanks.

Best regards,

Michael

Chosen solution

Thank cor-el --

As it turns out, I did not need to experiment with disabling DNT for gmail -- besides, gmail has no trackers anyway. And yes, for many years, Private Browsing is my approach -- both for FF at home and IE at work. Just seems more appropriate somehow!

The problem seems to have dissipated today. Maybe the various Windows update (21 or so, many security related), maybe changing the VPN protocol, maybe the GFW (Great Fire Wall - yes, I am in China) has relaxed itself a bit (including the scope of DPI deployment), or maybe a combination of all three? Still mysterious, but I'm glad to have gmail back!

Thanks for you assistance, and once again, thanks to Philipp as well.

Best regards,

Michael

Read this answer in context 👍 0

All Replies (18)

more options

hello michael, does it work when you access gmail through this link?: http://mail.google.com/mail?nocheckbrowser

maybe your vpn is interfering with the useragent string that your browser is sending out somehow...

more options

Hi Phiipp --

Thanks for the tip -- but the same problem happens using that gmail link as well (just tried). And the VPN connection has always worked well with gmail until FF 34.0.5...and the VPN connection still works well with other website. Finally, the DNS settings are for Google. I come back to perhaps there's an issue with FF 34.0.5?

Any and all other ideas welcome!

Best regards,

Michael

more options

does it make any difference clear the cache & cookies from google.com and reload the page?

more options

Hi again -- and unfortunately, no, that has not helped one iota. I always clear cache and everything before exiting, and just did so now -- still can't load gmail other than in basic HTML.

Thanks for following up so promptly.

Best regards,

Michael

more options

could you copy and paste the results from the useragent check at http://browserspy.dk/useragent.php here into a forum reply?

more options

Here's the results from the user agent text link:

Test Result UserAgent from header Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0

User Agent from JavaScript Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0

Browser string Mozilla/Netscape 6.x

Operating System Microsoft Windows 7

Browser name Yes - version firefox

Browser version Yes - version 34

Does that offer any insights?

Many thanks.

Best regards,

Michael

more options

no that just looks like it's supposed to be - so it won't be the source of the issue.

can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon (donottrackme?) is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Hi --

Safe mode seems to work -- thanks for that suggestion. It's still a wee bit odd, though -- I've had the same add-ons running for a long, long time, including (donottrackme). Maybe it's the one that is having issues with FF 34.0.5?

Thanks so much for your help, Philipp!

It is now 12:30 am here, so I think I need to head toward horizontal. If there are further problems, I'll let you know my tomorrow.

Best regards,

Michael

more options

In other words, I'd still like to use at least the other add-ons...I suppose I will need to disable one by one to see which may be causing the trouble, right?

Best regards,

Michael

more options

Try to disable DNT for that website and also make sure that you aren't blocking cookies. I see that you are in permanent Private Browsing mode, so all cookies are already session cookies and expire automatically.

more options

Chosen Solution

Thank cor-el --

As it turns out, I did not need to experiment with disabling DNT for gmail -- besides, gmail has no trackers anyway. And yes, for many years, Private Browsing is my approach -- both for FF at home and IE at work. Just seems more appropriate somehow!

The problem seems to have dissipated today. Maybe the various Windows update (21 or so, many security related), maybe changing the VPN protocol, maybe the GFW (Great Fire Wall - yes, I am in China) has relaxed itself a bit (including the scope of DPI deployment), or maybe a combination of all three? Still mysterious, but I'm glad to have gmail back!

Thanks for you assistance, and once again, thanks to Philipp as well.

Best regards,

Michael

more options

I have this problem with Firefox, too. I have put off going back to IE for a long time, having come to like Firefox very much, when it works. But, I think this is the last bug that I want to deal with :( Good-bye Mozilla. B

more options

Sorry, but this is no help...Tells me nothing if his Gmail just mysteriously started working....mine hasn't :(

more options

Hi borthober --

Yes, you are correct. Gmail started working mysteriously. But now we're back to the same old, same old. I've been on to my VPN service, and we've bend around the bush to see if that's causing a problem. Apparently not.

Is there anyone out there that has solved the gmail issues that started with FF 34.0.5, please?

Many thanks.

Best regard,

Michael

more options

Hello Everyone,

I am having this very same problem. Though for me it is happening in the web mail server for 1and1 when I log in using Firefox 34.0.5. Add this to the Flash problem. Have been using FF for years. This is the worst update that I've experienced. Sorry I have not tried to solve this particular problem. With the issues I've been waiting for Mozilla to update this stinker.

more options

Hi, Michael, YES...the problem is solved for me, at least until they update. What makes my Gmail show up correctly, AND allows other sites to come in as they should (and not just a list, as if JavaScript wasn't working) is to disable my Simple Adblock. When I did this, everything was back to normal....except now my Adblock is disabled :( I guess when I go to other sites where I really need it, I can temporarily enable it. But....we shouldn't have to DO it this way... Hope this helps. B.

more options

Hey borthober,

I tried your solution and it worked for me. I was able to disable my 'ad block' just for the particular mail web page. Now I can respond in html or text.

Thanks, Joe

more options

Just to update this string -- disabling DoNotTrackMe seems to have worked, at least for now. I've been on to them about the issue as well -- and I hope that FF will be fixed soon, too. I am accustomed to seamless operations, and a certain degree of privacy. May have to switch to TOR?

Best regards,

Michael