Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Why is the latest version of Firefox 33.0.2 using 100% of my CPU?

  • 4 replies
  • 2 have this problem
  • Last reply by Wayne Mery

more options

Just like the last update to Thunderbird, with no changes on my system, the latest version of Firefox uses 100% of my CPU where it didn't before. I've run every test, disabled my anti-virus, run in safe mode and it makes no difference.

Since there was no useful answers when I posted about the TB problem, I doubt there will be any here.

Sorry Mozilla, but you're about to lose my support. I already moved away from Thunderbird. Now that FF has the same problem, I'm about to switch my browser to Chrome, even though it is not as good.

All Replies (4)

more options

Hello DrStrange You can try to disable hardware acceleration in Firefox.

   Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" 

You need to close and restart Firefox after toggling this setting.
more options

I already have hardware acceleration in FF unchecked, so that doesn't help.

more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options
  1. 1 install flashblock addon
  2. 2 see and post the URL of a short profile