X
Tap here to go to the mobile version of the site.

Support Forum

How Can I get rid of Yahoo home page? Changing home page doesn't work.

Posted

A week or two ago, Yahoo started coming up as my home page. No matter how many times I change it back to Bing, every time I bring up Firefox, there is Yahoo as the home page. Changing it back to Bing and clicking ok is not working. I'm getting a little frustrated with this. How do I get rid of Yahoo coming up as my home page when I did not even ask for it?

Thank you for your time and consideration.

Sincerely, cbrsarah

A week or two ago, Yahoo started coming up as my home page. No matter how many times I change it back to Bing, every time I bring up Firefox, there is Yahoo as the home page. Changing it back to Bing and clicking ok is not working. I'm getting a little frustrated with this. How do I get rid of Yahoo coming up as my home page when I did not even ask for it? Thank you for your time and consideration. Sincerely, cbrsarah

Chosen solution

Does the home page change when you check that in "Options > General > Startup" or is this a problem with the page that opens when you start Firefox? For the latter you can check the target field in the Firefox desktop shortcut.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

If you do not keep changes after a restart or otherwise have problems with preferences, see:


Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • npAPI Plugin
  • Shockwave Flash 14.0 r0
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • This plug-in enables downloading of HTML5 videos
  • This plug-in enables downloading of Flash videos
  • This plug-in enables downloading with the Download This Video button
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160817 answers

Chosen Solution

Does the home page change when you check that in "Options > General > Startup" or is this a problem with the page that opens when you start Firefox? For the latter you can check the target field in the Firefox desktop shortcut.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

If you do not keep changes after a restart or otherwise have problems with preferences, see:


Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Does the home page change when you check that in "Options > General > Startup" or is this a problem with the page that opens when you start Firefox? For the latter you can check the target field in the Firefox desktop shortcut. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved ---- Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked
johnbarr 0 solutions 9 answers

? SOLUTION ? I wasted three hours last night trying to sget rid of the Yahoo home page. Just now I uninstalled Adobe Air and some superfluous unknown interloper with "hold" in its name; I had to restart after. When Windows restarted there was a notification that there was a new version of Firefox, which I installed.

One of these three items presumably caused the Yahoo! glitch.

? SOLUTION ? I wasted three hours last night trying to sget rid of the Yahoo home page. Just now I uninstalled Adobe Air and some superfluous unknown interloper with "hold" in its name; I had to restart after. When Windows restarted there was a notification that there was a new version of Firefox, which I installed. One of these three items presumably caused the Yahoo! glitch.
johnbarr 0 solutions 9 answers

One other thing I did: I did not make Firefox my default browser. (I haven't yet tried to make it my default browser, so I don't know if that might make the problem re-appear.)

One other thing I did: I did not make Firefox my default browser. (I haven't yet tried to make it my default browser, so I don't know if that might make the problem re-appear.)
jscher2000
  • Top 10 Contributor
8893 solutions 72761 answers

Hi johnbarr, I noticed you posted in two different threads, but you were not very specific about what you have tried so far.

Firefox 34 was released on Dec. 1, 2014, so unless you have been waiting to update, it's very likely that you already had it and that the prompt to update was bogus.

Have you already run the suggested malware scans (see earlier posts)?

Have you tried ruling out a bad extension by testing in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Hi johnbarr, I noticed you posted in two different threads, but you were not very specific about what you have tried so far. Firefox 34 was released on Dec. 1, 2014, so unless you have been waiting to update, it's very likely that you already had it and that the prompt to update was bogus. Have you already run the suggested malware scans (see earlier posts)? Have you tried ruling out a bad extension by testing in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?
johnbarr 0 solutions 9 answers

I spent three hours trying to get rid of the Yahoo! homepage before I gave up and uninstalled Firefox and started full use of Internet Explorer as my browser. Included in my attempts were the three normal ways of specifying my own home page (Outlook) in various combinations. Exactly what did others do that solved this problem? Your list of things to try was so long that I would still be trying things if I hadn't given up.

My Firefox version is 34.05.

Later, after my wife complained about not having Firefox, I re-installed it. It still had the hijacking bug. Then I did four things, one of which cured the problem: 1) uninstalled Adobe Air; 2) uninstalled a program which had "hold" somewhere in its name; 3) got a message about an upgrade to Mozilla or Firefox being available, 4) So I followed the link, installing Firefox. I declined everything except Firefox and did NOT make Firefox my default browser.

Result: no more Yahoo! home page.

I will try your safe mode suggestion if the problem returns. I did try safe mode once, but did not have the detailed instructions you gave above.

I spent three hours trying to get rid of the Yahoo! homepage before I gave up and uninstalled Firefox and started full use of Internet Explorer as my browser. Included in my attempts were the three normal ways of specifying my own home page (Outlook) in various combinations. Exactly what did others do that solved this problem? Your list of things to try was so long that I would still be trying things if I hadn't given up. My Firefox version is 34.05. Later, after my wife complained about not having Firefox, I re-installed it. It still had the hijacking bug. Then I did four things, one of which cured the problem: 1) uninstalled Adobe Air; 2) uninstalled a program which had "hold" somewhere in its name; 3) got a message about an upgrade to Mozilla or Firefox being available, 4) So I followed the link, installing Firefox. I declined everything except Firefox and did NOT make Firefox my default browser. Result: no more Yahoo! home page. I will try your safe mode suggestion if the problem returns. I did try safe mode once, but did not have the detailed instructions you gave above.
jscher2000
  • Top 10 Contributor
8893 solutions 72761 answers

Hi johnbarr, I didn't realize you had already solved the problem before you posted. Thanks for reporting back.

Hi johnbarr, I didn't realize you had already solved the problem before you posted. Thanks for reporting back.
johnbarr 0 solutions 9 answers

Helpful Reply

It isn't a solution. A solution is when everyone knows 1) the source of the problem, and 2) the specific fix, and 3) then Firefox makes it impossible to hijack my home page.

It isn't a solution. A solution is when everyone knows 1) the source of the problem, and 2) the specific fix, and 3) then Firefox makes it impossible to hijack my home page.
jscher2000
  • Top 10 Contributor
8893 solutions 72761 answers

Hi johnbarr, it's unlikely I can determine #1 and #2 at this point since the problem has gone away. If it recurs, I'll have some suggestions for tracking it down.

As for #3:

  • Firefox allows add-ons to override your home page setting. I don't think that is likely to be blocked because in some cases, that is useful.
  • Windows also allows third party processes to modify your program shortcuts to launch a web address or document. Firefox will faithfully load that instead of your home page. But in case of this kind of hijack, the Home icon or Alt+Home keyboard shortcut usually still work normally.
Hi johnbarr, it's unlikely I can determine #1 and #2 at this point since the problem has gone away. If it recurs, I'll have some suggestions for tracking it down. As for #3: * Firefox allows add-ons to override your home page setting. I don't think that is likely to be blocked because in some cases, that is useful. * Windows also allows third party processes to modify your program shortcuts to launch a web address or document. Firefox will faithfully load that instead of your home page. But in case of this kind of hijack, the Home icon or Alt+Home keyboard shortcut usually still work normally.
johnbarr 0 solutions 9 answers

RE: "Firefox allows add-ons to override your home page setting. I don't think that is likely to be blocked because in some cases, that is useful."

Is it a Product Improvement or a Bug Fix to give me the option to have Firefox not allow add-ons to override my home page setting?

I don't understand much about add-ons. Perhaps Firefox should keep and make available a table of add-ons together with the things those add-ons do to Firefox as an environment.

RE: "Firefox allows add-ons to override your home page setting. I don't think that is likely to be blocked because in some cases, that is useful." Is it a Product Improvement or a Bug Fix to give me the option to have Firefox not allow add-ons to override my home page setting? I don't understand much about add-ons. Perhaps Firefox should keep and make available a table of add-ons together with the things those add-ons do to Firefox as an environment.
jscher2000
  • Top 10 Contributor
8893 solutions 72761 answers

Helpful Reply

Hi johnbarr, please start a new question for further discussion since the original poster has marked this one as solved.

For more information on viewing and managing your add-ons in Firefox, see:

Hi johnbarr, please start a new question for further discussion since the original poster has marked this one as solved. For more information on viewing and managing your add-ons in Firefox, see: * [[Find and install add-ons to add features to Firefox]] (you'll notice there are several categories of add-ons on the page, the most important are Plugins and Extensions)
johnbarr 0 solutions 9 answers

Thank you for the support. I expect studying "add-ons" will be helpful to me.

Thank you for the support. I expect studying "add-ons" will be helpful to me.
johnbarr 0 solutions 9 answers

Ps: The hijacking of my home page by Yahoo! has not yet happened again.

Ps: The hijacking of my home page by Yahoo! has not yet happened again.